locked
Initial Boot after intall fails on crcdisk.sys

    Question

  • After initial install, the safe mode boot options comes up.

    • Choosing Start normally shows a blue screen, and restarts.
    • Choosing any safe mode starts listing all the drivers beeing loaded and stops at crcdisk.sys

    It is a clean install, on a USB HDD any ideas?

    I also had, before, the 80070017 error and solved installing from a slower DVD USB Drive.


    Thanks in advance

    Tuesday, June 27, 2006 10:30 PM

Answers

  • Install Vista to USB HD is not currently supported.

    You should install it to IDE HD or SATA HD.

    Beware of Nforce chipset, some guys in here report you may get problem on that.

    Wednesday, June 28, 2006 9:19 AM

All replies

  • Two things:

    1) Vista is not currently supporting booting to a USB drive.  I have yet to see one work.  Thats not to say it won't happen, but currently it is not supported.  Minimum specs for h/d is IDE 7200RPM, 2mb cache, and 100MBps or greater transfer rate, 20gig free.  Recommended is SATA w/ 8mb cache and 40GB free and Native Command Queuing (NCQ)

    2) Error 80070017 is usually a bad DVD or an acting up DVD reader.

     

    Tuesday, June 27, 2006 10:56 PM
  • Install Vista to USB HD is not currently supported.

    You should install it to IDE HD or SATA HD.

    Beware of Nforce chipset, some guys in here report you may get problem on that.

    Wednesday, June 28, 2006 9:19 AM

  •  Duane Vista Support wrote:

    ... Minimum specs for h/d is IDE 7200RPM, 2mb cache, and 100MBps or greater transfer rate, 20gig free...



    So I have another USB IDE at 7200RPM... Will trying on it be a time waste?

    Wednesday, June 28, 2006 9:26 AM
  • I moved this thread to a more appropriate forum (Setup). Hopefully, you'll get more help for this installation failure issue there.
    Thursday, June 29, 2006 10:00 PM
  • Last try was on onther USB HDD at 7200 RPM, but did not Succed.

    I am not plannig to change my HDD in my laptop, so, for now I will use Vista under a Virtual Machine, which let me to use my USB HDD.

     

    Tuesday, July 04, 2006 8:40 AM
  • I have SATA HDD and have the same problem. Not USB!!! Please help.
    Thursday, February 01, 2007 6:10 AM
  • This is what I did to bypass the blue screen.

    Restart your computer and choose to edit boot options. You will see a screen which shows default windows boot options: /noexecute=optin. After optin, add /debug command and press esc. (There needs to be a space between optin and /debug.)

    It should continue to boot. Hope this helps.

     

    Saturday, February 03, 2007 8:55 AM
  • I got mine to work after the crcdisk.sys kept failing by disabling usb keyboard support on my motherboard - please let me know if this worked for you too.
    Sunday, February 04, 2007 6:28 PM
  • I've solved the problem. I just deleted sptd.sys from <WINDOWS>\System32\Drivers\.

    This driver was installed by DAEMON Tools. Vista fails to load if you are trying to install it over XP with old DAEMON Tools installed. And Vista Upgrade advisor knows nothing about it. To solve the problem download and install latest DAEMON Tools before upgrading your OS.

    OR (if you are already in progress of Vista installation and have this problem) load from your bootable Windows Vista CD and choose to restore. Tnen choose 'other options' and go to console. Then go to <WINDOWS>\System32\Drivers\ and delete sptd.sys. Now restart. Vista will load fine after it and continue installation.

    Monday, February 05, 2007 5:21 AM
  • I was checking all kinds of help on the same kind of issue I had.  What happened with me was I first attempted the shrinking of the single partition of my HDD.  I then tried to install mandriva 2007 on the remaining empty area of the hdd.  It did not work at all as it kept giving me some kind of an error (By the way after the shrink I never booted into vista).  Since the mandriva failed (most likely due to the smaller size of the HDD (6 GB), I tried to get back into Vista and it got stuck at gving me the black death screen.  I later restarted to try the safe mode and nothing worked.  I tried using the Vista (RC1 - thats what I installed) CD to repair it but no good, as that also gave me the death screen.  After like 20 attempts, I tried the Windows XP pro CD and tried the repair option.  THis time it got into the C drive but wouldnt log me in as admin even thought I entered my password right.  I then rebooted and tried the Vista safe mode again and this time, Wow it just booted right up.  Try this option friends and see if it helps.
    Sunday, February 11, 2007 6:34 AM
  • THANK YOU Amate !!!!! HOURS AFTER HOURS!!! THANK YOU...NOW TO GET BACK TO MY 64% COMPLETE AND WAIT AND SEE WHATS NEXT VISTA HAS IN STORE FOR ME.

    VISTA BOOT LOOP

    CHECK OUT AMATE'S POST

    delete sptd.sys

    delete sptd.sy

    delete sptd.sys

    delete sptd.sys

    Wednesday, February 28, 2007 11:53 AM
  • ok, deleting that file helped me get to the part after installation, when it says it's preparing vista. But then....crashes.

    I heard it's an Nforce4 Driver problem, but still not sure. Anyone got any other idea?
    Friday, March 02, 2007 9:05 PM
  • I had the same issue, removed the sptd.sys (I had virtual daemon installed) file by using a NTFS boot disk then setup continued.
    Friday, March 09, 2007 10:49 PM
  • I to am having the same problem where my laptop seems to be caught in a loop after loading crcdisk.sys.

    I loaded a NTFS boot CD and looked for sptd.sys, it was not there.

    I have also tried twice to use the several hour recovery process on the Vista CD.

    Just before I could not boot for the first time I got the Blue screen of death.

    Friday, March 16, 2007 2:07 AM
  • I managed to fix mine. I took out some ram and it went throught the whole installation fine.
    Currently vista is running on 512mb which actually aint to bad.

    I don't really understand, as xp boots fine with it in.
    Friday, March 16, 2007 3:07 AM
  • Not quite the same error, but some similar behaviour here:

    I installed Vista Business edition on the same hard disk as a Windows XP installation, however, in a different partition. After installing Vista, I can't boot into Windows XP despite having the two OS'es installed on different partitions of the disk.

    Attempting to boot Windows XP in Safe Mode fails on crcdisk.sys. Trying to boot normally just gives a black screen and no disk activity; and Vista boots fine.

    I suspected this might be a flawed partition reference in boot.ini for Windows XP, however, changing the values yielded no results (the system complained that hal.dll was not present.)

    I never installed Daemon Tools under Windows XP, but I used "Magic ISO Virtual CD/DVD-ROM" instead, so there is no sptd.sys in my \System32 folder.

    Any ideas?
    Friday, March 16, 2007 11:48 PM
  •  Amate wrote:

    I've solved the problem. I just deleted sptd.sys from <WINDOWS>\System32\Drivers\.

    This driver was installed by DAEMON Tools. Vista fails to load if you are trying to install it over XP with old DAEMON Tools installed. And Vista Upgrade advisor knows nothing about it. To solve the problem download and install latest DAEMON Tools before upgrading your OS.

    OR (if you are already in progress of Vista installation and have this problem) load from your bootable Windows Vista CD and choose to restore. Tnen choose 'other options' and go to console. Then go to <WINDOWS>\System32\Drivers\ and delete sptd.sys. Now restart. Vista will load fine after it and continue installation.

     

    Great Amate, it's working now! Tnx.

    Sunday, May 27, 2007 4:24 AM
  • Thanks Amate you are an absolute legend! .... Deleted sptd.sys and it worked a treat!
    Thursday, June 14, 2007 10:22 AM
  • Removing 2G of RAM got me past the "completing installation" hangup. I am currently running on 2G. Apparently, there is some issue with 4G RAM and Vista.

     

    After 4 failing install attempts, a call to MS support (they wanted 59 USD to talk to me; now I push the Linux OS for real). Don't think I must pay Microsoft more than already I do pay. Pay them over 1,000 USD this week for Windows and they can't give me a two-minute solution without a charge?

     

    The anti-christ has appeared with the Vatican, the secret society of greed mongers. INto to lake of fire they were cast. 

     

    Will hold off on purchasing more Vista for a long while. I build and sell about 5 computers a week. Every time it is something different with Vista.

     

    Not all my PCs I build are the same, because people want different things.

     

    Thanks to those folks that offered their help here.

     

    It is my prayer that Microsoft would lose and Linux and Mac would win. Amen. 

     

    Tuesday, June 19, 2007 3:33 AM
  • talk about strange.

    could not get past load screen (same as everyone - crcdisk.sys error)
    could not boot from dvd for same reason
    opened box
    unplugged sata hdd (sata is the issue for me - just tried an additional add-on card)
    booted from os dvd (vista)
    tried a recovery with no hdd attached
    it failed, rebooted with sata drive plugged in, suddenly worked.

    proves that if you are not a techie, don't install hardware on a vista machine...

    Wednesday, July 04, 2007 3:17 PM
  • Looked for sptd.sys and it was not there, disabled usb keyboard and mouse support, took out a stick of ram and it still freezes at crcdisk, but here is the kicker... when I don't run safe mode, vista boots just fine.
    Monday, July 16, 2007 2:46 AM
  • This is on Vista Ultimate 32:

     

    I had this same problem, but it turned out to be my RAID volumes. I tried at first to reboot in safe mode, but it froze after loading crdisk.sys.

     

    I took these steps (not recommended unless you know what you're doing) and am happily watching the volumes rebuild:

     

    1. Turned off machine (duh)
    2. Unplugged one of my hard drives. (If this didn't work with one, I would've reversed the attempt on the other drive)
    3. Rebooted into safe mode (this told me that the one I unplugged must have been degraded)
    4. Installed Intel Matrix Storage Manager (Guide and download link can be found at http://download.intel.com/support/chipsets/imsm/sb/manual70.pdf)
    5. Replugged the bad drive and rebooted.
    6. On reboot, the RAID came up as degraded, but upon Vista boot the storage manager ap kicked in and began the rebuild process.

    Happy days! My rig and I breath a sigh of relief.

     

    Coop's "Hot $#!+ Rig":

    • Intel Core2 Quad 2.4Ghz
    • 2046MB mem
    • EVGA 8800GTS (1051MB total mem)
    • Intel D975XBX2 Board

     

    Tuesday, September 18, 2007 3:24 AM
  • Test systems -

    1. EVGA 680i nforce.

    2. ASUS Striker Extreme.

     

    Note: Systems were tested with various hard drives, memory, and video configurations.

     

    I chose these two motherboards because everybody has problems with them and they are really getting a bad rap. Both boards are fantastic but they are not for the average user and cannot be consider in a class with any production PC. These boards are also the most likely to cause the problems you've encountered so it saved me time trying to recreate the situation.   

     

    The idea that it is a hard drive problem is probably the most correct answer. The reality is that it is the hard drive cache failing to commit fully prior to shutdown/restart after install or update.

     

    Since you really can't disable the cache during the build process, the only other thing you can do is slow down your memory in BIOS. I tested under numerous conditions and found that the best way to stop the problem during the build was to drop the memory speed down to 400mhz. Once that was done I never got a blue screen again, (even with 4g's). This works because you effectively slow down the entire system enough dump the memory and give the drives time to commit their onboard cache.

     

    During the build, when you are prompted to enable automatic updates, say no. Then when the build completes, go into disk manager and disable the hard drive caching on your boot drive. You can then re-enable automatic updates and safely update your Vista install.

     

    Once you have all of your updates, you can go back into CMOS and set your memory speed back to no more than 800mhz even if you have 1066mhz like Corsair Dominator, etc. Whatever you do never enable disk caching again.

     

    I did run RAID 0 on two drives with no problem but as soon as I added the third drive I crashed after the updates. The 10,000 rpm WD Raptors went as far as 4 drives before a crash which furthers the validity of this workaround. Raid 1 will definitely frag and RAID 5 should never be deployed with caching enabled. The latter is standard procedure for servers and holds true here also.

     

    Wait, there's more..

     

    This will fix the 4gb problem also except but there is also another little gotcha. If you are running 4 sticks of DDR2 then you have to decrease your memory speed by at least one full step. If you have 800mhz memory drop it to 667 and so on. This is because their is an inherent latency between the memory slots and you need to compensate for it or you will have nothing but problems. This will also overcome problems with softboots not posting and video problems on startup. The way to do this is to only install two sticks at startup and put them in the second set of memory slots not the first set.

    You can then start the system with the default settings and change the memory speed. Once you've made the changes you can install the remaining memory and it should work fine.

     

    Best of luck to all, I hope this cures you woes..

    Steve Schefer

    30 year IT Vet

    Sunday, October 21, 2007 5:50 AM
  • Thank Steve Schefer  for the comprehensive testing, and also thank you all that contributed with suggestions.

    I went through all the suggestions one at a time. Including the ones from a parallel chain on the same issue but on a Toshiba. I did not think deleting the pcmcia.sys would make ant difference, and as it’s a desktop I did not care.

     

    This was an UPGRADE to Vista Ultimat(ly a pain in the A***) with new HARDWARE.

    My set up is / was

    Abit KN9_SLI

    SATA dvd drive ( Lg)

    4 gig in 2 cards PC6400 DDR2 Patriot memory.

    AMD 6400 X2

    Promise Tech Tx 2000 sata raid

    4 250 sata Maxtor

    1 IDE 160 gig ( containing my XP install )

    2 x EVGA 6800 SLI

     

    That’s how I started.

    When the issue first started I checked and upgraded the BIOS , mine was at 18 newest was at 21.

    The next thing to go was one of the evga 6800 ( no SLI )

    Then I took out the Promise STATA raid.

    Then I tried deleting the files listed in the chains.

    I was just about to take out the SATA DVD but tried reducing the memory to 2 GIG first.

     

     I did not have the sptd.sys so could not delete it. I disabled the USB mouse and keyboard support, did not work for me.

    The last posting, although the most painful for me, worked. I just spent $200 on PC6400 memory, 2 x 2gig cards. And the thought of taking one out was abhorrent. But desperate times etc. And it worked. I completed the post install boot without dying on the crcdisk.sys.

    Again thanks. I will get the system stable then put the memory back, and re post to let you know if it stays up.

    Although it is a delight to see so many people that are willing to help, I must agree with “timboe” who also posted on this chain.

    How can Microsoft justify the price of this software when it is unwilling to provide support to its customers, even for 1 hours without asking for a credit card number. I spent 8 hours fighting this with several reinstalls repairs and general stripping stuff out of the machine, To finally get an answer, not from the people that took my money but from volunteer help community. That is defiantly abuse of privilege and power.

    But again, to you Mr Schefer and the rest of you willing savants.

    KEEP UP THE GOOD WORK.

     

    Thursday, October 25, 2007 1:37 AM
  • Did you manage to solve it? If so, I would love to know how. I have the same problem on my ASUS laptop - on reboot it hangs after the "Microsoft" logo, before the login screen; in safe mode it stops on "\Windows\system32\drivers\crcdisk.sys".

    I too had just installed MagicDisc. I tried to mount a .mds file, and explorer locked up straight away. I rebooted (had to press and hold power button), and now can't boot at all.

    Thanks
    Friday, October 26, 2007 7:30 PM
  • OK ADDENDUM….

    The solution got me past the initial issue of installing and updating with patches. But nothing else I tried worked for adding more than One 2 gig DDR module.

    I figured out eventually that it was not on the shutdown that he problem is being caused but on the startup. By switching memory modules I eventually got to the point where I found the issue accurse with 3 gig or more.

     

    So I looked on the WEB again with different search parameters and found the following.

     

    http://www.tomshardware.com/forum/245556-30-vista-blue-screen-p5n32-geil-4x1gb-6400-black-dragon

     

    Posted by.

    Scotteq

     

    Profile: enthusiast

     

    More informations

    Gender : Male

    posts :  204

    Joined :  Tue Aug 07, 2007

    Location : Nooo Joizey

    View his configuration

     

     Posted on 10-26-2007 at 03:41:18 PM  

    Firstly, if you have overclocked please set the CMOS back to the defaults.  If that doesn't solve anything, or you haven't overclocked, then take out 2 Gigs, and install the following update:

     

    http://support.microsoft.com/kb/929777/ 

     

    Boot with the 2 gigs still installed.  Then shut down and put the other two back in. 

     

     

    ---------------

    THEY WILL BE DRIVEN AWAY FOR A LONG DRAWN OUT FIGHT

    THE COUNTRYSIDE WILL BE MOST GRIEVOUSLY TROUBLED

    TOWN AND COUNTRYSIDE WILL HAVE GREATER STRUGGLE

    THROUGH OUTSOURCED TECH SUPPORT THEIR HEARTS SORELY TRIED - /S/  Nostradude

     

    Ignoring the over clocking, as I don’t do that. I downloaded the fix. Applied it (all with only 2 gig in place), then shut down and put in 4 gig. IT ALL WENT VERY WELL THANK YOU. 

    Hope this HELPS

     

    Friday, October 26, 2007 9:01 PM
  • PPS

    BE AWARE....

    Because I "ACTIVATED" Vista with 2 gig. when I added the extra 2 gig , I went back on the clock for re activation..

    I have 3 days or it does something bad ( What ! ), It's a legal copy but because I activated on line once I cannot do it again that way. I have to call the activation hot line and talk to the nice lady in Bombay........

    Just to bl***** lovely for words.

    Thank you BIll. If your people put as much time into BUG  releases as they do in licensing , I think the product would have been out sooner and in better shape!!!!!!!!

     

    Friday, October 26, 2007 9:19 PM
  • Actually,  it is probably only asking you to re-activate after the hardware change.  I wouldn't have thought a RAM change would have done it though.  If you have changed motherboards or hard drives (maybe due to firmware update on motherboard) then it will ask you to re-activate.

     

     

    Thursday, November 01, 2007 3:20 AM
  •  

    For those who have a Toshiba Satellite M45-S265:

    1. Install Vista
    2. Wait until 1st reboot (obviously it will get halted with no disk activity for a long time)
    3. Reboot again, Press F8 and select Safe Mode
       Most probably, while loading drivers, the computer with be stuck at crcdisk.sys
       Reason:
            Vista is trying to load drivers which don't work in Vista
       Failing drivers may be:
     PCMCIA, 1394 (firewire, Texas Instruments)
            (Did you ever use them? I never did)
       Solution:
    4. Reboot and load from your bootable Windows Vista CD and choose to restore.
       Tnen choose 'other options' and go to console.
       Then do this:

     C:
     cd \windows
     del *pcmcia*.* /s/p
     del *1394*.* /s/p

       This will get rid of everything related to pcmcia and 1394
       including drivers, INF files .....
     
    5. Restart and enjoy!!!

    Notes:

    At first, I only did:   del *pcmcia*.* /s/p   but Vista didn't work.

    I am not sure what will happen if next time I reinstall Vista
    and only do:  del *1394*.* /s/p

    This method may work for other models of Toshiba or even other brands of Desktop/Noteboos

     

    Thursday, November 01, 2007 5:06 PM
  • Just to let you know that I recently reinstalled Vista.

    This time I only deleted the 1394 files and I got Vista working fine

    Thursday, December 06, 2007 11:31 PM
  • ****SOLUTION******
    Here is the solution to the crcdisk.sys problem many of you (including me) are having!!!


    If you have 4gb of ram installed and are trying to install windows x64, THAT IS THE PROBLEM

    The windows vista or xp 64 bit Installation CD does NOT support more than 2gb of ram!
    If you have 3 or 4gb of ram you will get the blue screen of deathm or in safe mode it gets stuck @ crcdisk.sys

    Remove the extra sticks and install windows with 2gb of ram.
    Once installed, run windows update, one of the patches (dont remember of the top of my head) is a patch to allow more windows to boot with more than 2gb of ram

    Thats it, just that simple.  It's been buggin me for 3 days straight, i was ready to rma my evga 680i A1 motherboard, but i finally ran into a irelevent thread that mentioned this.  So yeah, I just saved u a couple days of frustration, so what.  Thank me by replyin with ur comments.
    PEACE!!
    Saturday, January 05, 2008 7:56 AM
  • Yeah, spent the better part of 13 hours on this one! My issue was it was locking up during Vista Ultimate install at the "Completing Installation" screen. Safe mode would stop at CRDISK.SYS.

    I am running:
    Gigabyte GA-P35-DS3p
    C2D E6730
    4GB
    Seagate 320GB 7200rpm SATA

    I installed Vista successfully on this box the other day when I first threw it together, but that was with a different HDD and I forgot to enable the AHCI settings in the bios.

    Decided to start from scratch with the new SATA2 drive, this time enabling AHCI in bios before installing Vista. This is where I ran into problems! No matter what other settings I used in bios, it would always lock up at the "completing installation" screen. I knew the answer was to turn off AHCI in bios all along, but didn't want to take a disk performance hit, so I tried every fix under the sun! (ok, I admit that I did not try taking a stick of RAM out to bring it down to 2GB).

    Finally, just before I went insane, I disabled AHCI in bios and re-ran vista install. What do you know, it works just fine, even with 4GB ram installed!

    I will now update the disk controller drivers in Vista, install all updates, then try turning AHCI back in in bios and see if it boots ok.

    Hope this helps!

    Anthony.

    P.S. Oh, thanks Dziki for your suggestion. May work for some, but 4gb works fine for me. AHCI was the thorn in my side!
    Saturday, January 05, 2008 12:59 PM
  • Hi borosa,

    I seem to have exactly the same problem

    I am running:

    ASUS VGA EN8800GT TOP/G/HTDP/512M
    INTEL CORE 2 QUAD CPU Q6600 2.4GHZ BOX
    ASUS M/B P5E3 DELUXE WiFi S775, X38, CF, GL
    2 x GB RAM. KVR1066D3N7/1G 1066MHz DDR3
    SEAGATE ST3250410AS HDD 250GB/16MBc/SATA
    SEAGATE ST3160815AS HDD 160GB/8MBc/SATA
    MS Windows Vista Ultimate

    As long as the BIOS settings are IDE the whole thing works. Enabling AHCI in bios before installing Vista, it always locks up at the "completing installation" screen. Rebooting in safe mode results in the computer beeing sticking forever on crcdisk.sys.

    I have update the drivers in Vista and all the rest, update the mobo drivers - nothing helps

    So the problem is NOT the 4 GBs.

    Pelase let me know if you solve it.


    Monday, January 14, 2008 12:07 PM
  • I have this same issue,however, it is on the HP Pavillion internal SATA drive.  Occured after I used  the free Vista upgrade tht came with the PC (purchased in November)

    Any Ideas

    Thursday, April 03, 2008 6:27 PM
  • Hey just in case anyone is interested I have had the exact same problem,

    I'm running an ABIT Fatal1ty FP-IN9SLI board with a 3.2ghz dual core with 4GB 800MHz ram 640GB Striped Raid SATAII Array. Have been trying to install ultimate for days but kept resetting when attempting to boot for the first time after install. tried to boot in safe mode and system hung and then reset at crcdisk.sys line. All I did was to remove 2 sticks of ram to drop it down to 2gb, reinstalled on a brand new partition and hey presto, booted up first time. Will download all the updates and let you know how it goes

     

    Friday, April 04, 2008 9:17 PM
  • I had this problem as well. I read one post that said his system hung on the crcdisk.sys file, but after a delay of about 15 minutesw the PC booted normally. Sounded like a good option to me, so I tried it. After 25 minutes, I assumed there was no boot gonna happen.

    I had been having an issue with the DVD-ROM drive in this system, and I had noticed that the drive activity light would flash for extended periods of time for no reason - even though there was no disk in the drive.

    The activity light was again flashing maniacally while the PC was not booting at all - just a black screen with a cursor on it. I tried opening the DVD drive and it would not open. I grabbed my handy-dandy universal optical drive key and manually opened the drive.

    As soon as the drive opened - and I DO mean AS SOON AS - the system booted!

    Lesson learned, however, as soon as I get done with what I have to do this morning, I'm going back to XP. I love operating systems, and I like Microsoft. I've given Vista more than enough of a chance. All things considered, Vista is a lot like Dell. It sucks.
    Thursday, April 24, 2008 1:14 PM
  •  

    Hi I have the same problem. First my notebook cannot bootup. After trying to fix that with the HP Tech Support guy over the phone, got them to send me a new HD. But soon after, I can't even enter Safe Mode cos the crcdisk.sys error appeared.

     

    How do I recover my data if I can't enter windows at all???

    Friday, April 25, 2008 2:29 AM
  •  

    Hi everyone with this crcdisk.sys error.

     

    I had the same issue and after a lot of tech site reading came up with a solution that worked for me and may work for others.

     

    Firstly, I have gathered that it is not crcdisk.sys that fails but rather the file that loads after that in your setup.

    Windows safe mode loads drivers one at a time and shows the last driver to load that was successful. i.e. crcdisk.sys.

    [Still to find out how to determin which driver fails though  ]

    Secondly, end users need a way into recovery mode. Not allways available from Vista DVD.

    If you (still) have a copy of Windows XP on CD-ROM use that to enter recovery. Selecting repair install of windows, Press Enter on blank Password [seemingly Vista does not use default Admin EH! go figure].

     

    run chkdsk /r

    [If found that chkdsk /f did not work returning an invalid perameter error.]

    go make a coffee and toast, it takes a while.

     

    Remove disk from CD drive and reboot. everything was fine.

     

    If you don't still have an XP install CD laying arround (I didn't)

    You can download a copy of The Ultimate Boot Disk. from Here. [external link]

     

    Come to think of it it would be a great download for many reasons.

     

    two hours reading two hours download lots of coffee and toast.

    One working Vista Home Premium Install.

    Saturday, April 26, 2008 4:29 PM
  • I only can say you are the man thanks ...
    Friday, May 23, 2008 4:54 AM
  • Oh, my friggin God! It has been months and months and I have never found a solution to that ******** problem.

    I've searched the internet for solutions and came back with doo-doo. I've had a new Dell sitting in my sock-drawer because I could not load Vista.

     

    Changing the AHCI to ATA and pulling 2GB (of my 4GB) on my notebook fixed the problem in 10 minutes. Thank you for turning my paper-weight into a brick-house! I love you, man!!!

     

    PS This works for Vista x32, also!!!

    Monday, June 09, 2008 8:33 PM
  • It actually turned your expensive 4GB, AHCI PC into a 5 yr old 2GB and 10 yr old ATA box. I thought Vista was a new OS...

     

    This is an unacceptable solution, thank you very much. I am running it this way and it is REALLY slow loading anything (on expensive DDR3)

    Friday, June 13, 2008 11:40 AM
  • Can anyone please tell me how to do it with the "ultimate boot cd"? there is a menu: "mainboard tools, hard disk tools, filesystem tools, other tools... boot first hard disk..." what do i do here, as I don't have a copy of windows XP on cd-rom to enter recovery...

    Monday, June 23, 2008 7:00 PM
  • I would be very careful when using the Ultimate Boot CD with Vista, your better off using your original windows CD and PE-Builder to create a bootable CD which will allow you to access the file system and try one of the various solutions found in this article.

     

    I had the crcdisk.sys boot problem and it was probably caused by Windows Update installing an older version of my IDE drivers than the ones found on my manufacturers website. I used my bootable CD of Windows XP, ran a check disk and the laptop restarted fine!! I must be one of the lucky ones. My system is a Dell Vostro 1000, 2Gb Ram, Vista Home Basic.

     

    Although this might have worked for me, it probably wont work for many people. I've spent some time looking into this problem and so I have included 5 other solutions here that other people have used to their success, I haven't tried them yet but i hope they help someone:

     

    1)
     Goto the following folders and delete the following files
     C:\windows\system32\drivers\pcmcia.sys*
     C:\windows\system32\drivers\1394bus.sys
     C:\windows\system32\drivers\ohci1394.sys
     C:\windows\system32\driverstore\filerepository\pcmcia.infblablabla*
     C:\windows\system32\driverstore\filerepository\1394.infblablabla
     C:\windows\system32\driverstore\filerepository\sdbus.infblablabla*
     C:\windows\inf\sdbus.inf*
     C:\windows\inf\sdbus.PNF*

    2)
    Restart your computer and choose to edit boot options. You will see a screen which shows default windows boot options: /noexecute=optin. After optin, add /debug command and press esc. (There needs to be a space between optin and /debug.)

    3)
    Disable USB keyboard support in the BIOS(Only do this if you are not reliant on a USB Keyboard, otherwise you will lose the use of your USB Keyboard, either use a PS2 keyboard or have a Usb to PS2 converter Handy)

    4)
    Find and delete the following files
    delete sptd.sys
    delete sptd.sy
    delete sptd.sys
    delete sptd.sys

    5)
    Goto a command prompt and run the following commands
    cd \windows
     del *pcmcia*.* /s/p
     del *1394*.* /s/p

     

    Good luck to you all and many thanks to everyone who contributes help online :->

     

    James

    Friday, June 27, 2008 1:03 PM
  • Okay, here was my solution.

    Asus M2N32-SLI Deluxe
    AMD Athlon 64 X2 6400+
    OCZ 2GB DDR2 PC-6400
    Seagate 500GB SATA
    Western Digital 200GB ATA
    LG DVD-RW ATA
    Windows Vista Ultimate 64 bit

    The problem was I had a jumper missmatch on the IDE channel.
    I had the Hard Drive and DVD Drive on the same IDE cable and the jumpers were both set to Master.
    I simply corrected the jumper issue and it booted back up for me.

    Hope this helps.
    Saturday, June 28, 2008 7:34 PM
  •  

    My solution: Disable SATA Native Mode in BIOS.

    I have a HP Compaq 6710b running Vista. After a hardware crash, I ordered a new PC and swapped the hard drive (OEM Vista) that came with it with my old hard drive (my precious Vista), which made Windows reboot after loading crcdisk.sys (blue screen, restart). It turned out that the new PC had SATA Native Mode enabled in BIOS, while the old one didn't. So I changed this and only this, and the problem was solved.

     

    Best of luck to the rest of you...

    Wednesday, August 13, 2008 10:57 AM
  •  

    Yep, worked for me on Dell Inspiron 1720. Works on other inspiron systems too.

    1. Press F2 to enter BIOS mode

    2. Under "Onboard Devices" select "Flash Cache Module" and set it to "Off" (you cannot disable SATA unless this is set to "Off" mode.

    3. Move up to "SATA Operation" and change from "AHCI" to "ATA". It will prompt you that your operating system may not work after the changes. Accept, save changes and Esc from Bios.

     

    I tested it on three different dell notebooks and they all works fine without crashes.

    • Proposed as answer by Pedrusco Thursday, April 23, 2009 2:27 AM
    Wednesday, August 20, 2008 11:06 PM
  • disabling AHCI and dropping down to 2GB of RAM worked for me.  i had been getting the crcdisk error.  x64 ultimate, booting with RAID 0 w/ nvidia chipset.

    thanks to everyone

    Thursday, August 28, 2008 4:17 AM
  • Thanks Billy chkdsk /r definately works, i ran the the chkdsk /r and then restarted the laptop. Booted windows in Safe mode. And everything worked fine.

    Wednesday, September 10, 2008 9:49 PM
  • Anyone know why USB keyboard is part of this issue?  I came back to my machine in an S3 sleep state and had no USB keyboard support.  I had noticed that a Windows Vista update was installed - Search 4.0.  I performed a clean install update/shutdown (no keyboard) and the system came up fine.

    After this, I would periodically lose one of my SATA drives.  Also, clicking on a directory with 100's of files would take minutes - then the drive would disappear (event is logged that it's unmounted).  I performed an add/remove of Search 4.0 with no help.

    Booting into safe mode brought me to this thread - locked on crcdisk.sys.  Would repair from original windows disk be the bet option?  Any thoughts are appreciated. Thank you.

    ASUS P5B
    Seagate SATA 500GM x 2
    Corsair PC6400 - 2GB
    Vista 32 Home Premium


    Thursday, September 18, 2008 2:46 PM
  • I've never lost my keyboard, but coming out of screen only sleep and my mouse arrow disappears.
    Try adjusting your control panel\power options to never do full sleep mode, just let the monitor sleep.
    I have my BIOS set to turn system on when space bar is hit, very convenient. As for SATA, get all MS updates
    and keep searching.
    Good lucky,

    Thursday, September 18, 2008 9:52 PM
  • Well dude, you solved my problem too! I've been struggling all night with upgrading XP sp2 to Vista Business. Same symptoms as you, I did'nt find the driver in c:/windows/system32 but in a weird folder. I found it by using DIR /S sptd.sys
    After, it continued upgrading past the 64%

    I had Windows orginally installed on a F: drive. I found the sptd.sys file on the C: drive.

    Thanks!
    Thursday, October 02, 2008 10:06 PM
  • Hi all,

    I really need help with a similar problem. I have a fairly new computer with Vista Home Premium (clean install).

    Some days the system just works fine but other days it just crashes. I have not been able to find any pattern to what causes it. It can be when I'm playing a game or simply when I'm browsing the net.

     

    What happens is that I suddenly get the bluescreen with some message, the ones I have managed to see are: PAGE_FAULT_IN_NONPAGED_AREA,

    BAD_POOL_HEADER,

    BAD_POOL_CALLER,

    PFN_LIST_CORRUPT,

    and DRIVER_IRQL_NOT_LESS_OR_EQUAL.

     

    The system then reboots and I immediately get a new bluescreen with the message MEMORY_MANAGEMENT, and the system goes into a reboot-bluescreen cycle.

    Sometimes it works to boot it in safe mode, but quite often this too crashes and I get to the famous crcdisk.sys stop followed by a new bluescreen.   

     

    Here's some info about my system:

    Intel Core 2 QUAD Q9550 2.83GHz
    2 x A-DATA 2GB DDR2 PC2-6400 800MHz CL5
    Samsung Spinpoint F1 HD103UJ 1TB 7200rpm 32MB cache SATA2
    Gigabyte GeForce GTX 280 1024MB DDR3 TV-out HDTV DUAL DVI RETAIL PCI Express
    Windows Vista Home Premium 64-bit

     

    I have updated the BIOS to the latest version, but no changes in behavior. I hope someone out there can help me out with this problem. Thanks. 

    Wednesday, October 15, 2008 8:53 PM
  • This CRCDISK.SYS problem is USB related.

     

    In my case this happend,

     

    My brothers HD crashed so I took his pc and placed it next to mine.

    I turned off my pc an unplugged my USB mouse from USB PORT 0 and PS2 keyboard and connected both to my brothers pc.

    After installing XP on a new HD on my brothers pc, I plugged the mouse and and keyboard back into my own pc.

    BUT, instead of pluggin the mouse back into usb port 0, I plugged it into usb port 1.

    Result, CRCDISK.sys problem and Vista refused to boot from this moment on.

     

    I tried everything tot resolve this problem including Vista repair and some other tools, but nothing seemed to help.

    Because I unplugged my mouse while the pc was turned off, vista expected to find my mouse still in port 0 while booting and refused to boot. In savemode vista stopped loading at crcdisk.sys.

     

    After a couple of days without Vista I disabled the USB controller in the BIOS to see if this would help any and BINGO, Vista was rebooting like a charm again and works fine now (except for the mouse :-).

    I plugged the mouse back into usb port 0 (where is was before the whole thing started to go wrong) enabled the USB controller in the BIOS, and the problem was solved.

     

    So, if you run into this problem reconnect all usb devices as they where connected before this problem occurred and Vista should reboot again. Or disable the USB controller in the BIOS to test if your problem is USB related.

    And only connect or disconnect new usb devices while Vista is up and running!!

    Mayor Vista Bug!

        

     

    Thursday, October 16, 2008 6:56 AM
  • Thank You. This did the trick for me as well. I only had 2GB of RAM. But I disabled the local cache in order to change from ACHI to ATA, and the laptop is finally running again.

    Thanks again,
    Tuesday, October 21, 2008 1:38 PM
  • Yes Sir.  Disabling legacy SATA worked for me!  Thanks

     

    Tuesday, October 21, 2008 2:44 PM
  • I think I may have had the same problem.  I have an Asus system that would periodically refuse to boot.  I could fix the problem by reversing the SATA connections between the HD & CD.  Within a few days the machine would not boot again and I'd reswitch the cables and could boot.  I tried different hard drives, CD drives,. memory, even a whole new motherboard, nothing would fix it.

     

    Sometimes the system would boot, but I couldn't access my CD drive.  I did see a virtual CD drive, created by Magicdisc.  Finnaly, I uninstalled MagicDisc and MagicISO.  Since then, my machine has been running for about two days.  I think (really, really, really hope) this issues is fixed.

     

    What I don't understand is, if MagicDisc was causing the problem, why couldn't I at least boot to the start of Windows (in my case Vista)?  The MagicDisc software shouldn't come into play during the inital boot process.

     

    Is it possible that MagicDisc was writing to my CMOS memory?  If so, it's one very bad program.

     

    Jon

     

    Tuesday, November 18, 2008 2:57 PM
  • I know this post was due to using Acronis but the same process may apply to you:

    http://www.carrollzone.com/Blog/post/2007/06/Acronis-Uninstall-caused-Vista-to-BSOD-with-0x0000007B-in-crcdisksys.aspx.  Worth a look.

     

    • Proposed as answer by Mark514 Wednesday, January 20, 2010 5:23 PM
    Monday, November 24, 2008 7:33 AM
  • I dont think the problem is with the crcdisk.sys file. I tried all the software fixes and my problem was not solved.

    the other reason is that i have a dual boot setup with xp 32 and vista ultimate 64 and both had the same problem....a delay at the OS load screen where the moving bar would stop for up to 30 seconds.

    The meat of the problem lied with the Marvell IDE on my motherboard (ASUS P5Q Pro), as soon as i disabled this and booted up both my OS started extremely fast, and my system was looking like the beast it was built to be Big Smile

    Q9550 @ 3.0 Ghz
    4GB G.Skill PI Black @ 4-4-4-12 / PC6400
    Sapphire Radeon HD 4850
    640GB WD6400AAKS

    If you're looking to build a new system, those parts will exceed your expectations.
    Saturday, November 29, 2008 2:18 PM
  • Hurray!  THanks! Worked like a charm!
    Friday, December 05, 2008 2:18 AM
  • Ran into this problem after the computer was shut down during a power outage. When rebooting Vista the green bars would just go across, restarted in Safe Mode and it stopped at crcdisk.sys. After reading through the reviews, I removed one (of two) SATA hard drives. This allowed Vista to start and it loaded. I then shut down, and plugged in the other drive. Things are now at least working. Windows is very very slow to load up and can take about 5 minutes from power on to logged in, but at least I can get into it and can address the slow boot later.

    Thanks everyone who posted!
    Monday, December 08, 2008 1:42 AM
  • TPOLMike said:

    Ran into this problem after the computer was shut down during a power outage. When rebooting Vista the green bars would just go across, restarted in Safe Mode and it stopped at crcdisk.sys. After reading through the reviews, I removed one (of two) SATA hard drives. This allowed Vista to start and it loaded. I then shut down, and plugged in the other drive. Things are now at least working. Windows is very very slow to load up and can take about 5 minutes from power on to logged in, but at least I can get into it and can address the slow boot later.

    Thanks everyone who posted!



    I maybe suffering the same issue. I did have the stopping after crcdisk which I fixed with the Repair option off the Vista install disk. Then I added a new SATA disk and now it boots but only after it's sat for a few minutes after POST has finished - I get periods of no HD activity and periods of lots of it but no apparent progress. Shutdown's also slower - though I don't care as much. So, will be interested to know whether yours is 'hanging' at the same place ? Cheers.
    Monday, January 19, 2009 8:38 PM
  • I find that it is a Dvd or Cd rom drive malfuctioning, try unpluging your power and data cacble from your DVD or CD rom drive then boot up and select the "Last Known Good Configuration" option then hit enter on your keyboard., once your booted up try and remove uncessary programs from Start bar, you go into windows defender and select startup programs their.
    Friday, March 13, 2009 11:35 AM
  •  I find that it is a Dvd or Cd rom drive malfuctioning, try unpluging your power and data cacble from your DVD or CD rom drive then boot up and select the "Last Known Good Configuration" option then hit enter on your keyboard., once your booted up try and remove uncessary programs from Start bar, you go into windows defender and select startup programs their.
    Friday, March 13, 2009 11:36 AM
  • hi iam having same problem with an acer asphire 5315 vista it all started with two viruses appearing when i loaded internet explorer avg tried removing files as a power user but couldnt so i went to defrag the drive and its appears to do it in less than 20 secs ( i tried defrag because i have found with avg when u use another probgram like that to activate and find the file it can remove it easier) so i uninstalled avg and installed netscape internet security now 9 out of ten times when i boot up i get the big bad blue screen which i am sure is not because of the program  so i try booting up in safe mode but it freezes at crcdisk.sys its wont boot up in last known good configuration i can get it to desk top by using debuging mode when i do this if i conect the ethernet it usualy lasts less than 5 secs then the blue screen is back i am pretty sure that it is a virus causing all of this but nothing a try works and i realy dont want to format any help on this would be more than appreciated
    Friday, March 20, 2009 1:05 AM
  • p.s i am having major problems removing internet explorer it is not in the installed updates section any help would be great
    Friday, March 20, 2009 3:14 AM
  • I had this CRCDISK.SYS problem too! 
    My solution-->REMOVED 6MB (out of 8MB) of Ram, to bring it down to 2MB.  

    What else, sometimes I'd get the Blue Screen of Death (BSOD) & it would say:
    0x0000001a MEMORY_MANAGEMENT

    or it would say on the BSOD:
    the driver is mismanaging PTEs 
     

    It started right up.
    So for me, this was a hardware issue.

    BELIEVE ME, I tried ALL the software solutions out there (that I could, because I could never actually access windows vista or a command prompt).
    But I did Everything else BiOS-related.
    I tried switching my hard drive to AHCI and from AHCI.
    I put in the USB mouse and keyboard I had originally started the PC, & I removed them again.
    I enabled & disabled the USB keyboard & mouse in the BiOS.
    I did some other ____ too..
    Oh, unplugged & replugged the HD.  & I tried to reboot from the disk in between there.
    What FINALLY worked was taking it down to 2 MB. 
    I was worried I wasn't getting enough power to my RAM & almost upped the voltage (which always freaks me out), but they were getting 1.92V already & they only wanted 1.8V.

    Anyways, taking out the RAM was what worked for me.  I'm still trying to update my Vista Home Premium, but I'm still setting everything up (internet connections and all that 

    I JUST received my new PC (I've been a Mac guy for about 7 years now-I'm typing this on a Mac-but I needed something powerful & cost effective--Dare I say it, YES, I couldn't cough  up the dough for a comparable Mac-damnit, I said it!---and, well...lotsa new programs or proprietary programs only work on PC).
    I FORGOT ALL ABOUT HOW YOU HAVE TO BE COMPUTER PEOPLE or you have to pay someone like Dell or Gateway or tigerdirect or something to buy a PC.  
    I bought a relatively barebones system & figured I could throw a ton of RAM in & my own video card, which I have not been able to do...yet.

    Anyway, I know I'm supposed to rite what's under the hood, so...y'all might like this: Fast & cheap (<$800 online w/ Vista Home prem 64-bit):
    GIGABYTE Ultra durable 3 MA78GM-US2H SLi HD & all that jazz- decent sound card crappy onboard vid card
    AMD PHENOM II X4 9550 (4 x 2.2 GHz, but I'm going old school & I Will Overclock this puppy!  I got plenty of cooling.)
    8GB (4 x 2GB) DDR2-800 MHz Micron Ram
    250 GB Western Digital SATA2 7200rpm
    A decent midtower case with plenty of airflow
    20x CD-DVD-RW lightscribe Samsung
    and the kicker:
    BFG GeForce 9800 GT w/ 512 DDR3  - dual DVI  & TV-pout 400 Mhz --pretty snazzy for $100


    I'm updating this inexpensive little beast now...let's see if I can slide those other 6GB of RAM back in...& then...the video card.
    If all of this works, then I'll concede that I needed to take it down to 2MB RAM, update Vista, & then I can build it back up to it's final state!

    Oh no, I put the 8GB back in...& it stops on the CRCDISK.SYS again.
    I'm taking them out 2 at a time until this works.
    Looks like I'm going to have to try something else...maybe removing those files like they said in other posts
    Nope.  It works with 6MB! 
    OKay.   I rebooted once or twice, and then reinstalled the last 2GB.
    I'm up to the full 8GB after stripping it to 2GB and adding more RAM after a reboot or 2.

    Whew.
    Welcome back to the world of PCs, @nestabus  !

     


     

    Wednesday, April 08, 2009 7:02 AM
  •  

    Worked for me on ACER Aspire. I used option 1 and 3. In option 3 select IDE.

    1. Press F2 to enter BIOS mode

    2. Under "Onboard Devices" select "Flash Cache Module" and set it to "Off" (you cannot disable SATA unless this is set to "Off" mode.

    3. Move up to "SATA Operation" and change from "AHCI" to "ATA". It will prompt you that your operating system may not work after the changes. Accept, save changes and Esc from Bios.

     

    I tested it on three different dell notebooks and they all works fine without crashes.


    Thursday, April 23, 2009 2:48 AM
  • It seems that this is only the symptom of a larger unknown problem. I read this entire forum and not a single person solved the problem in the same manner. This includes me.

    I reloaded Vista HP onto a Dell Inspiron. Everything was fine until the first reboot to the hard disk (SATA). The machine halted. Booting in safe mode revealed that crcdisk.sys was the last file to load. I inspected the hardware, but found nothing wrong at all. I ran full Dell diagnostics and came up with 100% successful test results. Then I tried to load Windows XP on the machine. It REALLY hated that and would not even detect a primary disk to install windows on.

    I was ready to give up when I let the machine reboot and ignored the CD so it went to the hard drive. Next thing I was looking at was Windows Vista continuing its installation. I was dumbfounded. After trying everything in this forum, it just suddenly worked?!?

    But when it reset again later, I got the same halt on crcdisk.sys, but NOW it automatically reset itself after a quick flash of the blue screen of death.

    More hardware inspection. Then it hit me!      The POWER!!!!!

    Sure enough, the machine booted. I was then able to deduce and repeat my results by only booting to battery power. As soon as the log in screen appears, I then plug the AC power back in. Something about it being there causes a malfunction in the logic board of this refurbished laptop. Otherwise, everything works fine.

    So try unplugging your laptop if indeed this problem is occuring on one.
    Sunday, May 10, 2009 3:34 PM
  • You are right, there seems to be no single answer. My server recently had the same issue. Locked up in the exact sam eplace, no safe mode, no repair, nothing. A full hardware test found no problems. At one point I even tried a new drive, nothing, Vista would not even install on a NEW HDD, that really had me puzzled. The serber even rejected XP, however iy did get further in the install, but no succsess. I tried several times to restore the disk from 2 different backups I had, one of which was several months old, the backup was succsessful, but Vista was still hanging on crcdisk.sys. Last know good confog? Nope, cleared BIOS? Nope, nothing I did changed the way Vista axted.

    My solution was this, I disabled USB legacy support in the BIOS and moved my drive to a different SATA port. Bad SATA port? That was my guess, but since Vista is working now, I moved the drive back to it's orginal port, it STILL works. 

    So in conclusion, I have NO real idea what the problem was, and the solution was ramdom. I will say that the USB and port chage idea, I got from another post, at that point I was grasping at straws, turns out, it worked.....for me, for now. 


    It would be nice to hear from MS as to what crcdisk.sys actually does. 


     
    Monday, June 29, 2009 6:52 AM
  • Ok Guys. Source problem of CRCDISK.sys is not a single source, Also is not a continuos problem (Vista may boot up 500 times and suddenling does`t want to boot up again, fix selves and star again problem several times of boot ups later).

    Normaly, problem comes fron Mother Board adds-on devices and/or cotrollers.

    Try to Disable devices from mother board BIOS ( internals WI-FI, LANs, USBs, IEEE1394, SATAs and so on....)

    Good luck. Its a freaky problem....!!


    Wednesday, July 01, 2009 7:08 PM
  • I have been studying this problem since TWO of THREE Dell Inspiron 1525s that I bought for my kids at XMAS had this error within days of each other. My first assumption was that it must be a virus, but why would a virus "recur" after the hard disk was formatted and there was a clean install of VISTA? It wouldn't.  A virus scan of the third unit came up clean, to lend further validity to my theory.

    My kids systems have no weird hardware or peripherals, and the most complex software application they use is the game Spore.

    I spent many hours staying up late and reinstalled VISTA on both failed systems - NONE of the solutions proposed online in multiple forums have revealed squat, nor has exploration of Microsoft's site or Dell's site. I do not have the patience to talk to tech support in INDIA, and am not willing to pay someone else to do what I can do from home. My MAC powerbook PRO, BTW, functions beautifully and has allowed me to continue having internet access when the other machines are down.

    Even with clean installs of VISTA and the most current drivers I could locate on the web, the error recurred and put one of the Inspirons in an endless "death spiral" where I couldn't even reboot from the intallation boot disks. 

    Ths solutions proposed on these forums are laughably complex, and the average user has no idea how to start messing around with core commands or rewriting line by line code from the C:\ prompt.

    I think this is a fundamental incompatibility of VISTA with most hardware for some unknown reason. The fact that it is such a common problem, and Microsoft is mute about it, also makes me think there was a major fuckup in the code that just cannot be fixed.

    My solution was to install UBUNTU on the dead system - guess what - it was free and installed in about 25 minutes and is remakably user friendly (like the MAC OS). My son loves it, and so do I.

    Goodbye VISTA, and good luck to all of you out there reintalling VISTA for the 100th time and fussing with your motherboards....
    Monday, July 13, 2009 1:58 PM
  • Someone here said, "Beware of Nforce chipset, some guys in here report you may get problem on that." Can anyone be more specifc on this? I am working on a Dell Studio XPS 13, I just installed Vista x64 and it won't boot. It hangs at crcdisk.sys. I noticed on Dell's website there's an Nvidia chipset driver. I have never heard of an Nvidia chipset before. I tried reloading Vista and adding the Nvidia driver during setup but that doesn't work. How do I get Vista to boot for the first time on this computer?
    John Marcum | http://www.TrueSec.com/en/Training.htm | http://myitforum.com/cs2/blogs/jmarcum
    Monday, August 31, 2009 12:02 AM
  • Just in case it helps someone, here's what happened to me:

    My wife's PC had a HD failure.  I unplugged my secondary SATA drive on my PC and plugged hers in to see if I could recover any data.  I was able to get a bit.  Once I was done I plugged my drive back in and my PC wouldn't boot fully.  I tried booting into Safe Mode and it hung at crcdisk.sys.  I unplugged my second drive and it booted up fine.  so I moved crcdisk.sys out of the \Windows\System32\Drivers folder to see what would happen.  Still no boot.  Went back into Safe Mode and now it hung at a different .sys file (can't remember which).  I tried unplugging everything in my PC (cards, peripherals, etc.) except for the bare minimum to no avail.  I tried moving my HDs to different SATA channels but it didn't help.  I tried system restore... didn't help.  I put the HD into my wife's PC and it was fine with no errors detected in a scan.

    I tried moving/deleting these files as mentioned above but even though I'm an admin Vista kept telling me I didn't have the right permissions for the second through fourth files.

     C:\windows\system32\drivers\pcmcia.sys*
     C:\windows\system32\drivers\1394bus.sys
     C:\windows\system32\drivers\ohci1394.sys
     C:\windows\system32\driverstore\filerepository\pcmcia.infblablabla*
     C:\windows\system32\driverstore\filerepository\1394.infblablabla
     C:\windows\system32\driverstore\filerepository\sdbus.infblablabla*
     C:\windows\inf\sdbus.inf*
     C:\windows\inf\sdbus.PNF*

    I moved what I could but that didn't help. I then followed this link

    http://www.carrollzone.com/Blog/post/2007/06/Acronis-Uninstall-caused-Vista-to-BSOD-with-0x0000007B-in-crcdisksys.aspx

    Even though I don't remember ever having Acronis products or removing them (who knows though.  I am getting older) I figured what could it hurt. I booted up (second drive removed) and I searched for snapman in my registry.  Lo and behold I found 4 keys that had it.  I backed up my registry and removed the snapman part of the keys (not the whole key. Read the instructions) and rebooted.  Halleluiah!  Problem solved.

    Hope this helps

    Friday, September 04, 2009 5:04 PM
  • Fix: go into safemode and uninstall Vista Service Pack 2.
    Thursday, October 08, 2009 10:55 PM
  • I booted from the CD, chose "Repair" selected to open a command prompt and ran
    chkdsk C:\ /F
    That fixed troubles with the indexes and I was able to boot normally after that
    Friday, October 30, 2009 9:49 AM
  • My guess is an incompatiblility in one of Miscrosoft latest updates with the original Lenovo software.
    I happen to have a Lenovo N300 with a 64 bits version of Vista and 4 Gb of memory too.  Every second startup, the system shuts down when loading crcdisk.sys. What's relevant though is that I have had this configuration for months without any problem whatsoever. It's only after a Windows update between now (dec. 6 2009) and a few weeks ago, that this problem emerged.
    Must be some incompatibility in the Microsoft updates, as I did not update any Lenovo software. 

    Hope Microsoft will look into it, as indeed, many peoaple seem to have the same problem.
    Sunday, December 06, 2009 5:49 PM
  • My solution to this problem wasn't listed.

    My problem was a little different as well.

    Sometimes it would boot successfully and other times it would die on crcdisk.sys.  

    I double checked to make sure all my cables were in tight and the RAID card.  Once everything was nice and tight the system worked consistently again.

    Phew.

     

    Wednesday, April 07, 2010 6:14 PM
  • Greetings.

     

    I solved this problem using Hirens Boot CD 10.

     

    The problem was a bas sector on my HDD.

     

    I checked my disc with HDD regenerator tool.

     

    I hope it is helpulf for someone

     

    Cheers!!

    Friday, April 09, 2010 5:51 PM
  • well that does, but I had issue with Gigabit board where the 3 mem-slot has tendency to cause same problem where and asus is the 4 th one from my experience.

    if you have sli enable, make sure the patches are up to date other that would through things off as well hope this helps.

    Saturday, May 01, 2010 6:35 AM
  • I have a similar problem, but not quite. The problem occurs on The Compaq Presario C767EL, IntelCore 2 Duo processor T5250 1.5 GHz 2 GB RAM, 320 GB WD (hdd and RAM  both checked with all available diagnostic applications - 100% fine and working). Laptop crashes when installing the system (tried XP, Sabayon, Suse, Vista). If the system is already successfully installed - I only managed to install Vista -  it only works in Safe Mode - in normal boot it just freezes on the Vista loading screen and only the  power off button helps. The bios has no options whatsoever (InsydeH2O - you can only change the boot sequence and the date). There is no overheating. No possibility to restore or reinstall the system, because the laptop freezes after loading the windows files and will not boot in normal mode. Any ideas?
    Wednesday, May 19, 2010 9:59 AM
  • Hi guys I recently had this problem on my nieces toshiba laptop.Was pulling my hair out then found the following solution

     

    Go into your bios and enable the usb option.Then plug anything into the laptop that might have been in use before the error.In my case it was as simple as a usb mouse.

    Restart computer and hey presto,boots up fine ever since

    Monday, February 07, 2011 7:07 PM
  • Thank you for saving me hours , worked like a dream

    DELL INPIRON 1525

    Monday, April 04, 2011 4:31 AM