none
Games give Black Screen when I start them in Windows 7

    Question

  • All the games I had when I used Windows Vista were playable. Now with Windows 7, whenever any of my games starts in full screen mode, my monitor turns black and does nothing else. The monitor still detects my computer because the monitor gave me no error of a missing input. I cannot alt+tab or Ctrl+Alt+Del or even WindowsLogo+Tab and I am forced to cut the power and restart. After long tiring research giving me such suspects like DirectX 11, disabling Aero, to the all popular lacking computer requirements to play the game I could play before I installed Windows 7. My conclusion was I could play games as long as there are not in full screen mode or in other words Windowed Mode.

    Why must I play all my games in Windowed Mode to play them on Windows 7? Is there a way to fix this problem?
    Sunday, October 25, 2009 6:17 PM

Answers

  • I have however, found the answer to my problem!

    As it turns out is wat my firewall or Internet Security program Comodo Internet Security. There is a feature called "Defense +" which looks over my computer and protects my computer from anything that can cause suspicious behavior. Before Windows 7 this feature worked great with no issues. Now with Windows 7 their have been numerous small errors such as asking permission to access harmless files that really are safe. Comodo's Defense + does not run well with Win7 despite the website claiming to be able to run on Win7. After digging threw Comodo's forums I found support for this and with either turning off Defense + or changing a lot of settings, my games can play in fullscreen again.

    I thank everyone for trying to help me and I thank those who helped me come to my conclusion to my issue.
    • Marked as answer by Thecheese Thursday, November 05, 2009 2:29 AM
    Thursday, November 05, 2009 2:29 AM

All replies

  • Hi Thecheese,

     

    Try loading the game in compatibility mode. To do this, please perform the steps below:

     

    1. Right click the game's shortcut or the executive file and then click Properties.

    2. On the Compatibility tab, check "Run this program in compatibility mode for".

    3. Select the Operating System in the pull down list.

    4. Also, you can change the settings listed to run the program in the customized environment.

    5. To change the privilege level, please check "Run this program as an administrator".

    6. To apply the settings to all users, please press "Change settings for all users".

    7. On the popup menu, redo step 2 to 5.

    8. Click OK to save the changes.

     

    What is the result? In addition, please update the display card driver to the latest one and see if the issue can be resolved.

     

    Regards,

    Linda

     

    • Marked as answer by Linda Yan Thursday, November 05, 2009 1:29 AM
    • Unmarked as answer by Thecheese Thursday, November 05, 2009 2:29 AM
    Monday, October 26, 2009 7:03 AM
  • I've tried to start multiple game in full screen with compatibility mode set to Vista SP2 and admin checked off it still gave me a black screen crashing my computer and doing a force reboot.

    My graphics driver is updated to the latest driver available.
    Tuesday, October 27, 2009 9:46 PM
  • I am having the exact same problem. Compatibility modes, run as administrator mode, nothing works.

    For some more information, if it helps: If i have music playing when I try and run the game the screen goes black and the music stops, leading me to believe that the computer as a whole just stops working....

    I am running Windows 7 Home Premium x64.

    So does anyone have a solution to this, kind of irritating since I built a new computer to game and currently I have a high powered computer acting as a very expensive paper weight.
    Wednesday, October 28, 2009 12:10 AM
  • Hi Thecheese,

     

    Could you please let me know the brand and model of the display card? In addition, if the computer is an OEM (original equipment manufacturer) one, please let me know its brand and model as well.

     

    Also, please provide some names of the games which have this issue.

     

    In the meantime, please change the hardware acceleration and the refresh rate to see if the issue can be resolved.

     

    If the issue still exists, please run Windows Update and see if there is any newer driver can be found.

     

    Regards,

    Linda

     

    Wednesday, October 28, 2009 7:22 AM
  • Hi all,

    I had an the exact same issue in NFS Shift, the game would just freeze on a black screen and not respond, I tried all sort of compatability settings to no avail but discovered that the problem was Win 7's visual themes. In compatability mode make sure you tick 'Disable Visual Themes'; hope it works for you too :-)
    Wednesday, October 28, 2009 2:53 PM
  • Clicking all of the options with setting to Vista SP2 except 256 colors and changing the screen resolution under the compatibly tab and it changes nothing.

    I use a HP Pavilion Media Center m8530f PC and I removed the Nvidia GeForce 9300GE graphics card and replaced it with a Nvidia 9800GT graphics card that was manufactured by BFG Tech. I updated the graphics card driver to 191.07 designed for Windows 7 64-bit computers which is what my computer is. I run Windows Update everyday and there is nothing to update.

    Changed refresh rate and still no change.
    Wednesday, October 28, 2009 9:30 PM
  • Please also refer to the suggestions in this thread: Black Screen while playing games-Windows 7.

    Thursday, October 29, 2009 2:57 AM
  • That thread doesn't sound quite like my issue but similar. According to the poster, (I might be wrong on how I interpreted this), he says he plays the games then the black screen occurs. Cooling does not seem to make sense to me cause if that were the case the problem would of be happening since I had Vista. Its too bad though that thread was ended abruptly because the poster never said if what SpiritX said did the trick. It says his answer was marked as the answer by a Moderator, not the actual poster.

    My drivers are up-to-date; the ones that seem necessary and found from Windows Update that is, my graphic card driver in particular.

    The below was taken from my similar post on another part of this forum:

    http://social.technet.microsoft.com/Forums/en/w7itproappcompat/thread/350c1593-bf56-470b-b152-29b461f0e5c0?prof=required&ppud=4

    Allow me to give you a detailed description of what my problem is:


    (note that is same issue occurs with no difference with every game I try.)

    Prototype is a game released during Windows Vista and it worked perfectly fine with no issues whatsoever during the time I had it. While I had Windows Vista I updated Vista weekly and always made sure to have the latest Service Pack.

    Now with Windows 7, this is what would happen when I try to play Prototype:
    • I insert the disk to play because Prototype requires it to play
    • Auto-run pops up and I turn it off (playing in autorun will give me the disk's own personal menu that is used to install the game but also play the game once installed and starting from this menu makes no difference)
    • I go to my C: drive and go directly to the file that starts Prototype (I've been doing this as of late because of the black screen issue, again, either way makes no difference)
    • I execute the file and it takes around 10 sec, (like in vista so its normal), for a gray box to appear on the top left hand side of my screen for less than a second, (which was normal in Vista), then the screen goes black, thus, the black screen appears.
    • I cannot see my cursor, I cannot Alt+Tab, Ctrl+Alt+Delete, or Windows Logo+Tab. My computer has technicality crashed (my HDD light is blinking but it soon stops).
    • I force restart my computer.
    HOWEVER <------- (make sure you read what's coming next.)

    The black screen issue never occurs if the Prototype or any game I play is playing in a Window or Windowed Mode. My games run perfectly fine if in a window.

    Note: If you know anything about the game Prototype, it has no windowed mode. So how can I play Prototype in Windowed Mode? I use a 3rd party program I found called 3D Analyze which forces any game to go into window, or any other options the program gives me and it runs that way.
    Thursday, October 29, 2009 9:08 PM
  • Hi Thecheese,

     

    What is the screen resolution of your monitor and the game? It is possible the game does not support the current monitor screen resolution. Please reduce your screen resolution to 1024x768 pixels and see if the game works properly in the full screen mode.

     

    Also, please check if there is any game resolution setting can be changed. If so, adjust the screen resolution to see if the issue occurs.

     

    Besides, contact the game manufacturer and see if they have published any updates for Windows 7.

     

    Regards,

    Linda

     

    Friday, October 30, 2009 3:00 AM
  • I use a screen resolution of 1650 x 1080 and all of my games support that resolution and thus all of my games are at that setting. Even if it wasn't, back in Vista it would work regardless of what resolution I choose.

    As for updates, most of my games run from Steam which wont allow you to even play their games without updating them. World of Warcraft is the same way. As for Prototype, I've looked into it and Activision treats Prototype like a forgotten panda. The fans of the game beg for a patch but Activision ignores them.
    Friday, October 30, 2009 3:23 AM
  • Does the issue occur while using the original Nvidia GeForce 9300GE graphics in Windows 7? In addition, please install the monitor driver if it is available.

     

    Besides, please disable all startup items and third party services when booting. This method will help us determine if this issue is caused by a loading program or service. Please perform the following steps:

     

    1. Click the Start Button type "msconfig" (without quotation marks) in the Start Search box, and then press Enter.

     

    Note: If prompted, please click Continue on the User Account Control (UAC) window.

     

    2. Click the "Services" tab, check the "Hide All Microsoft Services" box and click "Disable All" (if it is not gray).

    3. Click the "Startup" tab, click "Disable All" and click "OK".

     

    Then, restart the computer. When the "System Configuration Utility" window appears, please check the "Don't show this message or launch the System Configuration Utility when Windows starts" box and click OK.

     

    Please test this issue in the Clean Boot environment, if the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Monday, November 02, 2009 9:18 AM
  • I have however, found the answer to my problem!

    As it turns out is wat my firewall or Internet Security program Comodo Internet Security. There is a feature called "Defense +" which looks over my computer and protects my computer from anything that can cause suspicious behavior. Before Windows 7 this feature worked great with no issues. Now with Windows 7 their have been numerous small errors such as asking permission to access harmless files that really are safe. Comodo's Defense + does not run well with Win7 despite the website claiming to be able to run on Win7. After digging threw Comodo's forums I found support for this and with either turning off Defense + or changing a lot of settings, my games can play in fullscreen again.

    I thank everyone for trying to help me and I thank those who helped me come to my conclusion to my issue.
    • Marked as answer by Thecheese Thursday, November 05, 2009 2:29 AM
    Thursday, November 05, 2009 2:29 AM
  • Glad to hear the cause was found. :)
    Thursday, November 05, 2009 10:01 AM
  • can you pleaseeeee tell me what settings you have changed because i am having the EXACT same problem
    • Proposed as answer by PetrPruner Thursday, February 25, 2010 7:59 PM
    Friday, February 12, 2010 9:58 PM
  • Go in the comodo  internet securiy in Defense + -> My pendig files
    Find the file of the game mark  it  and select move to my own safe files

    alternatively you can use:
    internet securiy in Defense + -> My own safe files -> Add -> bBrowse files and find the file
    Thursday, February 25, 2010 8:04 PM
  • I have the same problem with all games and even with 3dmark.
    Everything is updated,I do not use comodo,The pc is notebook - Amd turion64x2 with Ati mobility Radeon X1600.
    OS - Windows7 Ultimate x64
    I`ve tried all solutuions above but no result at all...when games start at full screen- the Pc freezes.
    If somebody can offer other solution - Thanks!

    Friday, February 26, 2010 9:35 PM
  • What I did to fix this issue, it seems stable right now, is to go to my video card manufacturer website and downloaded a new video bios.  I have the BFG 8800GT.  So, I downloaded the new video bios, installed it, resinstalled the nvidia drivers and things seem to be working well.

    My GPU temp is around 80C during games.  Hope this helps.

    Saturday, April 24, 2010 1:27 PM
  • Hey what if i use norton security then what do I have to do to get rid of black screen
    Thursday, February 10, 2011 4:51 PM