locked
How to properly remove "Network" from Windows Explorer and Save Dialog boxes? RRS feed

  • Question

  • I've recently rolled out Windows 7 and noticed that in some applications (Office 2003 - yes we are due for an upgrade - happening later this year), when a user clicks the down arrow in a "Save As" dialog box to view the available locations - a list of seemingly every computer in the broadcast domain is generated and displayed.  This takes about 30-45 seconds.  I don't want my users to be able to view a list of every computer in their broadcast domain, and I especially don't want them to be presented with said list every time they try to save something.  In newer apps, the list is not automatically displayed but is still accessible by clicking the "Network" selection.

    What is the proper way to remove this?

    I've tried the following:

    1) Disabling the NetBios over TCPIP service - works but prevents other things from working properly.

    2) Disabling the Computer Browser service - does not work.

    3) Changing HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder\Attributes from b0040064 to b0940064 as suggested here -http://www.sevenforums.com/tutorials/39699-network-add-remove-navigation-pane.html .  This seems to work but I cannot find anything that says this is supported by Microsoft and I am wary of what side effects may occur.

    4) Using a GPO to enable the "No Computers Near Me in Network locations" and "No Entire Network in Network locations." - no change.

    It seems like there should a simple way to do this as I can't be the only admin that doesn't want their users browsing a list of every computer on the network.

    Thanks!

    Sunday, February 6, 2011 7:17 PM

Answers

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    I have tested on my machine, change the registry HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder\Attributes from b0040064 to b0940064 is work to remove “Network” icon from Windows Explorer, and it will not cause any network problem.

     

    Since there is no professional KB of remove this icon from Windows Explorer of Microsoft, I suggest to back up the registry before you change it.

     

    Thank you for your understanding and cooperation.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Wednesday, February 16, 2011 8:15 AM
    Monday, February 7, 2011 3:21 AM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet forums.

     

    I have tested on my machine, change the registry HKEY_CLASSES_ROOT\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder\Attributes from b0040064 to b0940064 is work to remove “Network” icon from Windows Explorer, and it will not cause any network problem.

     

    Since there is no professional KB of remove this icon from Windows Explorer of Microsoft, I suggest to back up the registry before you change it.

     

    Thank you for your understanding and cooperation.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Wednesday, February 16, 2011 8:15 AM
    Monday, February 7, 2011 3:21 AM
  • I am deploying this on a wide scale today and will report my results.

    Thanks.

    Wednesday, February 9, 2011 11:40 PM
  • Hi,

     

    Did your issue solved? Please feel free to give me any update.

     

    Thanks.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, February 11, 2011 8:22 AM
  • I deployed the registry key change via GPO, but it did not seem to have the same effect as on my test systems.

    The "Network" option was still visible, yet the list was not automatically expanded as it had been before.

    It is possible that this is a coincidence and the registry key was not properly edited due to permissions.  I will verify this.

    Friday, February 11, 2011 5:50 PM
  • If you have verified the issue related with the permissions of registry key, please feel free to let me know.

     

    Thank you for your cooperation.

     

     

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, February 14, 2011 1:49 AM
  • Hi,

     

    I will mark my first reply as answer. It could help other communities here who have the same issue.

     

    Thanks for your understanding.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     

     

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, February 16, 2011 8:15 AM
  • Hi guys,

     

    I have the exact same problem but on a server 2008 R2 TS box. Unfortunatley that reg key that you suggest does not seemt o exist in 2008 R2. Any idea for a work around??

     

    Many thanks,

     

    Adam

    Thursday, March 3, 2011 12:03 PM
  • You may want to setup a GPO w/ specific Security Filtering so that you do not remove the "Network" option from ALL USERS in the computer.  I'm running in a Windows Server 2008 R2 RDSH Environment and am able to defined this to specific user groups without issues.

    1. Create the GPO
    2. Remove "Authenticated Users" from the "Security Filtering" section
    3. Delegation > Add "Authenticated Users" with "Read" access
    4. Add whatever user security group you want this defined to back into the "Security Filtering" section.
    5. Edit the new GPO
    6. User Configuration > Preferences > Windows Settings > right-click "Registry" > New Registry Item
    7. Action > Update
    8. Hive: HKEY_CURRENT_USER
    9. Key Path: Software\Classes\CLSID\{F02C1A0D-BE21-4350-88B0-7367FC96EF3C}\ShellFolder
    10. Value name: Attributes
    11. Value type: REG_DWORD
    12. Value data: B0940064
      Base: Hexadecimal
    13. Link the GPO to the location you want and you should be able to make the "Network" icon dissappear from the "Windows Explorer" display. 

    Sadly, I was trying to use this as a way to block Office XP's Excel from seeing "Network" and this isn't doing what I want.  I still have some users using old XP Macros that haven't been converted to Office 2010.  Since I have their "My Documents" folder redirected to a Network Share, as soon as you try to "Look In" it bumps back to "Network" and shows them a ton of machines even though I have "Network Discovery Service" disabled.


    "Those who fear the darkness have never seen what the light can do." Magic: The Gathering

    Monday, September 2, 2013 5:47 PM
  • I have a network full of Windows 7 64 bit workstations and this GPO is not making the reg change.  The above says to user HKCU.  Another thread says to use HKLM\Wow3264Node ...

    I have tried many variations but nothing is "hiding" the Network Icon.

    My current GPO is set to Computers - HKLM\Software\Wow6432Node\Classes\CLSID\{F02C1A0D-B...} with the attribute as Hex : B0940064  I have it set to replace as update didn't seem to work.

    When I try to edit the local registry on my computer, it gives me an error:  "Cannot edit Attributes: Error writing the value's new contents." - this is as an admin.


    I looked at permissions and added full control for administrators..it took the change.  I will reboot to check if it will remove the Network Icon.
    Thursday, March 5, 2015 1:40 PM