Appropriate permissions?


  • I installed Windows 7 RC x64 without a hitch.  Then I installed my usual applications, also without a hitch.  These included Adobe Photoshop CS4, Premiere Pro CS4, After Effects CS4 and Lightroom 2.3 and had no problems for a week.  Yesterday, I downloaded and installed the latest Lightroom 2.4. 

    There seemed to be no problems during the installation.  However, when I tried to run the application for the first time by clicking on the desktop shortcut, I got a "The item referred to by this shortcut cannot be accessed.  You may not have the appropriate permissions." message.  I went to the Program Files\Adobe\Adobe Photoshop Lightroom 2.4 folder but then got a "You don't currently have permission to access this folder" warning.  When I click on the "Adobe Photoshop CS4 (64Bit)" folder, I have no problems and can enter it.  Just the Lightroom 2.4 folder is "locked".

    Thinking that it may be a problem with the install application, I removed Lightroom 2.4 and tried to re-install 2.3.  However, the samething happens.  I then removed ESET NOD32, disabled Windows Firewall and tried again, to no avail.  Then, I used MSCONF's "Diagnostic Startup" and tried again.... Same problem. I ran MRT, no problems there, everthing was clean.  Then, I uninstalled all non-Microsoft applications except for the Adobe sets.  Again, no good.

    The installation process looks good everytime (no warnings, etc.) ... very smooth.  Each uninstall is also normal.  All traces of LR2.4 are removed, including the folders in "Program Files", "ProgramData", User "AppData", "Local", "LocalLow" and "Roaming" folders.  The only anomally is when I use the Start button, All Programs, Lightroom 2.4 is listed without it's usual "Lr" icon.  Just a plain blank icon.  And, when I click on that, nothing happens.

    All other applications that are currently installed work just fine.  The only problem is with Lightroom 2.4.

    I'm really stumped here.  Any suggestions will be appreciated.

    Thank you.

    Thursday, June 25, 2009 12:13 PM

All replies

  • Hi Leroy

         I have the same problem! You have triggered the Permissions Corruption Bug and it's disasterous, it corrupts all or part of the Volumes in the Client System Computer that is running the Windows 7 RC Build 7100. I have found no Fix for this as of now. You can take Ownership of the Volume and add the Permissions back in to the affected Volumes/Folders/Files that have been corrupted, but the only way to recover the default permissions is an Image Restore from a backup or a new clean reinstall. (unless you spend a lot of time doing it manually). See my post Here for more Info into my Problem.
    Regards - - - Shorto
    • Edited by ShortoW Thursday, June 25, 2009 3:05 PM Spelling
    Thursday, June 25, 2009 3:03 PM
  • Hi ShortoW,

    Thank you!  So, I'm not alone.  Although I didn't mention it in my original post, I've tried assigning ownership of every application file in the folder and gave myself "read" and "execute" privileges.  That took a long time and didn't help.  I wonder if any new installation will have the same problem.

    I don't believe I touched the "Homegroup" feature.  I have no idea what it's for....  The only thing I can think of what could have triggered it (what I did out of the norm since the original installation) is that I tried using the "make available when offline" option.  I'm not connected to the network now so I don't know the exact verbiage.  Since then, the "Sync Center" icon shows up on my tray.

    I can reinstall Windows 7 RC (sounds like I have no choice) but am afraid that it will happen again if I don't know what is causing it.

    Thanks again.

    Thursday, June 25, 2009 5:07 PM