none
Remote Shutdown problem

    Question

  • Hi,

    I am trying to shutdown (and restart) a Windows 7 (RC1) PC on my home network from another PC running Windows 7 (RC1). I am running the following command at a command prompt (I have tried with and without Administrator privilege):

    shutdown /r /f /m \\backup

    Originally I was getting "Access Denied" but after searching the internet I disabled file sharing on the remote PC and I now get the following error message:


    "backup: The entered computer name is not valid or remote shutdown is not supported on the target computer. Check the name and then try again or contact your system administrator. (53)"

    I have also tried using the IP address and the result is the same.

    I am using the same user name on both PCs, with the same password and the user is a member of the administrator group on both PCs. I have also checked the following policy settings on the remote PC:

    Local Policies:User Rights Assignment:Access this computer from the network: Administrators...
    Local Policies:User Rights Assignment:Force shutdown from a remote station: Administrators
    Local Policies:User Rights Assignment:Shutdown the system:Administrators

    Local Policies:Security options:Network access: Sharing and security model for local accounts: Classic - local users authenticate as themselves
    Local Policies:Security options:Shutdown:Allow system to be shutdown without having to log on.


    Is there anything else to check?

    Thanks

    Patrick
    Wednesday, June 03, 2009 4:52 PM

All replies

  • Can these machines see each other on the network?
    Wednesday, June 17, 2009 4:03 PM
  • Prior to disabling file sharing I could see shared folders on the remote PC and copy files to/from using explorer or from command prompt. Now that I have disabled file sharing I cannot, but I can still connect with remote desktop.

    Thanks

    Patrick
    Wednesday, June 17, 2009 4:23 PM
  • I am having the same issues. Any clue as to what may be going on? I can ping between the two computers without issues. I get the error also with firewall disabled as well as UAC disabled.
    Thursday, March 11, 2010 6:13 PM
  • After spending 4 hours trying to trace the same problem, and using an aftermarket shutdown that allows you to provide a user name and password, I still keep on getting the same error. Seeing this post and others, I suspect this issue will need to be addressed. I hate to say it - I think it's...

     

    A BUG!!!!!

     

    (or, ahem, a "feature"?)

    Tuesday, March 23, 2010 10:42 PM
  • I'm seeing this problem to now. We have been using it for years to shutdown computers at night here at the company. But for some reason af couple of computers are not reachable with the shutdown tool. Fileshareing, ping etc. works fine?!?
    Thursday, May 27, 2010 11:51 AM
  • Try using "shutdown -i". It's less likely to make a mistake.

    In Windows 7 and Windows Vista, the UAC strips administrative priveledges from users that are connecting remotely. This is called the Remote UAC LocalAccountTokenFilterPolicy. Instructions can be found at: http://support.microsoft.com/kb/942817/en-us. This applies to both Windows Vista and Windows 7.

    Wednesday, June 16, 2010 12:02 AM
  • Dear Patric

    try to start server service from services console. i found same problem and after starting server service i was able to get it done.

     

     

    regards

    Saturday, June 26, 2010 8:46 AM
  • I'm having the same problem.

     

    Did anyone find a solution to this problem?

    Monday, August 02, 2010 5:40 PM
  • Sadly we did not. We reinstalled the OS and things were fine again. Would like to have found a better solution.
    Monday, August 02, 2010 9:52 PM
  • I know this is a late response, but when I had the same problem, I discovered that the problem was the firewall setting related to File and Printer Sharing (SMB-IN).  That rule was disabled for the Public profile; I'm not sure what triggers that profile's use over the Domain or Private because the machine is on a LAN with the Domain Controller.  When I enabled that rule, I was able to shutdown the servers.  The puzzling thing for me is that the rule seemed to be "disabled" on its own.  I distinctly remember shutting down all 6 of my servers.  Then 2 weeks ago, I could only shutdown 5.  This week I could only shutdown 4, so I had to enable this rule on 2 servers, and I don't know what would have caused that setting to be changed.  Obviously, if any firewalls change on their own, that would appear to be a large disconcerting bug.

    Just to reiterate, the firewall rule which prevented me from remotely shutdown was the File and Printer Sharing (SMB-IN) Inbound Firewall rule associated with the Public profile.  I enabled it, and I could execute a remote shutdown command.

    • Proposed as answer by ravivo Wednesday, July 30, 2014 7:01 AM
    Friday, November 19, 2010 11:47 PM
  • This too a late response, but solved my problem 100%:

    I remote desktopped in and did the following at the computer: Control Panel > Administrative Tools > Local Security Policy> Local Policies > User Rights Assignment. Double click “Shut Down the System” and click Add User or Group. Type “Everyone” without quotes click OK. The same procedure must be done in “Force Shutdown from a Remote System”. Reboot.

    Now works.

    Tuesday, December 28, 2010 3:24 AM
  • This too a late response, but solved my problem 100%:

    I remote desktopped in and did the following at the computer: Control Panel > Administrative Tools > Local Security Policy> Local Policies > User Rights Assignment. Double click “Shut Down the System” and click Add User or Group. Type “Everyone” without quotes click OK. The same procedure must be done in “Force Shutdown from a Remote System”. Reboot.

    Now works.


    This is a dangerous patch as allowing everyone to shutdown remotely means that anyone could send a shutdown signal to the machine.  This is opening the door to a possible malicious attack.
    Thursday, January 06, 2011 8:44 PM
  • I have the exact opposite problem.

    Any user logging in via RDP can shut down the machine (Windows 7 Ultimate SP1) even if they are member of the guest group or of no group but the Remote Desktop one.

    This is very insecure and I hope it is just a bug and not a 'clever feature' of the product.

    I may however have missed something, so please if this is the case let me know.

    What I did is:

    1. created account 'demo'
    2. made 'demo' member of 'Remote Desktop Users' group and removed from any other group
    3. checked Local Security Policy / User Right Assignments
      - Shut down the system (Administrators, Backup Operators, Users)
      - Force Shutdown from a remote system (Administrators)

    The user 'demo', once logged in remotely, can shut down the machine by clicking on the windows orb, click on 'windows security' and then click on shutdown from the red button on the right bottom side of the screen.

     

    Friday, March 11, 2011 5:54 AM
  • That's true, enabling File and Printer sharing makes it work. Thank you.
    Thursday, June 09, 2011 7:50 AM
  • SMB-IN fixed my issue, thanks!
    • Edited by curtasian Thursday, March 27, 2014 6:51 PM
    Thursday, March 27, 2014 6:51 PM
  • Worked for me - Well done and thank you for the solution.
    Wednesday, July 30, 2014 7:01 AM
  • same problem....

    Monday, March 21, 2016 1:41 PM
  • This used to work, but now when i try to use shutdown -i it returns with the same response that was stated in this article

    Do tell me if there is a way around this

    Best Regards, TheNewestShutDowner

    Monday, November 07, 2016 8:52 PM