none
Cannot Re-image From Network Backup

    Question

  • Windows Ultimate x64
    Windows Workgroup Networking

    I was about to try come major changes to fix an existing problem on my laptop.  Before I did that I created a backup image on a share on another machine on the LAN.

    I am now trying to restore the image.  I booted from a USB drive that has Windows 7 SP1 installation on it.  I selected the System Image Recovery option and of course it could not find the image on the laptop.  Select a system image was selected and I pressed Next.  On the next screen I clicked Advanced to select a network location.  Got to the screen that asked for the location of the system image.  Entered the same location I used when the image was created:  \\<machine name>\Share

    Got to the Enter Network Password screen.  Entered the same userid and password used to create the image and got an error message:
    Re-Image Your Computer
    An internal error occured. The following information might help you resolve the error:
    The network location cannot be reached.  For information about network troubleshooting, see Windows Help. (0x800704CF)

    I did notice this under the Password textbox: Domain: MININT-8TUOLF6

    So I tried putting the name of the machine with the backup in front of the userid: <Machine Name>\userid
    which changed the domain to the name of the machine.  But I got the same error message.

    How do I get to the backup image?

     


    http://www.saberman.com
    Sunday, September 18, 2011 2:26 AM

Answers

  • In system recovery environment, you can't get access to network share unless you have installed NIC driver and assign IP address. To do this,

    1. At the following screen select the “Command prompt” option.

    2. Run the following commands at the command prompt.

    If your network adapter is not included with Windows you need to load the driver using drvload.

    Drvload driver.inf (Where driver.inf is the inf for the network adapter. You can load this from an usb flash drive or the local drive if it is available.)

    Start /w wpeinit

    3. Run ipconfig to verify the driver loaded and you have a valid ip address. If you have to set a static IP address, you could use netsh. For example

    “netsh interface ipv4 set address name = "<idx>" source=static address=<staticIP> mask=<SubnetMask> gateway=<DefaultGateway>”

    Netsh Commands for Interface (IPv4 and IPv6)

    http://technet.microsoft.com/en-us/library/cc770948.aspx

    The issue addresses in the following blog:

    Windows Server Backup 2008 Restore from Network Location

    http://blogs.technet.com/b/askcore/archive/2009/02/04/windows-server-backup-2008-restore-from-network-location.aspx

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by saberman Saturday, September 24, 2011 9:04 PM
    Saturday, September 24, 2011 8:31 AM

All replies

  • Hi,

     

    According to the error message, the issue is caused by the incorrect network access.

     

    Check using ping command from command prompt in WinRE whether the connection to the share can be access or not?

    if it fails to connect , one of the reason could be that fileserver need to be on ipsec boundary if ipsec is enabled on network.

    In another word, WinRE cannot connect otherwise to network location.

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, September 20, 2011 8:17 AM
    Moderator
  • As far as I know ipsec is not enabled unless that is a default.  This is a small lan with one router and the notebook is hardwired to the router.

    I selected Command Prompt from the System Recovery Options.

    Pinging the machine with the share that has the backup image failed with "Ping request could not find host <machine name>.

    I tried pinging the ip address of the machine and it failed with "Unable to contact IP driver. General Failure."

    I got the same error message when I tried to ping the gateway (192.168.1.1).

    Finally I ran ipconfig /all and got:
    Host Name . . . . . . . . . . . . :
    Primary Dns Suffix  . . . . . . :
    Node Type  . . . . . . . . . . . . : Hybrid
    IP Routing Enabled . . . . . . : No
    WINS Proxy Enabled . . . . . : No

    It appears that the Windows startup process when booted from installation media does not load a network driver.  (Did I miss a step during startup?)  So you can back up to a network share but not restore from a network share.

    I copied the backup image to a USB drive and used it to restore the image.

    BTW, I noticed another problem with WinRE -- it decided that my startup configuration was wrong and wanted to change it to boot from the D: drive but the size of the partition indicated it was looking at the C: drive.  I think it got confused by the system partition that is not assigned a drive letter.  This does not convey a warm fuzzy feeling about Windows recovery.


    http://www.saberman.com
    Tuesday, September 20, 2011 10:57 PM
  • Yes, network interface is not load in WinRE. You may need to manually install NIC driver.

     

    When you want to re-image your computer, you can click “Advanced”---“Install a driver”, then install network card driver. After finish installing, try to ping the network share to check if it can access.

     

    Hope that helps.

     

    Regards,

    Leo   Huang

     

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 21, 2011 1:50 AM
    Moderator
  • Yes, network interface is not load in WinRE. You may need to manually install NIC driver.

     Then why did you suggest pinging in the first place that that ipsec might be the problem.

     

    When you want to re-image your computer, you can click “Advanced”---“Install a driver”, then install network card driver. After finish installing, try to ping the network share to check if it can access.

    Tell me how I extract the driver from Windows 7 (which installed it as part of the orginal installation) and create an installation package for WinRE?  I cannot create recovery media because the laptop does not have a CD/DVD burner and the Windows recovery generator is too stupid to write to a USB flash drive.


    http://www.saberman.com
    Wednesday, September 21, 2011 3:21 AM
  • Hi,

     

    Sorry for my late reply.

     

    I have made a test on my machine, and find:

    1 Networking will be enabled when you click find image from network server

     

    2 The network location cannot be reached when the network share a part of  domain. Some GPO or firewall policy or IPsec block the access.

     

    3 When the network share is a part of workgroup, I can access network share on WinRE and success finding the image. By using \\machinename\sharefolder, and input the credential of local admin.

     

    So it should works in workgroup workaround, please turn off firewall and antivirus programs on network share machine for test.

     

     

    Regards,

    Leo   Huang

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, September 23, 2011 3:27 AM
    Moderator
  • Again, this is a small LAN without a Domain Controller.  It uses Windows workgroup networking.  I used \\machinename\sharefolder and used a local admin name and passowrd. 

    The problem is that WinRE does not install a network driver so it cannot find anything on a network.

    Please reread the thread.  From WinRE I cannot successfully ping the router much less the machine that has the share with the backup image.

    If you will post the exact commands you entered to access the network share after booting from installation media I would be glad to repeat the exercise.  Please do not leave out anything.


    http://www.saberman.com
    Friday, September 23, 2011 5:31 AM
  • In system recovery environment, you can't get access to network share unless you have installed NIC driver and assign IP address. To do this,

    1. At the following screen select the “Command prompt” option.

    2. Run the following commands at the command prompt.

    If your network adapter is not included with Windows you need to load the driver using drvload.

    Drvload driver.inf (Where driver.inf is the inf for the network adapter. You can load this from an usb flash drive or the local drive if it is available.)

    Start /w wpeinit

    3. Run ipconfig to verify the driver loaded and you have a valid ip address. If you have to set a static IP address, you could use netsh. For example

    “netsh interface ipv4 set address name = "<idx>" source=static address=<staticIP> mask=<SubnetMask> gateway=<DefaultGateway>”

    Netsh Commands for Interface (IPv4 and IPv6)

    http://technet.microsoft.com/en-us/library/cc770948.aspx

    The issue addresses in the following blog:

    Windows Server Backup 2008 Restore from Network Location

    http://blogs.technet.com/b/askcore/archive/2009/02/04/windows-server-backup-2008-restore-from-network-location.aspx

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by saberman Saturday, September 24, 2011 9:04 PM
    Saturday, September 24, 2011 8:31 AM
  • I downloaded a driver from the manufacturer web site and unpacked the files onto my intallation media.

    I managed to load a driver.  I can ping the machine that has the system image by name or IP address -- I can even ping a web site on the internet.

    I am now able to access the image on the network from WinRE.

     


    http://www.saberman.com
    Saturday, September 24, 2011 9:04 PM
  • In system recovery environment, you can't get access to network share unless you have installed NIC driver and assign IP address. To do this,

    1. At the following screen select the “Command prompt” option.

    2. Run the following commands at the command prompt.

    If your network adapter is not included with Windows you need to load the driver using drvload.

    Drvload driver.inf (Where driver.inf is the inf for the network adapter. You can load this from an usb flash drive or the local drive if it is available.)

    Start /w wpeinit

    3. Run ipconfig to verify the driver loaded and you have a valid ip address. If you have to set a static IP address, you could use netsh. For example

    “netsh interface ipv4 set address name = "<idx>" source=static address=<staticIP> mask=<SubnetMask> gateway=<DefaultGateway>”

    Netsh Commands for Interface (IPv4 and IPv6)

    http://technet.microsoft.com/en-us/library/cc770948.aspx

    The issue addresses in the following blog:

    Windows Server Backup 2008 Restore from Network Location

    http://blogs.technet.com/b/askcore/archive/2009/02/04/windows-server-backup-2008-restore-from-network-location.aspx

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    I just wanted to highlight this answer for others.

    Try using the command prompt and typing wpeinit then setting a static ip.  

    netsh interface ip set address "Local Area Connection" 192.168.1.100 255.255.255.0 192.168.1.1 1

    Afterwards ping the IP not the Name of the server if you get a reply back try to open the image recovery again and entering in your network share location.

    This worked for me!

    Monday, March 04, 2013 7:27 PM