none
No driver installed---system error: MCI Error: There is no driver installed on your system windows vista

    Question

  • I am getting this error everytime I try to use talk now Mutlilanguage CD, I could have sworn when I bought this computer brand new that it came with a drive.  I can play music CD's and DVD's but not this one. This is the error it gives me

     

     I have Windows Vista

     

    system error: MCI Error: There is no driver installed on your system

     

    Thanks for anyone's help I really want to practice learning a different language but I can't hear the CD.

    Monday, February 18, 2008 12:43 PM

Answers

  • Hi Scott,

    Is there a icon named "Talk Now Plus" on the desktop  that was created when installing?

    If it is, please right click it, choose properties, select the Compatibility tab, then selecting 'Run this program in compatibility'' mode for:' Windows XP (Service Pack 2).


    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support



    Wednesday, February 20, 2008 9:46 AM

All replies

  • Hi Scott,

    Is there a icon named "Talk Now Plus" on the desktop  that was created when installing?

    If it is, please right click it, choose properties, select the Compatibility tab, then selecting 'Run this program in compatibility'' mode for:' Windows XP (Service Pack 2).


    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support



    Wednesday, February 20, 2008 9:46 AM

  • Hi,

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios.

    If the issue still persists and you want to return to this question, please reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

    In addition, we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems.

    Thanks!
    --------------------
    Regards,
    Eric Zhang
    Microsoft Online Community Support

    Monday, February 25, 2008 6:03 AM
  • There is a fix available for the Eurotalk products: http://eurotalk.com/tnfixvista.zip

     

    There is quite a few solutions for issues on their website at http://eurotalk.com/en/support.php

     

    Thanks

    Francois de Ridder

    IT Consultant South Africa

    Friday, February 29, 2008 5:55 AM
  • Hi Eric,

     

    I am experincing somewhat the same problem as Scott. I installed XP service pack II like 1 month ago and now i cant use my Talk Now Cd. Prior to me reading the post above i uninstalled TalkNow and tried running it again but the same error occured. The i tried your suggestion as mentioned above but i cant choose XP servicepack II. My only options are windows 95 / windows 98 win Me/ windows NT 4.0 (servicepack 5) or windows 2000. The program wont run with any of these aka i get the same error regardless. Do you have any suggestions??

     

    Regard Helle

     

     

    Friday, April 25, 2008 8:41 AM
  • Hello Helle,

     

    I have just bought the Talk Now CD, and as you I am receiving the same Error Message "MCE Error: Driver not installed."

     

    I also have Windows XP installed on my notebook and cannot see the option under the compatibility settings.

     

    Have you been able to find a solution for this?

     

    Regards,

    Heidi

    Sunday, May 4, 2008 1:33 PM
  • Francois,

     

    For some reason the links you provided does not work.  Keep on receiving the famous "Page cannot be displayed" message.

     

    Regards,

    Heidi

    Sunday, May 4, 2008 1:46 PM
  • I have the same problem - No MCI drivers for Windows.

    I have the Kaplan LSAT Prep CD and it requires the MCI driver.  I could not find it on the Microsoft download site.

    I do not have "Talk Now" and really do not wish to install this on my laptop.

    I saw one note above about the XP Service Pack II but I have Vista.

    thanks
    • Proposed as answer by msspbm Tuesday, May 12, 2009 11:49 PM
    Monday, December 1, 2008 4:19 AM
  • I have a similar problem - I am trying to use a Kaplan GRE prep CD, and after installing it, when I try to open it the error message I get is:

    "This application requires the MCI Drivers for Windows to be installed. Please install the MCI Drivers as instructed in your sound card's user manual."

    I have Windows Vista and I just bought this laptop - I don't even know if I have a separate sound card user's manual. Any ideas??

    Micaela
    Saturday, December 13, 2008 2:13 AM
  • After I got my French v2.0 Instant Immersion cd, I loaded it and got the MCI error described above. After I looked at this page and noticed Eric Zhang's suggestion. I tried it out. It didn't work, so I looked at the system requirements on the box. It says Windows 2000. So I went back to the Compatibility tab described above, and re-set it from Windows XP Service Pack 2 to Windows 2000 and now it works fine. I hope this helps! :D 
    • Proposed as answer by Avila Isgamvul Tuesday, December 30, 2008 11:30 PM
    Tuesday, December 30, 2008 11:30 PM
  • I know its been a while.. but I recently had this problem, when i searched for fixing this error, your suggestion was truly helpful. I felt obligated to create an account just to thank you.
    Tuesday, May 26, 2009 3:06 AM
  • These suggestions did not work for me.  I have tried running it in various compatibility modes with no luck.  I am having this issue trying to use the Kaplan Higher Score program.  Please advise if anyone has any other/new suggestions/solutions.

    Thanks in advance for your help.
    Saturday, July 18, 2009 9:00 PM
  • hey Mr.Eric !
    i was having the same 'no driver installed 'problem ,did the right click and properties thing u said and it's fixed now!! thank u sooooo very much .i was getting terribly frustrated after uninstalling and reinstalling the cd a coupla times.
    God bless u and the microsoft online community support =P
    Thursday, December 24, 2009 9:25 PM
  • I think cause they all gave up and bought Macs. Your answer makes no sense. I hope you get fired cause you're worthless

     

    Saturday, March 20, 2010 7:17 PM
  • Eric:

    I did not see the Talk Now Plus icon you described. I have Windows 7 home premium. How do I install the MCI drivers? I get the error msg.

    "This application requires the MCI Drivers for Windows to be installed. Please install the MCI Drivers as instructed in your sound card's user manual."

    Please help!

    Wednesday, September 15, 2010 11:34 PM
  • It worked. You the man Eric!
    Tuesday, January 11, 2011 1:54 PM
  • Dear EZhang,

    That was indeed EZ! Thank you for your brief, no-hassle solution. I could have otherwise spent hours trying to find a solution and then given up but thanks to you, it took three seconds:)

    ym702

    Sunday, March 13, 2011 6:03 PM
  •  

     THANK U A MILLION TIMES, worked 4 me!!!  (OS: Vista, for "Talk now")

         Thank you very much.

     

     

    Thursday, April 7, 2011 11:44 AM
  • I think cause they all gave up and bought Macs. Your answer makes no sense. I hope you get fired cause you're worthless

     


     Who r u talking 2 this impolite!!!????

    Eric's solution has helped in many cases.

    Thursday, April 7, 2011 11:56 AM
  • I have a similar problem - I am trying to use a Kaplan GRE prep CD, and after installing it, when I try to open it the error message I get is:

    "This application requires the MCI Drivers for Windows to be installed. Please install the MCI Drivers as instructed in your sound card's user manual."

    I have Windows Vista and I just bought this laptop - I don't even know if I have a separate sound card user's manual. Any ideas??

    Micaela

    -

     

     

    found the following solution on a microsoft help forum 

     

    If u r using a desktop, just disconnect ur speakers and

    if u r using laptops, disable all audio output devices from device manager.

    My Computer(Right Click)> Properties> Device Manager

    OR

    Go into the control panel --> hardware and sound --> Manage audio devices 

     and disable all playback devices (right click, disable)

    It works for Windows Vista and Windows 7
    (the devices can be enabled later by again going to Device Manage -> right click -> enable)

     

    found the solution @:

    http://answers.microsoft.com/en-us/windows/forum/windows_vista-hardware/how-do-i-install-mci-drivers-on-my-windows-vista/de171bc1-6c08-4717-a7e9-88ced8a05eb8?page=3

    Friday, October 14, 2011 5:16 AM
  • Excellent solution at last...you are awesome, thanx :)
    Monday, February 6, 2012 9:41 AM
  • I have Windows 7. I am trying to install an LSAT Prep cd and am receiving the same error msg as previously stated. I also do not have a Talk Plus icon.. Please advise on how to resolve my issue.

    Thank You,

    C

    Tuesday, February 14, 2012 8:27 PM
  • i'm now learning chinese and meet this error. thank you for your help. xiexie
    Wednesday, November 28, 2012 9:31 AM
  • Hi Eric,

    How to resolve this issue on win 8. I cannot find anything like 'talk now'!

    I cannot use Kaplan cd due to MCI driver issue.

    Regards, R Tariq

    Sunday, March 24, 2013 8:33 AM
  • Thanks, Eric Zhang
    you solved my problem to
    Wednesday, January 1, 2014 9:43 AM
  • thanks Eric, I had the same problem with my french immersion and I have been searching for an answer for a long time. Again thank you your answer was very simple and it works!

    Regine

    Tuesday, July 15, 2014 3:34 AM
  • Hi Eric, 

    I had the exact same problem. I used your directions to fix the issue and it fixed it right away. 

    Thanks for the excellent directions!

    Regards,

    Rene

    Monday, September 15, 2014 9:04 PM
  • THANK U IT WAS VERY HELPFULL FOR ME MANY THANX
    Sunday, October 19, 2014 10:44 PM
  • I am getting similar problem in windows 10 pro and Throwing MCI error.
    Tuesday, June 12, 2018 11:15 AM