none
Microsoft Tun Miniport Adapter #2

    Question

  • This device cannot start. (Code 10)

    Click 'Check for solutions' to send data about this device to Microsoft and to see if there is a solution available.

    I did the "Check for solutions" and nothing.  I'll also Updated Device Software and received the message the device software is updated.

    I've seen the answer to the 6TO4 adapter problems and wonder if this answer will work for this problem.

    Several people have asked for help and haven't received an answer.

     

     

     

     

    Saturday, January 01, 2011 2:30 AM

Answers

All replies

  • Hi,

     

    You may try the steps in the following KB article:

     

    Description of Code 10-related errors that Device Manager generates in Windows-based computers

     

    Regards,

     

    Sabrina


    This posting is provided "AS IS" with no warranties or guarantees, and confers no rights. |Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Sabrina Shen Friday, January 07, 2011 7:51 AM
    Tuesday, January 04, 2011 7:39 AM
  • Hi Honor,

    I recently had this problem and scoured the internet for some answers.  I couldn't find any conclusive answers.  I lost my network connection which seemed to stop many other processes from working on my computer.  I am not a computer tech so I don't know exactly what the problem was but I also was given a Code 10 for the Tun Miniport Adaptor.  I couldn't connect to the internet so all my help functions were not working.  I decided to try to back-up my files and restore the utilities and drivers and possibly the operating system but this didn't work as again something was wrong with my PC and I couldn't proceed with this task.  Eventually I decided that I would try to restore the system using CONTROL PANEL > BACK UP AND RESTORE CENTRE > REPAIR WINDOWS USING SYSTEM RESTORE (in windows vista).  I initially did this using the automatic restore point but this didn't change anything,  so I tried again by choosing my own restore point date.  It seems to have worked! 

    You should try backing up your files first in any case to be on the safe side.

    Hope this helps. 

    lisa

    Friday, January 07, 2011 7:24 PM