none
BCD does not work RRS feed

  • Question

  • Hi everyone,

    I have actually booted my pc with winPE and applied a WIM image to the C drive. The image was captured before from a reference computer having Windows 7. So what I did on the new PC is as follows:

     

    I created a partition on the disk.

    I labeled it C

    I made it active.

    then I applied the image to this partition

    Now the thing is that I do not have any BCD file. I tried this command:

    bcdboot C:\Windows

    But I receive this error message:

    Failure when attempting to copy boot files.

    I decided to export the BCD file from the PC that I created the image from. So I exported the BCD file from there and imported it here on the new PC.

    Again I restarted the PC but I see the usual error of BOOTMGR is missing. once I run the command bcdedit.exe /v I can see both Windows Bootloader and Windows Boot Manager but I do not know what's wrong that I still can't get rid of this "BOOTMGR is missing" error.

    I tried running this command:

    bcdedit /default {Windows Boot Loader identifier}

    But still didn't work.

    What should I do now? I have done all the steps in migration to Windows 7 right but now that I have applied this image, I am stuck with the task of booting. I have almost tried any commands of bcdedit but maybe in the wrong way.

    Could anyone please show me a way?

    Thursday, October 14, 2010 8:46 PM

Answers

  • Please enter the full path:

    C:\windows\system32\bcdboot C:\windows


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Tuesday, October 19, 2010 7:37 AM
    Moderator