none
Installing Windows 7 spwizeng.dll and autorun.dll issues

    Question

  • Hello,

    I've been having issues installing my Windows 7. When i start setup, I get a D:\Sources\SPWIZENG.DLL is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media...
    I also get an autorun.dll could not be loaded or is corrupt. Setup cannot continue. Error code is [0xC1]

    I currently have:
    Dell Dimension 8400 
    Vista Ultimate SP2
    Pentium 4 3GHz
    Ram: 1 Gb
    32-bit OS

    So, I've read through many other forums and questions about how to fix it and everyone says it boils down to a bad download of the .iso file or a bad burn onto a DVD. I downloaded the VL version x86 through MSDN and burned it onto a DVD using just a basic DVD burner Roxio, using a different computer.

    Now, I'm pretty sure the problem is not a bad iso file or bad burn because I installed Windows 7 onto a laptop perfectly fine and setup starts up fine on another computer that I have using the same DVD. Only when I use the DVD on this computer does it pop up with the above errors.

    I also assumed that there might be an issue with my DVD drive as its had some problems in the past, so I downloaded another copy of the .iso file from MSDN again and tried mounting it to a virtual drive using Daemon Tools. I get the same errors again.

    I don't know if there's a way to replace the spwizeng.dll or autorun.dll files on a DVD, or if there's an issue with these files in my systems folder and I don't know where to find these files that work to replace them. If anyone can help me with this issue, that would be great. Because as you can tell from my RAM, Vista does not like me too much, but I know that 7 at least has less RAM requirements. Thank you.

    - Victor
    Monday, December 28, 2009 7:38 AM

Answers

All replies

  • Hi Victor,

    To make sure you can install the Windwos 7 successfully, I suggest you to run the Windows 7 Upgrade Advisor. It scans your hardware, devices, and installed programs for known compatibility issues, gives you guidance on how to resolve potential issues found, and recommends what to do before you upgrade. You can get it from the following link:

    Windows 7 Upgrade Advisor:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=1b544e90-7659-4bd9-9e51-2497c146af15&displayLang=en

    Since your ISO file is good, you can try to install the Windows 7 via the USB flash drive. You can refer to the following link:

    http://www.intowindows.com/how-to-install-windows-7vista-from-usb-drive-detailed-100-working-guide/

    Hope this helps!


    John

    • Marked as answer by Vivian Xing Monday, January 04, 2010 9:44 AM
    Tuesday, December 29, 2009 8:49 AM
  • I am having the same problem with this dll.  However, I already have win7 Ultimate installed and I am trying to repair the system.  IE 8 will not work, Firefox will not work, and I am now starting to have problems with Chrome.  

    I downloaded the disk image from Technet, used winzip to uncompress the zip file, used windows to burn the DVD.  I get the same issue that Victor had.

    Hope you can help;

     

    Thanks, Rich

    Wednesday, August 18, 2010 3:03 AM
  • I know this reply is late, but I do agree  that the ISO is flawed/corrupt for anyone who reads this. Even if someone says it is flawed, unless you have a md5 to compare it to, it is only a guess. But I gathered proof. 

    Fact: People who have downloaded Windows Vista, or Windows 7 version ISOs  have posted that they ISO worked after they have re-downloaded the ISO again.  I did nd if they won't do that, they should perhaps put the ISO in a Zip file, most likely if it is corrupt the zip will not open and you know your download is messed up.  I did self check. I have never seen a Zipped item that loaded to be corrupt.

    I mounted the Enterprise ISO Trial  so I didn't have to waste a DVD by burning, cause it seems that it is a common thing for people to get corrupt ISO's from MS by the many postings on the web and I did get an Autorun.dll error. 

    Anyway, I copied the files out of the ISO to a folder then did a file compare to the Windows 7 Trial ISO sources folder, but not the sub-folders. Turns out, I found half dozen of mismatches to the DLLs and the XSL files didn't match. I figured the XSL files were just laid out differently, being that they are written in English and should look like a HTML File. In this case, loading the Enterprise XLS files looked more like a Wiped disk.Now I knew the ISO was corrupt.

    I did a small test. I replaced the Enterprise files with the 7 files, and just to see what would happen?. Well, the Enterprise disk made it to the Partioner.  And I didn't replace XLS files, and they looked this.

    sample section.

    ______________start bad XSL

    i         —i  ˜i         ˜i  ™i         ™i  ši         ši  ›i         ›i  œi         œi  i         i  ži         ži  Ÿi         Ÿi   i          i  ¡i         ¡i  ¢i         ¢i  £i         £i  ¤i         ¤i  ¥i         ¥i  ¦i         ¦i  §i         §i  ¨i         ¨i  ©i         i  ªi  

    _____________end truncated copy. 


    Even at this point, I tend to wonder about the Whole ISO, the XLS files should have been like this...

    ------------------start sample----

    <?xml version="1.0"?>

    <xsl:stylesheet
      xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
      xmlns="http://www.w3.org/TR/REC-html40"
      version="1.0">
      <xsl:output method="html"/>

      <xsl:template match="/">
        <html>
          <head>
            <title></title>

    -----------end truncated copy----------

    As you see, even thought the ISO downloaded and Mounted with no error, the XSL files, not being readable in your Language, only says, HEY, this ISO downloads sux's, Better try again..

    I haven't tried tried to install the Enterprise Disk, on the computer, I fret the outcome.




    Saturday, June 30, 2012 6:01 AM