none
"Local Area Connection" doesn't have a valid IP configuration

    Question

  • I got a new computer for christmas, (HP Pavilion p6214y Desktop PC, running Windows 7 64-bit). I'm trying to connect the computer to the internet via the wireless router using an ethernet cord, but the computer doesn't connect, and when i try troubleshooting, it says " "Local Area Connection" doesn't have a valid IP configuration ". I've been searching google, and this seems to be a pretty common problem, tho i have yet to find a proper solution. How do I get the internet working?
    Tuesday, January 05, 2010 5:48 AM

Answers

  • Temporarily turn off firewall on the machine to check the result. If the issue persists, I suggest you bypass the router and connect to DSL modem directly instead for a test.

    • Marked as answer by Novak Wu Monday, January 11, 2010 8:49 AM
    Thursday, January 07, 2010 3:20 AM

All replies

  •    What is the IP configuration on the LAC? Look at the details of the adapter or run "ipconfig"  from a command prompt. If it has an IP like 169.254.x.y it is not getting its config from DHCP on your router and won't see the Internet.

    Bill
    Tuesday, January 05, 2010 6:17 AM
  •    What is the IP configuration on the LAC? Look at the details of the adapter or run "ipconfig"  from a command prompt. If it has an IP like 169.254.x.y it is not getting its config from DHCP on your router and won't see the Internet.

    Bill

    i did what you said, and it did have 169.254.###.###
    if this is the problem, how do i fix it?
    Tuesday, January 05, 2010 6:25 AM
  •  

     

    Hi,

     

    Please try the following steps to troubleshoot the issue.

     

    1. Refresh a new IP address

     

    a. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. In the popup window, type the following commands and press Enter one by one:

     

    ipconfig /release

     

    ipconfig /renew

     

    Then, the new IP address will be obtained. If the issue persists, please proceed to the next steps.

     

    2. Assign a static IP address for a test

     

    a. Click "Start", input "NCPA.CPL" (without quotation marks) and press Enter.

    b. Right click on the connection that you use for the local connection, and then click "Properties".

    c. Click “Continue” to verify the administrator permission.

    d. Click to select "Internet Protocol Version 4 (TCP/IPv4)", and then click "Properties".

    e. Select “use the following IP address”.

     

    Manually set “IP address” (For example, if your router IP address is 192.168.1.1, we can type the IP address as 192.168.1.22. If the router IP address is 192.168.0.1, we should type in 192.168.0.22.)

     

    Manually set “Subnet mask” as 255.255.255.0 (Note: We can use this address as the default subnet mask.)

     

    Manually set “Default gateway” (Note: Default gateway is the IP address of the router.)

     

    Manually set “preferred DNS server” (Note: Preferred DNS server is also the address of the router.)

     

    f. Click “OK”.

     

    3. Upgrade the Wireless adapter driver.

     

    What's the result?

     

    Thanks,

    Novak

    Wednesday, January 06, 2010 8:52 AM
  • Tthor, is the router win 7 compatible???

    if not turn off IP6 on the win 7 boxes, or  buy a win 7 router (I also had issue with an old netgear switch)

    http://www.microsoft.com/windows/compatibility/windows-7/en-us/default.aspx


    Wednesday, January 06, 2010 2:15 PM
  •  

     

    Hi,

     

    Please try the following steps to troubleshoot the issue.

     

    1. Refresh a new IP address

     

    a. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. In the popup window, type the following commands and press Enter one by one:

     

    ipconfig /release

     

    ipconfig /renew

     

    Then, the new IP address will be obtained. If the issue persists, please proceed to the next steps.

     

    2. Assign a static IP address for a test

     

    a. Click "Start", input "NCPA.CPL" (without quotation marks) and press Enter.

    b. Right click on the connection that you use for the local connection, and then click "Properties".

    c. Click “Continue” to verify the administrator permission.

    d. Click to select "Internet Protocol Version 4 (TCP/IPv4)", and then click "Properties".

    e. Select “use the following IP address”.

     

    Manually set “IP address” (For example, if your router IP address is 192.168.1.1, we can type the IP address as 192.168.1.22. If the router IP address is 192.168.0.1, we should type in 192.168.0.22.)

     

    Manually set “Subnet mask” as 255.255.255.0 (Note: We can use this address as the default subnet mask.)

     

    Manually set “Default gateway” (Note: Default gateway is the IP address of the router.)

     

    Manually set “preferred DNS server” (Note: Preferred DNS server is also the address of the router.)

     

    f. Click “OK”.

     

    3. Upgrade the Wireless adapter driver.

     

    What's the result?

     

    Thanks,

    Novak

    i tried everything you listed, short of upgrading the wireless adapter driver (i don't have a wireless adapter on the computer, i am hooking it up with a wired connection)
    Thursday, January 07, 2010 3:12 AM
  • Temporarily turn off firewall on the machine to check the result. If the issue persists, I suggest you bypass the router and connect to DSL modem directly instead for a test.

    • Marked as answer by Novak Wu Monday, January 11, 2010 8:49 AM
    Thursday, January 07, 2010 3:20 AM
  • I found that McAfee has its "Lockdown Firewall" auto enabled.. after dissableing the lockdown, the internet worked fine.. 
    Friday, July 02, 2010 3:44 PM
  • Go into windows explorer and insert this in the address bar: Control Panel\All Control Panel Items\Troubleshooting\Network and Internet Now click on Internet Connections and Follow the fixer's steps
    Wednesday, January 05, 2011 10:56 PM