none
Screen flickering when using Windows Media Center

    Question

  • Hello everyone. So recently my windows media center in Windows 7 (build 7100) 64bit started to make my 42 Samsung Plasma TV flicker when initiated (42" Samsung Plasma Model PN42A450). I have it connected with a VGA cable from my Nvidia GeForce 260. When I use a windows media player or VLC player the flickering does not occur, just when using Windows Media Center. Funny thing is if I use it on my main monitor (Westinghouse 19") it does not flicker. The flickering has occured two days ago, before that it was working just fine. I did not install any software during the two days or any hardware, just windows updates. I already updated my drivers for the video card and firmware for my tv, and that did not solve the issue. I uninstalled any codecs and that did not solve the issue either. I am completely out of ideas at this moment on what to do. Any ideas?
    Thanks,
    Tomas

    additional info: the flickering only occurs when I extend the display in screen resolution setting. When I make my Samsung the only one displayed the flickering does not occur.
    Tuesday, July 28, 2009 10:43 PM

All replies

  • wow 26 views and still no one who could help?? Cmon guys... :)
    Wednesday, July 29, 2009 4:36 AM
  • Quite a few people out there seem to be having the problem but I have not found a solution yet. I am having the issue with Vista 32 bit Media Center with a Vizio LCD TV. I am operating with a single display. Guessing it could be related to the screen refresh rate that we have picked or possibly the video card device driver. This is based on some of the stuff I read while searching for a solution for this problem online.
    Friday, August 14, 2009 4:18 PM
  • You may try adjusting the refresh rate in the Media Center settings. I had a similar problem with Vista, and that seemed to do the trick. Media Center usually changes the display settings while it is running. With TVs, the refresh rate seems to matter more.

    However, with my same machine but with Win7 the flicker is back. I had to go down to 30Hz (much lower than my Vista setting) for the main system setting to make it stop flickering. But Media Center won't allow me to select those same settings and refresh rates. 



    If anyone from Microsoft reads this; There should be a way to force Media Center to use the same display/resolution settings that the rest of the system is using.
    Thursday, December 31, 2009 1:46 AM
  • Hi guys, you certanly got rid of the problem you have with flickering but I'll post the solution and it's so easy and got nothing to do with refresh rate or graphic drivers or anything like that...The issue comes from the graphic card settings, I for example have nvidia geforce 9800gt,and  the 186 driver comes along with the 3d stereoscopic something, I realized it troubled me with some other games like Age of empires 3 and C.S.I resulting in weird green and red colours and this setting have to do something with compatibility between the card and the software (games)...So...I turned off stereoscopic 3d (unchecked) and I restored my other settings to default and there it goes... I have a full screen with no flickering and damn I'm so glad to see that, so to anyone still looking for solution do not install suspicious beta programs or drivers or fixes for it is not the problem, you just set your VGA 3d settings...Hope someone benefits from this post...cheers
    • Proposed as answer by DarrenPearson Sunday, May 23, 2010 2:23 AM
    Saturday, February 27, 2010 12:20 AM
  • Thanks so much Zoki Dame! I have an older ATi card and I simple reset it (through Catalyst Control Center) to factory defaults and the flickering is gone! =D   Thanks again!
    Friday, May 14, 2010 6:48 AM
  • Glad I was able to help...enjoy your media center...  :)
    Friday, May 14, 2010 7:10 AM
  • I am running Windows 7 mediacentre with 8800GTS. I turned off all of the 3D optimisation for Windows Media Cenre through the NVidia Control Panel. Flicker has disappeared.

    Thanks Zoki Dame.

    Sunday, May 23, 2010 2:23 AM
  • For me, in the ATI drivers for a Radeon 5570, I had to uncheck "enable dynamic contrast".  The smoothvision settings were NOT the problem.

    • Proposed as answer by 3119 Tuesday, June 15, 2010 3:17 PM
    Thursday, May 27, 2010 9:43 PM
  • I fixed the image flicker in WMC simply by changing the display theme from an Aero theme to Windows 7 Basic.  Go to Control Panel/Display/Personalization  to change to a basic theme

    I ran into the same problem just yesterday after installing a Diamond ATI Wonder Hd 750 USB TV Tuner on my 6 month-old HP Pavillion Entertainment PC running 64 Bit Windows 7 Home Premium.  FWIW, the problem only existed with WMC; the image was completely stable with the HP live tv software that came with this laptop as well as with the Total Media 3.5 software that came with the USB tuner.

    • Edited by jampatashi Monday, June 14, 2010 3:42 AM
    Friday, June 04, 2010 10:44 PM
  • I just discovered that if I maximize the window the flicker returns.  So it appears, apart from switching to a non-aero windows 7 theme, one may also have to run WMC in a non-maximized window.  I was able to get rid of the flicker by simply closing down WMC and restarting it in a non-maximized window. 
    Monday, June 14, 2010 3:38 AM
  • I had this issue that cropped up suddenly. I thought it was drivers, conflicting .dlls etc. What fixed 100% it was removing the DVI to HDMI adapter and going straight hdmi. Could also have been a loose connection or something like that on the cable or even the adapter was beginning to go defective.

     

    Some background on why I used the adapter: an XFX GT240 card that, when the TV was turned off and it didn't detect signal, would not re-initialize HDMI when the TV was turned back on. I even warranty'd it and had it replaced. Seems to be a software/hardware issue as this is the first card that does this.

    Hope this helps someone.

    Tuesday, May 17, 2011 1:22 AM
  • This is an old post, but it's the first one that came up when I searched.  I figured I would share what's worked for me.

    Gear
    I had the same issue.  I'm running a Win 7 Pro 64-bit on an ASRock Z68 Extreme 4, with a Zotac GeForce 550 Ti.   Attached to the GeForce I have two 30" Dell (3007WFP and U3011), both via Dual Link DVI running @ 2560*1600.  Attached to the motherboard DVI i have a 24" 1080p monitor.  NVidia 285.62 driver.

    Problem
    Running media center TV stream on the second dell monitor (non-primary) generated random flickers on the bottom half or momentary blanks on the whole screen.   The problem increased as the size of the media center window expanded-- meaning if i kept it to 1/8 the screen i got no blanks, at 1/4 and up it started to blink getting progressively worse as size increased.

    This problem did not occur when the 2nd dell monitor was connected using display port.   Unfortunately, windows 7 doesn't recognize display port as HDCP enabled.

    Change 1
    In the 3D Settings --> Manage 3D Settings --> Global Settings changing "power management mode" from "adaptive" to "Prefer maximum performance".  Adjusting this setting reduced instances in blanking to almost zero at all sizes except full screen.  At full screen small, but tolerable, blanking still occurred.

     

    Change 2
    In the 3D Settings --> Manage 3D Settings --> Program Settings --> Windows Media Center i changed a few settings.   I suspect you can do these changes instead of the first set of changes.

    • Anisotropic filtering -> off
    • Antialiasing - Gamma Correction --> off
    • Multi-display/mixed GPU acceleration --> multiple display performance mode
    • Power Management Mode --> perfer maximum performance
    • Texture filtering - anisotropic sample option --> off
    • Texture Filtering - Negative LOD bias --> allow
    • Tripple buffering --> on
    • Vertical sync --> force on

    This group of settings solved my flickering problem 99%.  Although, the crawl on news channels like CNBC is a little choppy looking. I suspect I could tweak these settings to have fewer customizations.

    Hope this helps someone.

    • Proposed as answer by RobertAUT Wednesday, November 23, 2011 10:49 AM
    Wednesday, October 26, 2011 2:41 PM
  • Thank you so much Eric-Barr!

    I had a problem with browsing and screen flickering (basically turning on an off for itself, as it took sometimes over 2 seconds for screen to appear back). It mostly appeared only in full screen, but sometimes even in a window which was not maximazed. This switching off or flickering was only on selected sites and appeared one day without any obvious reason for me.

    I adjusted the settings like you suggested in Change 2 for Mozilla Firefox and the switching off / flickering disappeared! Well done - it took me only about 6 hours to find a solution for this... :-(

     


    • Edited by RobertAUT Wednesday, November 23, 2011 10:55 AM
    Wednesday, November 23, 2011 10:54 AM
  • Thanks Eric-Barr but I have tried your method and still get green flickering when I have Media Center loaded.  I have a GeForce 570 and am using 295.73 drivers from NVIDIA.

    One workaround I found that worked for me was installing the 3DTV Play from NVIDIA and  setting to 720p. It solved everything but now Im in 720p instead of 1080p.

    Im using a Samsung 3D HDTV as my monitor.

    Is there a possibility its a sign that my HDMI cable is going bad?
    • Edited by tecknotot Monday, March 05, 2012 1:03 AM
    Sunday, March 04, 2012 5:31 PM
  • tecknotot: I suggest that you repost this at the Windows Entertainment and Connected Home forums, there are some Windows Media Center experts there:

    http://experts.windows.com/frms/windows_entertainment_and_connected_home/f/114.aspx


    Tim De Baets
    http://www.bm-productions.tk

    Thursday, March 08, 2012 8:00 PM
  • Thank you so much for posting!
    Tuesday, April 17, 2012 7:40 PM
  • For me, in the ATI drivers for a Radeon 5570, I had to uncheck "enable dynamic contrast".  The smoothvision settings were NOT the problem.


    This is what did it for me too.  Just build an HTPC based on an AMD A4.  I am using the built-in video which is some 6xxx radeon variant.  I had flickering ONLY on the Cinemax channels.  Showtime and all non-premium channels were ok, although Showtime is on a "free preview" this weekend.  I initially thought it had something to do with the copy protect flag and HTCP.  Even in a window it flickered (the WMC window only).  I turned off dynamic contrast in the catlyst control center and magically the flicker was gone.
    Saturday, January 12, 2013 5:36 PM
  • My solution involves an Nvidia 8800GT. Or, actually, ignoring it an sticking to Microsoft's driver. I don't game, so I don't know the effect(s) there. I did these things:

    1. uninstalled all nvidia programs -- everything I could find. I used the Nvidia installers if/when they provided options to "uninstall." Then, I used the windows windows device manager to uninstal the graphics driver. I ignored the prompt to reboot, & instead:

    2. ran CCleanup. That deleted files & folders littering the HDD plus files & folders referenced in the Registry.

    3. Rebooted.

    4. Went to device manager to install a graphics driver. Go slow here....

    5. the trick that works for me: avoid automatically finding the driver AND insuring that any Nnvidia driver does not install. I found on my system (using the "let me choose the driver on my computer" or words to that effect) a windows, not Nvidia, driver. Mine was a 1.1 Microsoft driver--may have come from the Vista days, though I'm using Win 7 Pro.

    6. Rebooted.

    So far so good after a few days. I suspect that Nvidia programs install all kinds of things I don't need for smooth TV/DVR viewing. CCleaner removal screens had a lot of them. Got tired of figuring out where to disable 3D & other graphic card stuff. etc. YMMV. --Ed



    • Edited by em77 Saturday, January 12, 2013 11:19 PM
    Saturday, January 12, 2013 11:12 PM
  • Well, like Eric said. This is a VERY old thread but the first one to come up in a web search. It helped give me a starting point for troubleshooting so here goes my solution.

    I'm running Windows 8.1, and I must say I am quite impressed with the sound and video quality over windows 7 wmc. I think it's actually windows 8 that improves sound and video quality. I'm especially happy with the Netflix app. And for that alone I am sold on windows 8! I'm kind of disappointed WMC wasn't enhanced especially since we have to pay $10 for it.

    Back to the topic at hand! I am using the intel graphics 3000 with an HDMI connection to a 52" Sammy lcd. When I was watching HD channels there was a flicker SD channels didn't flicker. With Win 7 WMC I never had a flicker. So when looking through the advanced settings in the intel graphics properties I noticed the refresh rate was set to 59P Hz and so I set it to 60P Hz and the flicker went away. Not sure how it got set to 59P Hz but glad it was easily fixed.

    John

    Friday, February 07, 2014 4:00 AM
  • Actually the Hz setting didn't fix it. It turns out that Adaptive Contrast Enhancement was the cause. It's on by default. It can be found in the advanced settings for my Intel video card (hd graphics 3000) under Media, Image Enhancements, and uncheck Adaptive Contrast Enhancement. The flickering goes away immediately after unselecting that. Hope this helps someone with a similar setup to mine.
    Friday, February 07, 2014 11:51 PM