none
Windows 10 Enterprise N edition - Not allowing SMB connections. RRS feed

  • Question

  • Greetings, 

    After weeks of troubleshooting my Gold Image not allowing SMB connections for shared folders on local machines, along with no access to the admin share (C$), and not allowing remote Computer Management. I've determined, it's the edition of Windows 10 I am using. Originally, I started with the N edition, to remove a little bloat from the Gold Image. After trying numerous tips on the Internet to restore SMB connectivity: Disabling/Re-Enabling SMB 1.0/CIFS File Sharing in Windows Feature, Adding Firewall rules to allow port 445 inbound/outbound, Turning on File and Pritn Sharing, Regedit LmCompatibilityLevel, Regedit LocalAccountTokenFilterPolicy, and several other suggestions. 

    None of these fix actions have worked. So, I rebuilt the Gold Image using just the regular Enterprise edition. Re-imaged a system that had the broken N edition on it, and it worked immediately without having to make any changes. I have probably close to 100 machines in my domain with this broken N edition Windows 10. Is there something specific in N edition that is refusing SMB connections, that I can change and restore this feature? 


    • Edited by BCasillas Monday, July 9, 2018 1:07 PM
    Monday, July 9, 2018 1:06 PM

All replies

  • Hi,

    Any errors when you attempt to access the network share and remote computer? What if you turn off the Firewall and security software?

    Have you tried to re-download the Windows 10 Enterprise N edition from your Volume License center to install on one test machine for test.

    In addition, apply the latest Windows Update KB4284848 to your image. Since it fixed one SMBv1.0 issue.  


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, July 10, 2018 7:03 AM
    Moderator
  • I have this issue with the v1709 and v1803 N Edition Windows 10 Gold Images I have built over the past few months. I will try the new Windows Update and report back. Also, I have tried completely disabling the Firewall and Windows Defender to no avail. The error I normally see is:

    Error Code: 0x80070035

    The network path was not found.

    Clicking the Diagnose button I see:

    Windows can't communicate with the device or resource

    It is available but is not responding to connection attempts. A firewall or network security policy on the remote computer might be blocking the connection on port "file and print sharing resource".

    I get this error, with or without the Firewall enabled and with or without File and Print sharing enabled on all network profiles.

    Tuesday, July 10, 2018 8:19 PM
  • I installed the Windows update last night, no changes.

    I went through that article and disabled SMBv2 on both Enterprise N machines, get the same error message. Re-enabled SMBv2, still get the error message. 

    I have a VM, that is not joined to the Domain. It's what my current Gold Image(Windows 10 Enterprise v1803) came from that allows SMB connections. I can get prompted for user credentials, when attempting to UNC to \\%IPADDRESS%\c$.

    So, I checked the registry under the LanmanServer settings. I duplicated the settings in there over to the Windows 10 N Edition machine. Still cannot browse to it's admin share via \\%IPADDRESS%\c$.

    To recap, I have a VM running Windows 10 Enterprise v1803 that allows SMB connections and admin share access. I have 2 x Enterprise N edition laptops one is v1803 and other is v1703 that do not allow SMB connections and admin share access. I duplicated the Lanmanserver settings from the VM over to the v1803 N Edition machine, still no luck. SMB1 and SMB2 are enabled on all machines.


    Wednesday, July 11, 2018 1:38 PM
  • Hi,

    Could you ping each other on your Windows 10 Enterprise N?

    If no, what's error message?

    Do the following operation on your Windows 10:

    Step 1: Please open Services console, make sure the following services' startup type is "Automatic" and status is "Running".

    • DNS Client
    • Function Discovery Resource Publication
    • SSDP Discovery
    • UPnP Device Host

    Step 2: Turn on the network discovery for all network profile using command:

    1. Open Prompt command(Admin).

    2. Type the following command:

    netsh advfirewall firewall set rule group="Network Discovery" new enable=Yes

    Step 3: Check if those PCs set disable NetBIOS over TCP/IP in the NetBIOS settings:

    1. Open Control Panel \ Network and Internet.

    3. Click Change adapter settings.

    3. Right-click your connection, and then click Properties.

    4. In the This connection uses the following items list, double-click Internet Protocol Version 4 (TCP/IPv4), click Advanced, and then click the WINS tab.

    5. In NetBIOS settings, there are there options.

    Besides that, type ipconfig /flushdns in the command prompt as Admin to flush the DNS.

    Finally, reboot the computer to check the result.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 13, 2018 1:57 AM
    Moderator
  • I can ping each machine with no issues. I've checked all the settings you suggested. Only change was enabling UPnP Device Host and enabling Network Discovery for every network profile. Still cannot connect to the admin shares on these machines. I even completely disabled the Windows Firewall on one of the machines to rule it out with the changes. 

    Might just need to throw in the towel and re-image these machines. There is practically no difference between these machines, other than the edition. Services, and security settings are the same. Yet, the N Editions will not allow SMB connections. Thanks for your help and time! 

    Tuesday, July 17, 2018 1:47 PM
  • What if you re-image?

    If so, you can try this provided by other members used to resolved similar problem:

    Unchecked File and Printer Sharing for Microsoft Networks in the NIC settings. Applied the change.  Checked it.  Applied the change. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, July 18, 2018 8:04 AM
    Moderator
  • I can ping each machine with no issues.

    See if you can make use of PowerShell  Test-NetConnection  instead.  E.g. in particular test the protocol that matters instead of just ICMP connectivity.   ; )

    Test-NetConnection  -?   |  Out-String  -Width 90

    for help and syntax.



    Robert Aldwinckle
    ---

    Thursday, July 19, 2018 3:42 AM