none
Fast Ring update to builds 17711 & 17713 fail with blue screen "microcode version mismatch" RRS feed

  • Question

  • Wow, somehow the title of this post describes the whole problem. I have not been able to load the last few updates.  The update seems to work but upon reboot, I get a blue scree with "Microcode Version Mismatch"  Repeated attempts do not help.  Revisiting setup, the reported error is 0x1900101.

    Anyone else see this?

    Is there a fix?

    Bill


    • Edited by Bill W_1 Thursday, July 12, 2018 1:48 PM add info
    Thursday, July 12, 2018 1:17 PM

Answers

  • FIXED by build #17744!

    A the point of failure on the earlier builds, the system reboots and proceeds with setup.  Oh happy day.

    Bill

    • Marked as answer by Bill W_1 Friday, August 24, 2018 2:22 PM
    Friday, August 24, 2018 2:22 PM

All replies

  • This error code is generally followed by another because it's a generic code when the upgrade fails (0xc1900101)
    The last time I had this kind of problem, I  had to search a lot for the second code in the different logs.

    There's a new tool (Setupdiag) that may help to troubleshoot the upgrade but if it's happening after each upgrade, it should be reported in the Feedback Hub so the logs can be uploaded and analysed by the Dev Team.

    Gérald



    Thursday, July 12, 2018 2:38 PM
  • Gérald,

    Thanks for the info on SetupDiag.  that's a very useful tool.  In my case it revealed that the whole error code is:

    0x1900101-0x20017

    For some people this appears to be caused by virtualization.  Not in my case.  I truned off the virtual machine capability an got the same error.  this is an AsRock MB, by the way.  No USB devises plugged in.


    • Edited by Bill W_1 Thursday, July 12, 2018 4:50 PM
    Thursday, July 12, 2018 4:49 PM
  • Maybe this can help ;-)

    Code:0xC1900101 - 0x20017

    Cause

    A driver has caused an illegal operation.
    Windows was not able to migrate the driver, resulting in a rollback of the operating system.
    This is a SafeOS boot failure, typically caused by drivers or non-Microsoft disk encryption software.

    Mitigation
    Ensure that all that drivers are updated.
    Open the Setuperr.log and Setupact.log files in the %windir%\Panther directory, and then locate the problem drivers.
    Update or uninstall the problem drivers.

    Gérald
    Thursday, July 12, 2018 4:57 PM
  • A logical approach, but nothing leaps out to me as the problem.

    • Edited by Bill W_1 Saturday, August 18, 2018 11:57 PM
    Thursday, July 12, 2018 9:25 PM
  • Your share folder has many files, I can’t pick out which file is the log file.

    About microcode version mismatch, it seems that your device motherboard architecture needs to be updated first before we can proceed in doing the Windows update. I suggest that you get in touch with your device manufacturer for inquires to get an update for your motherboard architecture or if there's any way to update the microcode version. Once done with that, proceed with the Windows update.

    Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 13, 2018 8:57 AM
    Moderator
  • By microcode, I assume you mean BIOS.  Am I correct?  I am running the latest BIOS.  Getting in touch with AsRock in a meaningful way would be a challenge.
    Friday, July 13, 2018 1:26 PM
  • Build 17723 also fails.
    . No solution found. Anyone have an idea?
    • Edited by Bill W_1 Saturday, July 28, 2018 6:35 PM
    Thursday, July 26, 2018 3:16 PM
  • Build 17733 fails with the same error.
    Wednesday, August 8, 2018 9:29 PM
  • Build 17741 fails with the same error. Nothing from Microsoft on the feedback hub.
    Saturday, August 18, 2018 11:53 PM
  • As Teemo stated before, your Onedrive Shared folder contains too many files. Please clean it because you're sharing a lot of personal information to everyone and provide an easier way to find your logs.

    And it seems that you only shared the setuperr.log...You should create a .zip containing all the files in the panther folder for analysis...

    I've upvoted your feedback to see if this can help ;-)

    Gérald


    Sunday, August 19, 2018 10:27 AM
  • You folks are right, of course. I destroyed the old link. I will retrieve the error log and repost it properly. My attempts to installl the latest version may have changed the error logs contents anyway.

    Here it is:  https://1drv.ms/f/s!AmXKqAwyCrbxiIQx0UNqrCjBzASHjQ

    • Edited by Bill W_1 Sunday, August 19, 2018 10:38 PM
    Sunday, August 19, 2018 9:38 PM
  • Indeed, SetupDiag don't see an error in these logs:

    SetupDiag was unable to match to any known failure signatures.
    System Information:
     Machine Name = Offline
     Manufacturer = To Be Filled By O.E.M.
     Model = To Be Filled By O.E.M.
     HostOSArchitecture = x64
     FirmwareType = PCAT
     BiosReleaseDate = 20130711000000.000000+000
     BiosVendor = BIOS Date: 07/11/13 20:48:38 Ver: 04.06.05
     BiosVersion = P2.30
     HostOSVersion = 10.0.17686
     HostOSBuildString = 17686.1003.amd64fre.rs_prerelease.180603-1447
     TargetOSBuildString = 10.0.17741.1000 (rs5_release.180814-1430)
     HostOSLanguageId = 1033
     HostOSEdition = Professional
     RegisteredAV =
     FilterDrivers =
     UpgradeStartTime = 18-08-18 09:30:00
     UpgradeEndTime = 18-08-18 10:47:50
     UpgradeElapsedTime = 01:17:50
     ReportId = 597AD29E-E21F-4F75-8D24-9E2C7BCE4B24

    Since you're still on build 17686, have you tried to upgrade using the latest ISO from the slow ring?
    This could be faster for testing the upgrade than trying to download the latest fast ring release and if you have the possibility, you can also try a clean install from the media.

    Gérald

    Monday, August 20, 2018 12:30 PM
  • FIXED by build #17744!

    A the point of failure on the earlier builds, the system reboots and proceeds with setup.  Oh happy day.

    Bill

    • Marked as answer by Bill W_1 Friday, August 24, 2018 2:22 PM
    Friday, August 24, 2018 2:22 PM