none
Downloads Folder Slow to Load RRS feed

  • Question

  • When I open any folder on my PC in Windows 10, the folder opens immediately.  The exception is the downloads folder.  When I click on the downloads folder it can take up to 20 - 30 seconds while the OS seems to do something in the background.  I don't need the folder indexed or searchable - I normally just need the most recent download.

    Does anyone know what causes this and how to make this folder behave like all other folders?


    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    Sunday, January 15, 2017 10:04 PM

Answers

  • Hi,

    I consider that this issue could be caused that there is any big files in your Download folders.

    Please first uncheck Download in Indexing option:

    Then, please check if the Customized type is General items in Download properties:

    Change as what I mentioned and check if your issue still happens. In addition, please save the file from Process monitor and upload the PML files onto OneDrive and share the link here for our research.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 19, 2017 10:21 AM
    Owner

All replies

  • Try using Proc Mon and check what's taking that long. 

    https://technet.microsoft.com/en-us/sysinternals/processmonitor.aspx


    Arnav Sharma | http://arnavsharma.net/ Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Sunday, January 15, 2017 11:33 PM
  • Thanks.  I did that but admittedly I wasn't really sure what I was looking for.  I noticed lots of missing registry keys so I cleaned that up - but it didn't help.

    This must be something that is not unique to me as I see lots of people asking questions about it.


    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    Tuesday, January 17, 2017 10:38 PM
  • Hi,

    I consider that this issue could be caused that there is any big files in your Download folders.

    Please first uncheck Download in Indexing option:

    Then, please check if the Customized type is General items in Download properties:

    Change as what I mentioned and check if your issue still happens. In addition, please save the file from Process monitor and upload the PML files onto OneDrive and share the link here for our research.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 19, 2017 10:21 AM
    Owner
  • Sorry for my slow reply - I wanted to do some testing. 

    Firstly I deleted a couple of 4GB files, but that has had no impact.  It only happens the first time I open the folder for "a while" what ever that means.  I currently have 208 files and it took 23 seconds to open today.


    I will now try the other things (un-index, customised types).  Interesting is that the folder type was set to "picture".  I am feeling good about this change and will report back how it goes.  Thanks for the ongoing suggestions and support


    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    Saturday, January 21, 2017 8:01 PM
  • I consider this now resolved.  Thanks to all that helped. The problem was resolved when I changed the customized file types to General - it was set at picture for some reason.  This single step fixed the problem.

    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    • Proposed as answer by Tomas An Wednesday, April 11, 2018 12:02 PM
    Sunday, January 22, 2017 5:12 AM
  • This seems to have corrected the problem, thank you.
    Monday, April 9, 2018 5:53 PM
  • Yes! It was set to "Picture" inst/of "General" - this seems a MS bug, since that is a system setting. Indexing response should care about number of files more than the size of individual items. 
    Wednesday, April 25, 2018 3:31 PM