none
Problems with Fallout 3 + Steam in Win7 x64

    General discussion

  • Hello all,

    I'm new to this forum and I thought I'd drop a line about Steam and Fallout 3 in case anybody here is experiencing the same issue.  Almost all the programs I use are running perfectly fine under Win7 x64.  Steam runs fine and most of my games within Steam also run without a hitch.

    That is, except for Fallout 3.  When I launch the game I see the opening menu where you can adjust your performance settings.  This is all normal so far.  Then I click the Play button to get the game started up... and nothing happens!  No error.  No popups.  Nada.

    I used the verify files button in Steam and it found no errors.  I tried running as administrator, and running under compatibility mode.  Updated gfx card drivers.

    I'm not expecting a fix of course, this is still beta and all that, but maybe somebody around here has an idea or two.  I have not yet tried uninstalling/reinstalling the game but most likely I'll try that over the weekend.  I should note that the game works perfectly fine on the same computer while booted into XP.
    Friday, January 16, 2009 4:53 PM

All replies

  • Not that this helps solve the problem, but I wanted to weigh in that I have the same issue myself, so it isn't just your system.
    Friday, January 16, 2009 5:06 PM
  • When I first installed Fallout 3 it ran fine all the way up until it caused a BSoD. Now, even after an uninstall and reinstall, it will not get past the Fallout Launcher screen. I'm going to try wiping and reinstalling Win7 X64 and start over if going back to a Restore Point doesn't work.
    Friday, January 16, 2009 5:19 PM
  • Hey grwoods,

    What kind of card are you running (ati,nvidia) ?
    What driver ?

    I'm running a Nvidia 8800GTS 512mb (G92) with the last official driver (181.20)
    (just saw that there is a new beta 182.22)
    I had the game freeze up on me a few times.
    Same problem I have with GRID and Mirror's Edge.
    The way to get them working was to, "turn off PhysiX" in the controle panel.
    For Nvidia cards that is.
    And now it works fine most of the time.
    I do have some 'freezing' going on, but far less that before.

    Gtz. DW

    Ps. I have the Non steam version of the game
    Friday, January 16, 2009 6:34 PM
  • hi, I have very simillar problem with win7 x32 - I'm testing this to be different than everybody else ;) Anyway, my configuration is Athlon 64 3200+, 2GB DDR400, GF8800GT with latet Beta drivers. Everything ran perfectly until I played inside the Vault. After going out problems started - I make a few steps and the game is freezing. At minimum resolution and detail it works better. TYurning off PhysiX gives no results unfortunately. I hope good folks from Redmont will find solution soon :)
    Tuesday, March 17, 2009 4:48 PM
  • Its weird, i have windows 7 x64 and it downloads through steam, and sticks on thedotnetfx install saying i need to do something with hardware features in the control panel. so once that s happend clicking on the seemingly installed Fallout 3 icon in my games list, the launcher comes up with an INSTALL button where the PLAY button should be. Clicking on this claims that i am using the DVD-ROM version (a load of rubbish seeing as i downloaded itfrom steam) and that the setup.exe could not be located..... which is true, as there is no sign of a setup exe in the game directory. so i dont even get to the freaking main menu.! before i break my hand punching the wall.......any ideas?
    • Edited by m0ochach0 Tuesday, July 07, 2009 2:35 AM
    Tuesday, July 07, 2009 2:31 AM
  • Hey, I know you asked this a LONG time ago, but I am having the same problem, and I am wondering if you got it fixed?
    Thursday, April 29, 2010 12:52 AM
  • You're not the only one who has this issue.  Has anything been resolved with this?  (I'm on Windows 7 64 Pro here)
    Monday, June 14, 2010 12:27 PM
  • The above worked for me. I've been playing fallout 3 for several hours with mostly no problems. I would freeze up every hour or so, but changing to Window'd mode completely resolved that issue. Then when I was getting further along (my save games are around 3.9MB - 4MB), it would freeze predictably as I walk down certain corridors. I turned graphics all the way down, but the particular corridors would freeze me up.

     

    I did the above with...actually I just realized this is a different forum that doesn't have this solution posted. Anyway, someone suggested:

    Open Documents/My Games/Fallout3/FALLOUT.INI

    Find the line that has "bUseThreadedAI=0"

    Change it to (2 lines):

    bUseThreadedAI=1
    iNumHWThreads=2

    I have Win7 x64 Quad core. The guy on the other forum said that quad cores were having issues with threaded AI, and this was supposed to do something. I decided I had nothing to lose (easy to change, try, and then change back), and it worked!

    Good luck,

    Matt

    Tuesday, June 29, 2010 2:27 PM
  • I Jacked with this for some time and found that closing steam and running as an Administrator made Fallout 3 magically work. running as user gave the Install option on the launcher. Running as Admin gave me the Play option. very strange. 

     

    Hope this helps everyone.

    Sunday, August 15, 2010 5:14 AM