none
KB4338814 causes Microsoft VBScript runtime error '800a01ad' ActiveX component can't create object: 'System.Text.UTF8Encoding' RRS feed

  • Question

  • Starting with yesterday's installation of KB4338814, we receive an error in our ASP pages where we use System.Text.UTF8Encoding. Error is Microsoft VBScript runtime error '800a01ad' ActiveX component can't create object: 'System.Text.UTF8Encoding'.  Error goes away when we remove KB4338814.  Can this be fixed?

    • Moved by Ajay Kadam Thursday, July 12, 2018 5:05 AM better suited here than Azure AD
    Wednesday, July 11, 2018 8:49 PM

Answers

  • Starting with Tuesday's newer update (KB4343887), we no longer have this problem.  The older update(s) went away too.


    • Marked as answer by ChrisRh Friday, August 17, 2018 11:27 AM
    • Edited by ChrisRh Friday, August 17, 2018 11:28 AM
    Friday, August 17, 2018 11:27 AM

All replies

  • We have the same problem.
    Monday, July 16, 2018 9:13 AM
  • Same problem here. Besides, we can no longer restart the www service after we installed the July Windows Update. The service locks in "stopping" mode forever and we have to restart the server.

    Erro no task scheduler

    Monday, July 16, 2018 4:15 PM
  • The same thing happens with the update KB4338825
    Monday, July 16, 2018 4:42 PM
  • July 19, I'm having same problem with my scripts as well. 

    And this is LIVE!

    This will break a lot of my LIVE servers too...

    KB4345421


    Wednesday, July 18, 2018 9:42 PM
  • We have the same problem windows server 2012 R2
    • Edited by Sarvex2018 Thursday, July 19, 2018 3:14 AM
    Thursday, July 19, 2018 2:30 AM
  • The same problem in KB4338815 with Win Server 2012

    Thursday, July 19, 2018 2:49 AM
  • Has anyone got a solution at all to this? 
    • Proposed as answer by EckiS Friday, August 17, 2018 5:20 AM
    • Unproposed as answer by EckiS Friday, August 17, 2018 5:21 AM
    Thursday, July 19, 2018 3:45 PM
  • Microsoft has acknowledged the issue and is actively working on a solution.

    Erro no task scheduler

    Thursday, July 19, 2018 3:49 PM
  • Found this, and it worked for me:

    On "Authentication" option, on your web application, double click, select "Anonymous Authentication", click edit... If you have, "specific user " option selected, change it to "Application pool Identity."

    Friday, July 20, 2018 4:57 AM
  • Anyone know if there is a fix for this other than the IIS change, which has not worked for me?
    Monday, August 6, 2018 7:01 AM
  • Starting with Tuesday's newer update (KB4343887), we no longer have this problem.  The older update(s) went away too.


    • Marked as answer by ChrisRh Friday, August 17, 2018 11:27 AM
    • Edited by ChrisRh Friday, August 17, 2018 11:28 AM
    Friday, August 17, 2018 11:27 AM