none
Fix for Unidentified Network - Local Only Vista Issue

    Question

  • If anyone who is having issues with Windows Vista and being unable to connect to the Internet, hopefully this is of use.
    I have been having issues with this for months since I got my laptop. Have never been able to connect wirelessly without receiving "local only" and just recently had it develop into an issue with wired internet as well. Anyways just a bit of background on my PC specs. I am running Vista Ultimate 32 bit. PC is an ASUS N50VN. Running Trend Micro Internet Security 2010. Have kept all my Windows Updates up to date.

    Anyways now onto the fix, after looking around a number of sites for a fix for the issue, and attempting a number of things e.g reinstalling the network adaptor, unchecking the box next to IPV6 and various other suggested fixes to no avail, i come across two that I gave a go that seemed to work well together and got the issue resolved for not only my wired internet, but also my wireless connection too. I have put in order the steps that I took to resolve the issue below:

    1. Run regedit. 

    2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\tcpip6\Parameters\

    3. Rightclick on Parameters

    4. Choose New > DWORD Value 

    5. Replace <New value #1> with DisabledComponents - If DisabledComponents was already there, disregard this step.

    6. Doubleclick on DisabledComponents

    7. Enter value 255 (This will Disable IPv6 completely)

    8. Close Regedit and restart your system

    9. Open Command Prompt 

    10. Enter the following command: netsh winsock reset

    11. When it is complete, reboot.

     

    After the reboot, and when your PC loads up, it should detect the connectivity. Fingers crossed you have as much luck as me with this one and this fix has helped. Post some feedback and let me know if you have any questions or how it went.

    Adam

     

    Wednesday, December 16, 2009 1:07 PM

All replies

  • Has anyone else attempted this that can advise if it works?

    Worked for mine, and hopefully it has worked for others.
    Thursday, January 07, 2010 12:53 AM
  • Thanks for the detailed, easy to follow steps. I've had this problem forever with windows vista (64-bit) and have recently upgraded to windows 7, everything seemed fine and then after a week of using the new OS it the "local only" started again. so frustrated. this solution has fixed my machine and i have the internet again. thank you so much.

     

    Thursday, April 08, 2010 4:43 PM
  • Didn't work for me :(

    I can access other computers on the network, but I can't acces the internet.

    It says :  " Unidentified Network " "Access: Local only"

    I have the Vista Ultimate 32-bit

    On the microsoft help page, they said to modify the DhcpCo0nnForceBroadcastFlag to '0' instead of '1' under

    \HKKEY_LOCAL_MACHINE\SYSTEM\currentcontrolset\services\Tcpip\parameters\Interfaces\{the serial of my wireless adapter}

     

    Thursday, April 22, 2010 9:08 PM