none
Mouse Vertical Scrolling: Painfully Slow

    Question

  • I just upgraded to Vista Ultimate and I have a Microsoft Wireless Laser Mouse 7000. It works perfectly in XP with or without the Intellipoint drivers you download. But now in Vista, the vertical scrolling is absurdly slow. Even if you speed it up all the way in control panel, it takes about 2 full spins for it to register.

    I downloaded the specific Intellipoint drivers for my mouse and installed it, and it fixed the problem... until I went in Sleep mode. When I came out, the problem was there again. Even if you uninstall and reinstall the drivers, it will always fail after coming out of sleep mode.

    The only way I've found to fix it is to kill ipoint.exe and then restart it by opening Mouse in Control Panel. Obviously this is not a good solution.

    I would expect buying new Microsoft Hardware and Vista Ultimate that the most basic of devices, the mouse, would work perfectly. Scrolling is broken, and I would like to know if theres any fix out there that doesn't involve killing and restarting the process every time.

    Thanks
    Jeff
    Saturday, September 06, 2008 12:33 AM

Answers

  • Hi Jeff,

     

    Did you install Windows Vista SP1?

     

    If not, it is recommended to install it first. It will install the latest Windows Vista components and system files. It fixes known issues about USB device problem after resuming from sleep or from hibernation.

     

    If the issue still persists after installing Windows Vista SP1, please take the following suggestion to troubleshoot this issue.

     

    1. Click Start, right click Computer and choose Properties.

    2. Click Device Manager.

    3. Navigate to your mouse , right click it and choose Properties.

    4. Choose Power Management tab.

    5. Please assure “Allow the computer to turn off this device to save power” is unchecked.

     

    Then, restart the computer to test this issue again.

     

    Hope it helps.

     

    Tuesday, September 09, 2008 9:20 AM
    Moderator

All replies

  • Jeff

     

    There is a Hotfix available for various device problems that occur when the system resumes from Sleep Mode.

     

    Go to the following article, read the article and then click the link to the hotfix at the top of the page. Follow the instructions to receive the hotfix.

     

    You may experience problems after you resume a Windows Vista-based computer from sleep or from hibernation:
    http://support.microsoft.com/kb/929734


     

    Hope this helps.

     

     

    If this post helps to resolve your issue, click the Mark as Answer or Helpful button at the top of this message.
    By marking a post as Answered, or Helpful you help others find the answer faster.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Saturday, September 06, 2008 12:58 AM
    Moderator
  • Hi Jeff,

     

    Did you install Windows Vista SP1?

     

    If not, it is recommended to install it first. It will install the latest Windows Vista components and system files. It fixes known issues about USB device problem after resuming from sleep or from hibernation.

     

    If the issue still persists after installing Windows Vista SP1, please take the following suggestion to troubleshoot this issue.

     

    1. Click Start, right click Computer and choose Properties.

    2. Click Device Manager.

    3. Navigate to your mouse , right click it and choose Properties.

    4. Choose Power Management tab.

    5. Please assure “Allow the computer to turn off this device to save power” is unchecked.

     

    Then, restart the computer to test this issue again.

     

    Hope it helps.

     

    Tuesday, September 09, 2008 9:20 AM
    Moderator
  • I have the same problem, but with the 8000 mouse. IE scrolling is quite jumpy, and scrolling in Windows Explorer windows, or Outlook, requires at least two turns of the wheel for any response, and then the page jumps downwards suddenly. Word is ok, for some reason. Firefox scrolling is awful, although using about:config and changing mousewheel.withnokey.sysnumlines to false, and mousewheel.withnokey.numlines to some number higher than the default value of 1 seems to help. However, scrolling in Acrobat Reader is truly terrible, taking about 20 turns of the wheel to get half way down one page of a PDF in normal zoom.

    I only noticed this problem today, after resuming the computer from sleep, which seems to link with the suggestion from the poster here, although the link provided doesn't seem to mention anything to do with the scrolling problem. It seems that turning the computer off, and then on again fixed most of these problems (although Acrobat scrolling still is not particularly good). Sleeping again seems to cause the problems to recur.

    Interesting how the obscure and daring combination of Microsoft Windows Vista plus Microsoft Office 2007 and Microsoft Intellimouse seems to cause so many problems...

    Friday, September 12, 2008 2:45 AM
  • The same problem can be found in this tread:

    http://forums.microsoft.com/technet/ShowPost.aspx?postid=3940186&isthread=false&siteid=17&authhash=3232172e991435626ecffc47658ee43457c64958&ticks=633583205136858846
    Tuesday, September 30, 2008 4:17 AM
  • This issue apparently happens when resuming from standby, and I am having this problem even with Vista SP1, so the hotfix from MS did nothing for me. The fix is to reboot, or to unplug the wireless receiver for the keyboard/mouse (or if the mouse is directly connected on a wired connection, unplug that) and then replug. Essentially, you are stopping the device and restarting it, which is how I came up with the following solution:
     
    The way I solved this problem, was by simply making a bat file which restarts the device. My batch file is one line:
     
    c:\devcon restart USB\VID_045E*
     
    On my computer I determined that USB\VID_045E was the keyboard/mouse combo. It will probably be different for each computer, but the bottom line remains that by running this script (to which I keep a shortcut to on the desktop), my mouse starts working properly again. You also need to have devcon.exe in the c:\ folder for this to work.
     
    If you search online for devcon, you will find the download. You can then run a cmd similar to "devcon find *" and then look through the list.
     
    Hope this helps you guys who are having similar problems.
    Monday, November 17, 2008 5:55 PM
  • The batch file is a great help (in place of an actual fix for the problem!) but since it's a pain to run it every time you log in, you could set up a task to run it every time you log in after waking the computer up using the trigger "On workstation unlock" and you shouldn't ever have to think about it again.

    Even better, you don't even have to use a batch file.  You just specify to run devcon.exe and under the arguments, you set it to "restart USB\VID_045E*".  Like kingbear2 said, I'm not sure if it will be exactly VID_045E on other systems or not, but it was on both of ours.
    Friday, February 27, 2009 8:35 AM