XP Mode in Windows7 Professional Drops Network connectivity


  • Ok - I've seen and followed several (5+) discussions on this problem dating back 4 years through Vista, but no one seems to have posted a definitive question.  I've been rolling out Windows 7 for over a year now and have been following the same procedure and installing the same apps to the same configuration without issues until this week,  I now have 2 boxes doing the same behaviour.


    Workstation is a PowerSpec B634 with Intel motherboard, using onboard RealTec NIC.  Windows 7 Professional, with Microsoft's Virtual XP vhd.  They are connected only via the ethernet NIC (wireless is disabled) on a 1GB connection.  I've moved the port on the switch they've been connected to and switched both the patch cable at the rack and the ethernet cable at the workstation.  And, as I've said I'm seeing this behaviour on 2 separate boxes.


    Unit boots flawlessly and I've not seen any connection issues on the Windows7 side of the world (i.e. Outlook isn't reporting disconnects from Exchange and the NIC isn't reporting loss of connection.) However, in the virtual XP side I can launch the virtual XP, and then start my database application.  It finds the database network share (mapped through the virtual xp as a drive letter to "//tsclient/drive" referencing a share on the host Windows7 machine.  The application runs great up to 10 minutes at which point the connection to the network drops as the database client loses all pointers to it's tables and references and crashes.  If I start a remote desktop session from inside the vitual XP it also will run fine for a while then report the conenction has been broken.  At no time does the NIC icon in the virtual XP system tray report loss of network connection.

    I have turned off all power-saving settings in BIOS, Win7, and as much as I could find in virtual XP - - I'm really at a loss here, especially as I have 15 other machines of very similar specs and identical software installations working just fine, oh, and yes, I'm running SP1 and have downloaded all available patches.

    Hints tips suggestions and/or more questions all very much appreciated.

    • Edited by Gobokat Wednesday, November 14, 2012 11:11 PM
    Wednesday, November 14, 2012 11:08 PM

All replies

  • Have you checked for updated drivers from the NIC manufacturer?
    Thursday, November 15, 2012 10:23 PM
  • Absolutely - I checked via the "Update Driver" function in Hardware Manager AND dowloaded the latest posting from the manufacturere's web site after which Windows informed me the most currently available drivers were already installed.

    However I'm now beginning to suspect and underlying hardware issue as RDP sessions from the Win7 side are now beginning to drop as well.

    How odd, however that 2 machines would have the same defect with integrated hardware.

    Thursday, November 15, 2012 11:52 PM
  • Is there any power management happening on the nics? Are the two NICs the same model? 

    also, what happens if you switch the patch cable, and also try a different port on the switch?

    Friday, November 16, 2012 1:53 AM
  • Thaks for the suggestions - as noted in my original post:

    1) all power management for the NICs (which are integrated on the Intel Motherboard) have been switched off in BIOS, Power Management in both the Win7 host and XP virtual environment, and in Device Manager specific to the NIC I've switched of any power management options to force them to stay on at full speed/power at all times

    2) I have had this problem now with the computers plugged in to two different "patch to outlet" locations in the office (i.e. different in-wall wiring), plus have used two different wall to PC ethernet cables (which I have also pin verified with a fluke cable tester) and have used different patch bay to switch cables and have not only switched ports on the switch but have switched to a completely different switch.

    With those considerations taken into account I am continuing to see the issue.  The connectivity drop is occurring pretty regularly between 6 and 10 minutes of operation.

    3) sorry, yes, NICs are same model as both towers have same Intel motherboard.

    • Edited by Gobokat Friday, November 16, 2012 6:58 AM
    Friday, November 16, 2012 6:50 AM
  • I had the same problem for 10-20 computers. The problem only happen with Realtek Nic. I have tried change the MAC, but it still doesn't work. So far using VMware and change the NIC will fix the problem but it cost work and money. I want to know does anyone has fix for keep using Realtek NIC. All my computer are from Dell. If the computer using Intel NIC or Broadcom NIC, they don't have this problem.
    Monday, December 03, 2012 9:16 PM
  • Ok - don't know if this is THE solution, but in desperation here's what worked for me - move the RealTek NICs to a subnet with under 50% population.  I have no idea if this just happened to work for me or why it should matter, but in diagnostic desparation I moved these two desktops to a test LAN with only two other desktops on it they stabalized.

    I then created a clean /26 subnet and routed it to be able to see the servers in my other /26 subnets and they're now sitting there just happy as can be and are participating nicely in the network.

    Anyone think of why this would have been a solution?  They were static IP addressed and the subnet where I was originally trying to put them was only 80% full.

    If this proves to be a workable solution or looks like it might help anyone else please let me know so I'm not thinking I tripped over an accidental and imperfect remedy.

    Thanks to those who've given me things to think on and here's to finding the real and permanent RealTek solution.

    Monday, December 03, 2012 9:24 PM
  • RealTek's have been an issue with VPC/Virtual Server since the original days (2001-2003) back at Connectix.  We had problems with them then and swapping to an Intel or other NIC would fix it.

    It could be driver or just the particular hardware, they had good and bad years for drivers/models.

    Or, it's possible the NIC can't handle the extra load of 2 OSes with the overall traffic of your busy subnet.

    What model RealTek is it?

    Monday, December 03, 2012 9:36 PM
  • I've got the same issue described in the initial question.

    It's Windows XP Mode on Windows 7 Pro. SP1 32-bit. The host is a HP 6005 Pro MT PC (XG068EA#BED) with onboard Broadcom NetXtreme Gigabit Ethernet NIC.

    The power options in Windows 7 are set to Hight Performance and in the NIC properties the "Allow the computer to turn off this device to save power" option is disabled.

    In the Virtual PC settings of the Windows XP Mode the networking is set like this:
    Adapter 1: Broadcom NetXtreme Gigabit Ethernet

    With these settings the Windows XP Mode drops network connectivity a few minutes after start. E.g. if I start pinging another host on the network with "ping host -t" I quickly get "Request timed out."

    But the network connectivity is restored as soon as I open Tools > Settings on the Virtual PC window.

    The issue is not present when the networking mode of the Virtual PC is changed to NAT:
    Adapter 1: Shared Networking (NAT)

    So, I use this as a workaround.

    -- rpr.

    Wednesday, February 26, 2014 2:31 PM