Agent Issue - Cannot see Exchange RRS feed

  • Question

  • Hi,

    I have a new DPM 1801 install.  Is working fine to backup file and SQL data to disk and to tape library.  Now trying to backup my Exchange 2010 server but am having issues.  I was able to backup that same exchange server using a previous version of DPM.

    • I've installed the agent from the DPM server.
    • I've copied to two files from Exchange to the DPM server bin folder.  Rebooted both systems even.
    • When I create a protection group for that single server (no DAG) I see only "Shares" and "Volumes".  Nothing about the Exchange farm.  I can expand the shares and volumes normally, but there should be a section for exchange outlining the database available for backup and stuff.
    • Any tips?

    DPM 1801 on Server 2016 with SQL 2016 SP1 in a local named instance. Has very recent updates for everything.  Exchange 2010, VM hosted in Azure (that shouldn't matter), a 10-15 windows updates are needed so its not super out of date, mostly for .net stuff...

    Thursday, January 3, 2019 6:29 AM

All replies

  • Hi

    Did you already tried to update the data source? When creating a protection group select your Exchange Server and click refresh.

    Microsoft Certified Professional

    [If a post helps to resolve your issue, please click the "Mark as Answer" of that post or click Answered "Vote as helpful" button of that post. By marking a post as Answered or Helpful, you help others find the answer faster. ]

    Thursday, January 3, 2019 6:59 AM
  • Yup, tried that.  No change.  Just thinks its a plain old file server.
    Thursday, January 3, 2019 4:15 PM
  • Can you please confirm if account which you are using have access on Exchange servers.

    Account should have local administrator rights.

    I am assuming that you have copied ese.dll and eseutil.exe to DPM server.

    Thanks, Ashish MCITP, MCT, MCSE

    Thursday, January 3, 2019 4:35 PM
  • The account is an enterprise administrator, full exchange administrator, and local administrator via a domain security group (domain admins, which I am also a part of).  Yes, I have copied the two files to the DPM BIN folder.

    Thanks for the suggestions, but no change so far.

    Thursday, January 3, 2019 4:57 PM
  • Hi,

    You mentioned that Exchange VM is on Azure.

    Is that correct or I misunderstood that?

    Thanks, Ashish MCITP, MCT, MCSE

    Thursday, January 3, 2019 5:18 PM
  • I did mention that, yes.
    Thursday, January 3, 2019 5:19 PM
  • So it means that DPM is on local datacenter (Onprem) and Exchange is on Azure VM.

    I am asking because there are different methods for taking Azure workloads backups.

    Thanks, Ashish MCITP, MCT, MCSE

    Thursday, January 3, 2019 5:36 PM
  • DPM is a local resource, correct.

    Exchange is in essence an on-premise server, but yes, it is hosted in Azure.  We have a VPN to the Azure network so hardware firewalls are not blocking traffic.  I was backing up this Exchange server from DPM 2012 last week (and now the new DPM server has the same hostname and same IP as before, just has DPM 1801 now). 

    I don't see any limitations documented so far about DPM 1801 not supporting Exch2010 so I have a feeling that is not the issue.

    Thursday, January 3, 2019 5:43 PM
  • Thanks for this information.

    I will suggest to re-install DPM agent on Exchange using new DPM server management console.

    As you are able to see volumes and shares but Exchange not showing in DPM so it's point out to Agent issue.

    Also please review firewall setting one more time.

    Also please review support matrix (for e.g. Disk to tape not supported for exchange DAG).

    Thanks, Ashish MCITP, MCT, MCSE

    Thursday, January 3, 2019 6:10 PM
  • 1) Re-install DPM agent

    Originally, I installed the agent manually by mapping a drive to the DPM server, using an administrative command prompt to install the agent and specifying the DPM server FQDN.  I confirmed the firewall rules were added as expected at this time.

    I experienced the issue mentioned above.  Uninstalled the agent, rebooted exchange, then I installed the agent from the DPM server as mentioned above in my original post. Rebooted, same issue.

    2) Firewall

    Confirmed the firewall rules have been applied.

    3) DAG

    Not using DAG as mentioned above

    4) Pre-Req's

    Checked those, no concerns there

    Thursday, January 3, 2019 6:30 PM