none
Moving large files to an usb hard drive problem(W7 Pro x64)

    Question

  • Hi!

    I would like to describe a problem with my notebook that is related to moving large files (from 1 GB up) to and external hard drive via USB.
    First, here's my Specs:

    Notebook: HP Pavilion 6950la
    Specs:
    Product Number FG755LA
    Microprocessor 2.1 GHz AMD Turion 64 X2 Dual-Core Mobile Technology TL-62
    Microprocessor Cache 512 KB + 512 KB L2 Cache
    Memory 4096 MB (2 dimm)
    Video Graphics NVIDIA GeForce Go 7150M
    Hard Drive 320 GB (5400 RPM)
    Multimedia Drive LightScribe SuperMulti 8X DVD±RW with Double Layer Support
    Display 15.4” WXGA High-Definition HP BrightView Widescreen Display (1280 x 800)
    Fax/Modem High speed 56K
    Network Card Integrated 10/100BASE-T Ethernet LAN
    Wireless Connectivity 802.11 b/g WLAN

    Bluetooth
    Sound Altec Lansing

    Internal speakers
    Keyboard 101 key compatible
    Pointing Device Touch Pad with On/Off button and dedicated vertical Scroll Up/Down pad
    (Sorry if my copy/paste was large)

    And then I have the following programs and OS installed:
    OS: Windows 7 Professional x64 RTM
    Programs:
    Ares
    Cdisplay
    Combined comunity codec pack
    Core codec
    Cyberlink DVD suite (has about 8 programs in this suite)
    Divx
    Driver Genius
    Eset NOD32 4.0 Antivirus
    Sisoft Sandra
    Maple 13
    Spybot
    Ultraiso

    So my problem is:
    I connect my external hard drive (My book, Western Digital, via USB, powered by a AC adaptor), the OS detects it and installs it quite fine. I'm able to copy large files from my HD to my notebook just fine, the problem is when I try to do that backwards, the system gets slower and slower and eventually gets stuck (sometimes it tells me that the location of my external hard drive is nos found)(even though the file seems to copy, because it appears in my external hard drive). The only thing I can do when my system gets slow is to try and wait a lot of time to remove my hard drive from my notebook carefully so I don't lose any data and then restarting it.

    Here's what I tried:

    1.- Tried the "grant full control permission " to the files, didn't work.
    2. Tried Teracopy to make the task, but it still gets stuck in the same way as windows 7.
    3. Since I have a notebook, I can't upgrade the chipset drivers so easily, just tried the chipset drivers from the HP site (the latest dates from 2007!) but that didn't work, tried to download from nvidia the driver for my chipset (nforce) but doesn't seem to make any change, the problem persist (even though I'm not completely sure if the drivers from nvidia got correctly installed in my system).
    4. I notified HP from this issue today too, because I think it's very annoying and relevant to search for a solution to this issue, since it's enough motive for me at least to return to vista (which I really don't like but at least this problem never ocurred there)
    5. My Hard drives are fine, they are not the problem, tested in my other pc, which has XP, and it transfer, copies and moves files perfectly fine between the pc and the hard drive (they are formatted to FAT32, but I really don't think it's important)

    I hope a solution can come up from this, this is the only complain I have from windows 7, the rest is fine and running good so far.

    Thanks in advance and I hope you can throw some ideas to fix this.





    • Edited by SSnake Tuesday, September 08, 2009 3:01 PM updating the title to clarify
    Tuesday, September 08, 2009 2:59 PM

Answers

  • Hi,

    Unfortunatelly, the above method doesn't work. In addition, sometimes the copy time can be consuming if the destination disk has bad sectors. Thus I kindly recommend you to run chkdsk.exe utility to scan your external hard drive. To do this, please take the following steps:

    1. Connect your external hard disk to your computer.
    2. Open a command prompt in elevated privileges.
    3. Run the following command:

    chkdsk [Drive letter] /f

    If there is any bad sectors, please run the following command to locate bad sectors and recover readable information.

    chkdsk [Drive letter] /R

    BTW, we hear your voice and I'd like to forward to our DEV team. I believe the performance can be improved with the efforts of our developing products team in the future.

    Best Regards.
    Dale Qiao
    Friday, September 11, 2009 3:17 AM
    Moderator

All replies

  • Hi,

    It is recommended to format your hard disk in NTFS format. The cause for copying large files is due to the file system, differt file systems can handle different sizes of file. As I know, FAT32 can only handle files up to 4GB in size. NTFS can handle files more than 4GB. If you need to copy files larger than 4GB, you may need to make sure that the file system on the hard disk you are copying to is NTFS and not FAT32. However, many portable USB hard disk dirves come formatted as FAT32 in order to interface with the maximum number of operating systems.

    Based on my research, the problem for moving and copying large files because of the new auto-tuning network. Once auto-tuning network is turned off, then the issue of moving files goes away. Here is the steps.

    To Turn off Auto-Tuning
    ==============

    1.press Ctrl+Shift+Enter to open the Command Prompt. Choose run as administrator.
     
    Type in: netsh int tcp set global autotuninglevel=disabled

    2.Reboot

    If you have any problems, then to turn auto-tuning back on type the following in Command Prompt:

    Type in: netsh int tcp set global autotuninglevel=normal

    BTW, I would like to share the following blog with you.

    Slow Large File Copy Issues

    Best Regards
    Dale Qiao 

    Thursday, September 10, 2009 9:36 AM
    Moderator
  • Hi!

    Thanks for your reply.

    I really appreciate it, in the HP forums they still can't help me with this. But the solution you gave me unfortunatelly didn't give me good results.
    I even tried a clean boot, but no results yet. So I'm sure it has to do with the OS bug, not my programs installed.
    It would be nice to know that HP and Microsoft are working to solve this problem, many people still complains about it but no solutions yet.

    I appreciatte your effort Qiao, thanks anyway, I visited the blog, but didn't give me any ideas to get around the problem.

    Best Regards
    SSnake
    Thursday, September 10, 2009 2:20 PM
  • Hi,

    Unfortunatelly, the above method doesn't work. In addition, sometimes the copy time can be consuming if the destination disk has bad sectors. Thus I kindly recommend you to run chkdsk.exe utility to scan your external hard drive. To do this, please take the following steps:

    1. Connect your external hard disk to your computer.
    2. Open a command prompt in elevated privileges.
    3. Run the following command:

    chkdsk [Drive letter] /f

    If there is any bad sectors, please run the following command to locate bad sectors and recover readable information.

    chkdsk [Drive letter] /R

    BTW, we hear your voice and I'd like to forward to our DEV team. I believe the performance can be improved with the efforts of our developing products team in the future.

    Best Regards.
    Dale Qiao
    Friday, September 11, 2009 3:17 AM
    Moderator
  • Hello,

    I am encountering the same problem. Whenever I copy large files the system slows down and my ram fillls up. I am running Windows 7 Professional x64 on a Intel E6550/Gigabyte P35-DS3 board/4GB of ram/2 WD Harddrives.  It's extremely irritating and if I remeber properly I had the same problem on Windows Vista x64. I tried to use the SetCache and set the maximum cache to 1GB but it's useless. The ram will still fill up and get all the other apps working with the pagefile instead of ram and everything slowing down. There must be some kind of an answer to this.
    Capture Screen : Look here


    Thank you,
    Andrei



    • Edited by Andrei Biro Saturday, January 09, 2010 1:50 AM To post screen capture
    Saturday, January 09, 2010 1:41 AM
  • Hello,
    I am experiencig the same problem.

    When trtying to do anything with large files, systems hangs up it is not possible to cancel the operation and even correct reboot is not possible. And I have tried to let it run for hours, but ends always the same.

    I have freshly new system installed.
    The files I am trying to copy are of 500 MB - 4 GB sire mpeg-2 files, extension mpg recordings from sat receiver.

    My system is almost the same config as described above. Except it is 3 GB Ram and HP Compaq Presario CQ61 Dual Core Athlon.
    Win 7 Home Premium 64x.

    I am connecting NTFS 120 GB SATA Drive. Formated by Windows Vista.

    Please help.......
    Monday, January 11, 2010 10:42 PM
  • Shouldn't Microsoft be noticing this and offer some support as it is a very encountered problem ??
    Tuesday, February 09, 2010 9:25 PM
  • Hi Dale, I can tell you that you all need to be fixing bugs and your reply is silly. There is a bad problem here and that answer kinda shows you guys dont get it. I am having the same issue. I have a quad processor and 4db ram (about to be 8gb) brand new 7200 rpm western digital (as are all my drives) using firewire for some and the internal is sata. It takes 5 hours to copy 3 gb of data. Sometimes even 700mb file takes hours. I am in tech support for a telecom company and have built and maintained hundred if not more machines. Windows 7 is seriously dorked up in the file transfer process. We really need someone who cares enough to try to find answers and get this fixed. Your answer says try to old standard and ignoring it has nothing to do with that. When I try to transfer, its getting worse. It now stops other programs from funtioning becasue it takes all the drive speen and ram to move files. This spells BROKE. Please listen to thounsands of users in all of you forums and hear what they are sayting. ITS BROKE please help.
    Friday, March 12, 2010 7:04 AM
  • I'm having the same problems as the OP using Windows 7 Professional.  Only with large files.  I didn't have this problem before.

     

    It's seriously annoying!  I can't transfer large video files to USB anymore!

    Can't recommend Windows 7 to anyone if this persists.

    Wednesday, March 24, 2010 2:04 PM
  • Ok,   im using a gigabyte ep45 motherboard,  have turned off usb detection ect ect in bios.    None of my usb hubs are usefull for large file transfers to USB sticks,   and i have over a dozen .   

    Ive done it all,  removed, disable, reinstalled  drivers, hub controlers all that ____.  Nothing,    large file transfers to usb is now impossible.  Windows 7-64bit and yes, microsoft need to get off their butts and take a look at this issue,  google search is enough for them to realise it needs their attention.

     

    Intel raid drivers updated , all the usual intel stuff updated,  wound back ect ect.  Even tried transfering from different hard drives to usb to eliminate sata port issues,   all 6 taken up by raid (0)  


    yuyuiui
    Friday, March 26, 2010 4:54 PM
  • I have this problem too. Any hardware tuning does not help. System: Windows 7 Enterprise x64. Hardware: HP Compaq 7900.
    Tuesday, May 04, 2010 8:31 AM
  • Most problems with copying large files to a thumb drive are due to FAT/FAT32 not being able to handle large files. I'm talking about the format of your THUMB DRIVE now, not your hard drive.

    If you know for a fact that your thumb drive is already formatted as NTFS, then this solution will NOT work for you. However you should probably check again, because this is a very common problem.

    Edit: Also, these instructions are for Windows XP. I just realized the OP was asking about Windows 7. Maybe someone with Windows 7 can translate these instructions, but I can't since I don't have it. Sorry.

    When choosing to format a USB flash drive in Windows (at least in Windows XP, haven't tested Vista/7), USB flash drives don't even show NTFS as an option by default. You'll need to enable it using the following steps:

    1. In "My Computer", right-click on your flash drive, then click "Properties". Then, click the "Hardware" tab.

    2. Find your flash drive in the list and click on it. On my system, my flash drive is listed as "USB Flash Drive USB Device". Once that's highlighted, click the "Properties" button below the list of drives.

    3. In the resulting window, click the "Policies" tab.

    4. You have two options. The first is probably chosen by default ("Optimize for quick removal"). Change this to "Optimize for performance". Click OK, then click OK again.

    5. Now it's time to format. Once again go to "My Computer", right-click your flash drive and choose "Format..." Then, under "File System", choose "NTFS" (which should now be available). Also be sure to check the box next to "Quick format". Hit the Start button.

    When it's done formatting, you're all done. Large files should copy over now.

    • Proposed as answer by Taufiqabdullah Monday, August 16, 2010 4:17 AM
    • Edited by equazcion Thursday, September 02, 2010 6:24 AM
    Friday, May 21, 2010 2:02 AM
  • Same issue: Windows 7 Ultimate 64, Firewire (1394a) external 7200rpm 80GB Hitachi SATA drive, defragged and chkdsk'd with XP, NTFS. Reboot machines to XP, and can copy as large of file as desired to the external drive. In Win7, virtually stops at 1.5GB. Tried with brand new Dell Precision M6500, and an HP xw9300.
    Thursday, July 01, 2010 8:32 PM
  • Most problems with copying large files to a thumb drive are due to FAT/FAT32 not being able to handle large files.

    If you know for a fact that your drive is already formatted as NTFS, then this solution will NOT work for you. However you should probably check again, because this is a very common problem.

    Edit: Also, these instructions are for Windows XP. I just realized the OP was asking about Windows 7. Maybe someone with Windows 7 can translate these instructions, but I can't since I don't have it. Sorry.

    When choosing to format a USB flash drive in Windows (at least in Windows XP, haven't tested Vista/7), USB flash drives don't even show NTFS as an option by default. You'll need to enable it using the following steps:

    1. In "My Computer", right-click on your flash drive, then click "Properties". Then, click the "Hardware" tab.

    2. Find your flash drive in the list and click on it. On my system, my flash drive is listed as "USB Flash Drive USB Device". Once that's highlighted, click the "Properties" button below the list of drives.

    3. In the resulting window, click the "Policies" tab.

    4. You have two options. The first is probably chosen by default ("Optimize for quick removal"). Change this to "Optimize for performance". Click OK, then click OK again.

    5. Now it's time to format. Once again go to "My Computer", right-click your flash drive and choose "Format..." Then, under "File System", choose "NTFS" (which should now be available). Also be sure to check the box next to "Quick format". Hit the Start button.

    When it's done formatting, you're all done. Large files should copy over now.


    it works .Thank you very much

     

    Monday, August 16, 2010 4:18 AM
  • i have the same problem while dealing with copying file to my seagate exdisk. file copy eventually stop at somewhere then wont resume back no matter how long i wait, then the only way is to unplug the exdisk. but when i try to copy the same file again, it will stuck again and go to no responding if i cancel it. i also try teracopy and end up same result.
    Monday, December 31, 2012 10:29 AM
  • Thank you, it really worked! :D
    Monday, February 11, 2013 10:09 PM