Vista Chkdsk


  • I am having problems running chkdsk in a vista tablet PC. This does not appear to be my problem alone, but other tablet PCs have similar problems.

    When running chkdsk c: /f from an elevated command promt, vista indicates it will run chkdsk on reboot, but never does.


    Running CHkdsk /f does not set the dirty bit. I can set it manually with fsutil, and chkdsk still does not run on reboot.


    The problem is also happening to other tablet PC users. is a url reflecting this.


    I am an administrator on the PC, am running the command from an elevated privilidge command prompt.


    I can run chkdsk from the repair console (from the original Vista disk). This is very frustrating.


    PC is a fujitsu 4210 convertible tablet PC. 2 gigs ram, 80 gig hard disk, intel dual core 1.8 cpu. avg anti virus, running Ultimate VIsta installed from the released CD from Fujitsu.

    Sunday, May 20, 2007 3:45 PM

All replies

  • I confirm that I am having the same issue. However, Vista was preloaded on my computer and I have no Vista boot CD / DVD so cannot use your workaround.
    Tuesday, July 10, 2007 5:11 PM
  • I'm having the same issue on a Dell E1505 Vista laptop running Vista32 Home Premium.  Very frustrating indeed.  I can't even run chkdsk from the partition properties | tools menu for the C: partition.  My account has admin privs, and I've disabled UAC, still nada.  :-(






    Saturday, September 15, 2007 2:42 AM

    Microsoft Hotfix

    This update resolves an issue that prevents chkdsk.exe from running at system boot.


    Tuesday, September 18, 2007 9:01 PM
  • That hotfix is marked as "Windows XP Home and Professional Edition Patch: NTFS chkdsk.exe Update" and was released in February 2002.


    Wednesday, September 19, 2007 1:26 AM
  • Too bad, although I was able to run chkdsk c: /f /x from the Vista recovery console, a workaround I'd rather not have to do, but ...  PerfectDisk 8.0 is unable to perform its version of Diskeeper's boot-time defrag.  Raxco had a couple fixes that did not resolve the issue, so I expect that this particular issue is related to Vista's inability to run chkdsk on C: outside the recovery console.  From what little I've read about it, it seems to be confined to tablets and laptops.  Enough to keep me from upgrading my main machine for a goodly while.  And I've always been an early adopter!  Ah well....
    Wednesday, September 19, 2007 1:54 AM
  • I'm assuming that this means the hotfix is not for Vista, and so we still don't have a solution for this issue (which has begun to plague me - my defragger notes a currupt file, and running chkdsk without the /f perameter also shows the problem, but there seems to be no way to fix it.
    Saturday, October 20, 2007 4:47 PM
  • I have the same problem on an HP Pavillion notebook.  Due to wife turning off power instead of shutting down windows, I have several corrupt files and a corrupt directory.  Since chkdsk won't run, I can't even delete the directory and reinstall.


    Sunday, November 25, 2007 1:59 AM
  • After my last post, more files began to show up as corrupt. At that point, the Lenovo techs asked me to rebuild my system from the partition of the hard drive with the recovery files on it. Which turned out to not exist on the hard drive. So they sent me a new hard drive, and the recovery DVDs (nice - three of them, instead of 7 or 8 CDs). I've now installed the system back on the new hard drive (twice - but it was sort of my fault), and made sure to set up restore points at the appropriate times (after initial set up, after the "necessary" programs are re-installed and working, after some other programs are going, after all the data and preferences are set). I did try to run chkdsk /f once, and found that it would only run after a reboot from Safe Mode, but at least I did see it run - which it wouldn't do at all on the earlier hard drive/factory setup. I hope to not have to try to run it in the near future - I'll try the restore points if there's a problem later. I do hope that MS comes up with a solution (either getting chkdsk to run in Vista, or coming up with some new utility that fixes corrupt file systems.

    Sunday, November 25, 2007 2:44 AM
  • well its sounds like i have the same issue on my friends dell pc its shown as "Dirty" so i went in to the recovery console and tryd to work my way though the issue using chkdsk /f but on his pc the chkdsk /f command is not reconized  invalid command so i doubt that chkdsk /f /x is goin to work and i carnt even start in safe mode to recover that way every thing i do on boot up it just auto scans with chkdsk and just loops on every boot up does same thing Tongue Tied and i canot format has the pc had documents that his kid needs for Uni


    Helpppp lol any 1 got any bright ideas tryd putin the hard drive into my pc but it doesnt find it or gives me a dam stop error


    Friday, February 15, 2008 1:19 PM
  • It is quite possible that the BootExecute data value in the Registry has be changed or got corrupted. Alternatively, your autochk.exe file situated in the system32 folder may have got corrupted. Pls check if something at If ChkDsk does not run at startup in Vista helps you.


    Friday, February 15, 2008 2:57 PM
  • The update posted in your comment is NOT for vista

    Wednesday, March 26, 2008 3:56 AM
  • I just noticed this post is over a year old but just in case I'll leave my 2 cents worth.

    Most of the PC's produced today have another partition on the drive with the complete operating system ready to reload and I think the utilities as well.  Anyway there is a provision to make your own load disks and if that doesn't work the computer mfg. will sell them to you for 10 to 15 dollars usually.


    dmeans 43

    Monday, August 18, 2008 5:48 PM
  • I've been looking around on the internet for solutions to this same problem. I don't have a windows cd for my tablet (though I will investigate buying one as you suggest dmeans43 if I can't fix it myself) but I was able to get into the HP system restore screen (or called something similar) during bootup. I'm not sure how similar it is but I was able to run "chkdsk c: f/" and got different results than running it in windows. Normally it tells me it can't proceed but wants to schedule it. This time instead it asked me if I wanted to unmount the drive and warned me saying something about open indexes not working. I was concerned that this was something permenant that I would not be able to reverse, so I cancelled. Can anyone tell me if unmounting the C: would've been a safe thing to do? I was concerned about losing whats on my hard drive.
    Sunday, September 14, 2008 7:29 PM
  • On my HP, I finally got into the system restore partition at boot up and was able to run chkdsk.  It had to unmount c: before it ran (I told it to go ahead).  It found all the errors and cleaned up the hard drive, but I then had to reload several programs.  I'm still not sure what caused my problems to begin with, but believe it was when my wife turned off the computer with the power switch while it was updating the hard drive.  You would think there would be some kind of protection against this type of corruption.  Once everything is completed, you have to reboot the system, which then remounts the drive and you're back to normal.  However, you will lose all of the corrupt files.  I believe it saves the file fragments, so if it is data file that's corrupted, you can recover at least part of it, but if it is a program file as mine was, you will have to reinstall the program.
    Monday, September 15, 2008 10:51 PM



    This very same problem drove me crazy for a couple of hours.


    When scheduling a chkdsk on restart you MUST "Shut Down" the pc, not restart, then power the pc back on.


    For some reason chkdsk will not be performed on vista if you specify it to "restart".


    Hope this helps.

    Thursday, November 06, 2008 10:57 PM
  • Try chkdsk /R.......this includes the /F.




    Wednesday, December 10, 2008 7:36 PM
  • hey guys. i was having the same problem on a HP pavilion with windows vista premium on it. the chkdsk wouldnt load up when yu schedule it. figured out that when you restart the pc you will need to hit f8 so it goes into the start up option mode where you will see these options

    repair the pc

    start in safe mode
    start in safe mode with networking...

    then you go repair the pc where you will see the windows recovery console. go in command promt and type chkdsk c: /f . it will ask you to unmount. proceed with a y( you might have to reinstall some programs) proceed with the system restore and hopefully things should start working..

    • Proposed as answer by hddcs Saturday, September 05, 2009 7:32 AM
    Saturday, September 05, 2009 7:29 AM
  • when i tried to run the chkdsk i got the same response>>> i do not have the privileges>>>im the admin on my laptop....excuse my language but ....WTF....i never had that come up b4>>>>   im a little P.O. 'D.... but i can always work around it >>>but damn this is irritating!!!!! it wastes my time!!!!  I hope they are paying attention to every gripe!!!!
    Wednesday, December 23, 2009 9:01 AM
  • i have gone around this b4 >>> and no they dont give this info if its preloaded on your computer...they dont on any system u buy we are all suppose to figure it out and its actually not that hard but....lately they have been changing this/updating ( since even 3 months ago) that now even i have to circumnavigated round the by the way u dont need that disk or cd barton....
    Wednesday, December 23, 2009 9:19 AM
  • theres alway an issue with chkdsk with 32bit >>> google the chkdsk for the 32 bit only...its diff
    Wednesday, December 23, 2009 9:22 AM
  • hotfix >>>apparently does not seem to work so well for vista...tho i have ran around that one a couple of not a fan of hotfix for much anyway.....
    Wednesday, December 23, 2009 9:25 AM
  • whoops...clearing search history...temp files/cookies everytime will help as well....there are lots of ways to avoid ANY corrupt files etc....and ya tell your wife to do a shutdown first>>>>much safer AND so much better for thee ole system>>>lol lol
    Wednesday, December 23, 2009 9:30 AM
  • there is no just chkdsk/f command..... or chdsk f /x command for that....u got to go at least to your c drive.....chkdsk c:\      then try......the fix command  which is then    \f       or go to ur start programs........accessories......then click on yr c for yada yada.....
    Wednesday, December 23, 2009 9:48 AM