none
Root cause found : unspecified changes to system configuration might have caused the problem

    Question

  • Hi , my com was running well last night till when i want to open my download folder it said the directory is corrupted and unreadable. This happen out of sudden and i thought a restart will solve the problem so i restarted my pc.

    Then i couldnt access to the windows and i have 2 options , repair startup or start windows normally.

    I tried to start windows normally but it only lead to restart of my pc. I tried repair startup(without windows cd) 3 times. At the end it shows Root cause found : system volume on disk in corrupt. Repair action : File system repair    Result : completed successfully  Error code 0x0 .

    After 3 times of repair startup (without using windows 7 CD) , the black screen still pop out and i cant start windows normally.

    So i decided to use my windows CD repair function.

    Before that i had some issue with BCD and i rebuild one and solved the problem.. So i put in windows CD and try to run the repair function on the cd and it shows Root cause found : unspecified changes to system configuration might have caused the problem

    Repair action : syst files integrity check and repair

    Result : Failed. Error code = 0x490

    This shows at the bottom of the list , there are many test performed but all of them success for example : check for updates , system disk test , disk failure diagnosis , disk metadata test , target os test , volume content check , boot manager diagnosis , system boot log diagnosis,  event log diagnosis , internal state check , boot status test , setup state check , registry hives test , windows boot log diagnosis , bugcheck analysis , access control test , file system test , software installation log diagnosis , fallback diagnosis. All of these tests completed successfully with error code = 0x0

    What can i do with my windows and harddisc?  Is there any chance i can restore the data i have inside?

    Wednesday, October 13, 2010 5:48 AM

Answers

All replies

  • You may run “chkdsk /r” to check and fix drive issues. If the issue still occurs, please let us know if it persists in Safe Mode and Clean Boot Mode.

    Perform a clean startup to determine whether background programs are interfering with your game or program


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, October 18, 2010 9:46 AM
    Moderator
  •  

    Having similar issues (Unspecified changes to system config...) Aurthur, your instructions can't be followed as the system won't boot!

    We are seeing this problem quite a bit.  Sometimes the repair works and sometimes it doesn't.  There is definately a bug in the system repair logic somewhere.  We commonly see this with a shutdown that isn't clean causes the system to become unusable (in that the system repair doesn't fix the problem leaving a normal user out of luck).

    To recreate this, all you have to do is power down Windows 7, during the restart, power down again and most likely you will run into this.

    In my specific case just now, I get the repair action is "System files integrity check and repair."

    To create this, I had a system where it didn't have the CD as a boot device. I kept killing the windows start trying to find the right key to get into the BIOS. I booted from CD to take a snapshot of the disk (no write to the disk during this process).  After getting a snapshot, I tried booting windows and now I get this error.

    XP was not nearly as sensitive to this.  I used to be able to power off XP with confidence that it would just boot when I powered back on.  That is not the case with windows 7.  Overall, wouldn't trade Windows 7 for XP but this is becoming a major issue for us as several of our users are experiencing this now.

    Hoping that MS puts some effort into fixing the system repair so that it does a better job repairing.  Would also like to see more status during the repair. If it's just doing a chkdsk, then tell us that so we know what's going on.  Sometimes, the "repair" takes 45 minutes with no idea of how long it will take leaving some users very angry.

    Monday, November 01, 2010 6:27 PM
  •  

    Having similar issues (Unspecified changes to system config...) Aurthur, your instructions can't be followed as the system won't boot!

    Ditto.  Can't do anything with no boot, and I'm having this problem.  Win 7, I ran the repair step which couldn't repair the problem, twice, ("unspecified changes to system configuration might have caused the problem ") and also ran hours of HD & memory diagnostics which showed there were no problems.  This happened after a probable non-clean restart (I have a laptop and walked away after I restarted post-AVG update, so I can't say with 100% certainty).

    RayBarbieri, how were you able to get around this and get it to boot (or were you able to)?

    Friday, December 03, 2010 7:00 PM
  • In my case the problem was due to a mucked up AVG forced upgrade (free version).  I later read that it evidently only affected 64-bit Win 7.  I followed instructions given at this site and all is well now.

    http://www.dailytech.com/AVG+Update+Cripples+Users+Windows+7+Vista+Computers/article20310.htm

    Tuesday, December 07, 2010 1:01 AM
  • I am getting the same problem with my Toshiba laptop running Windows 7 Professional.

    My problems started when I switched on and got no further than the "Starting Windows" screen. Powered off and on and got the choice of starting normally or with repair (recommended). After a few seconds I was informed that the computer could not be fixed and asked whether I wanted to use the last known good startup to restore from. Having declined that, it proceeded to attempt to fix for about half an hour.

    Eventually I got the message "Startup repair cannot repair this computer automatically" and asked whether I wanted to send the info to Microsoft which I declined.

    Looking at the diagnostic "details" it listed a number of tests performed where the error code is 0x00. The only one that was not was:

    "Unspecified changed to system configuration might have caused the problem".

    Repair Action: System Restore

    Result: Cancelled

    Repair Action: System files integrity check and repair

    Result: failed error code = 0x490 

    After I click on "Finish" the computer shuts down and when I restart all is fine (i.e. restarts without any issues).

    Just before this problem appeared I had plugged in my Canon scanner (USB) but I don't think that this is the problem..

    Any assistance would be highly appreciated

    Alexis

    Wednesday, March 21, 2012 9:13 AM