Windows 10 & Android Fastboot (Device Failed Enumeration - Error Code 43) RRS feed

  • Question

  • Hi, To TechNet Community!

    I Am Using Windows 10 Enterprise Edition (x64). I Am Having Issues Connecting My Android Device In Fastboot Mode. Although I Have Installed Proper Drivers For My Device & It Is Recognized By Windows 10 In Normal Mode (HTC Android Composite Device) But I Am Unable To Use It In Fastboot Mode. My HTC Device Is Also Recognized In "HBOOT Mode".  It Shows "USB BOS Descriptor Failed" & "Device Failed Enumeration - Error Code 43" In Fastboot Mode. I Have Tried Everything But Unable To Get It Connected.

    Here Is The Screenshots Link For Better Understanding. Looking Forward For Your Reply. Thanks!


    • Edited by SyedBilal07 Wednesday, October 7, 2015 9:47 AM
    Wednesday, September 9, 2015 5:53 PM

All replies

  • Hi SyedBilal07,

    As far as I know, the difference between the fastbood and the normal boot mode is that the fast boot will boot from the hibernate file and it won`t re-initialize the device driver. For a normal boot mode, it will re-initialize the device driver.
    Here is a link for reference of fastboot:
    Windows 8: Fast Boot (The theory should be applied to Windows 10, too)

    We could try to reinstall the driver from the device manager to have a check (Right click the driver, "Uninstall", then choose "Scan for hardware changes" from "Action" tab).
    I think this issue is more related to the driver, please try to download the latest Windows 10 compatible driver for the device from the device manufacturer website.

    Best regards

    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Monday, September 14, 2015 5:59 AM
  • Same issue here. Answer below is completely irrelevant to the question.
    Monday, September 28, 2015 11:48 AM
  • Tried It. Not Working. Please provide us a solution.
    Saturday, October 3, 2015 5:14 PM
  • I don't know why this is marked as an answer, but it isn't. He is talking about the android fastboot drivers that are needed to flash android images (bootloader, recovery etc) to android devices. Not the fastboot mode of his PC.

    I have the same issue, also had problems on windows 8, but was able to fix it, but upgrade to windows 10 and problems are here again. The fixes for windows 8 however don't seem to work anymore. With windows 8 the mayor problem was it being unsigned drivers, I don't know if that might also be the issue here.

    Tuesday, October 6, 2015 10:59 PM
  • Thanks for pointing out :) Marked it wrongly. Please solve the issue TechNet community members!
    Wednesday, October 7, 2015 9:48 AM
  • Now see my screenshot No 5. I have updated my link for the screenshot file. If you see my specified screenshot, you will be amazed to see that why my Android Driver is Provided By My "ESET NOD32".?

    From my personal research, i came to find out one solutions for our problem but they require Administrative Permission For Windows Folder. I am the Admin of my PC but unable to delete/move/copy files from Windows Folder. So, the solutions are : -

    For Windows 8/8.1, There is an UPDATE (http://support.microsoft.com/kb/2917929) which fixed the above issue and also Disabling the "Driver Signature Enforcement" worked on Windows 8/8.1

    There was a old solution also provided by XDA Community Member (janek2012 - http://forum.xda-developers.com/member.php?u=4753858). the solution was to replace the usbport.sys and usbhub.sys file of Windows/System32/Drivers Folder with the one he provided. The link for his thread is http://forum.xda-developers.com/showthread.php?t=2598155.

    But on my Windows 10, I am unable to copy these files because Windows 10 says "I don't have the rights to copy these files" although i am Admin of my PC. He also included Run.bat file in his USB.zip archive but when i ran it and restarted my PC, my mouse seem to be dead, no pointer. So dont try Run.bat file but copy those files manually. Try it, i cannot :( due to Administrative Rights. This is based on my own research.!


    Wednesday, October 7, 2015 10:03 AM
  • Dear members,

    have any of you got fix for above problem with windows 10, I am also facing similar issue and thinking go back to win 7.

    Wednesday, November 4, 2015 10:31 AM
  • OK I waste hours and I end up here...no solution?


    So backward compatibility is not a priority anymore?

    not good

    Thursday, November 19, 2015 12:43 AM
  • Hi !

    since two month i have the seem problem, my HTC One S is not reconize in fastboot mode with windows 10.

    I have tested a lot of things find on forums, but nothing works.

    Install/Deleted drivers, Test drivers HTC v3 and v4. Not works.

    Also the news usb drivers Samsung for win 10. Not Works.

    The USB drivers by google, not Works.

    And the Intel USB Flash loader utility. Not Works.

    Windows say "unknow device" when i plug the smartphone in fastboot mode.

    Hellllppppp !


    a lost french

    Monday, November 30, 2015 8:13 AM
  • are you a retard we are looking for a solution to use our phone on fastboot mode on windows 10 home/pro
    not a solution how to flash a phone -_- 
    So please Don't post irrelevant answers to the post 
    + up for this topic 
    we still need a solution for windows 10 home/pro so windows can install the drivers of fastboot 
    we still waiting Microsoft Please dont fail us you already provided an update to win 8 
    Monday, January 25, 2016 5:56 AM
  • I am really hoping that Microsoft pays attention to this one. I also have an htc one S and have spent two days trying everything I can to get the HBOOT mode to communicate to my Windows 10 using fastboot. I even contacted HTC directly. They insisted it can not be done, and the latest drivers from their sync manager should work, and if not, there's a problem with my phone, and I should send it in for $200++ so I could get it repaired.  I tried various drivers, the "Intel Android USB Composite Device" driver won't even install. It gives a code 43 Windows stopped this device because it has reported problems. So my phone is a brick until Microsoft figures this out, and provides us with a driver that works. My suspicion is that the driver does work, but detects some irrelevant handshaking protocol, and quits.

    Regarding normal mode... My phone is recognized as being connected, but as I don't presently have a working operating system on it, there's no communication possibilities. If I use the cmd terminal to invoke "adb usb" it responds with:

    adb server is out of date.  killing...
    * daemon started successfully *
    restarting in USB mode

    After this, if I try from HBOOT, I get:

    error: no devices found

    ... and the device manager says there is an unknown device and/or device failed Enumeration, whatever that is!!!

    Wednesday, March 30, 2016 5:55 AM
  • Try installing the registry patch mentioned in this thread:

    [GUIDE] Fix Fastboot on Windows 8.1 [Latest fix as of 8/25/14]


    I had the same issue and most threads suggested variations on reinstalling drivers.

    It turns out that all that was needed was to skip the BOS Descriptor Query.

    • Proposed as answer by TWKnight Wednesday, June 20, 2018 9:31 PM
    Tuesday, May 24, 2016 6:34 PM
  • Microsoft You sucks, this problem occurs for a year and no solution, no update. I really angry on You.

    I like windows 10 but it's not suitable for use.

    • Edited by Misiekxcv Friday, July 1, 2016 6:18 AM
    Friday, July 1, 2016 6:17 AM
  • I just wish people would STOP talking about other issues or operating systems, This is a WINDOWS 10 topic and related to a fastboot problem. so if you have no suggestion how to fix this, please reframe from posting here.

    Does anyone have a solution for this issue yet, or are we still waiting for a windows 10 update to incorporate our problem? (assuming it is a windows 10 problem) thanks in advance for replies and solutions given.

    Saturday, August 20, 2016 8:21 AM
  • This worked for me on windows 10
    • Proposed as answer by Fanta5 Friday, September 30, 2016 8:43 PM
    Wednesday, August 31, 2016 11:06 PM
  • Hello,

    there´s a solution for windows 10.

    I got my htc desire 500 into fast boot mode. (;-)

    Put this in a *.reg file (with your texteditor and rename the file to e.g. import.reg

    Windows Registry Editor Version 5.00


    Then import that import.reg via regeditor (as admin) into your registry. Then reboot your computer.

    Put your HTC device into fastboot usb mode. Plug it on your computer via usb.

    Then android drivers are beeing installed from Windows 10.

    Enjoy. (;-))))))



    • Edited by Fanta5 Friday, September 30, 2016 9:40 PM
    • Proposed as answer by Josh Soref Tuesday, October 11, 2016 6:00 AM
    Friday, September 30, 2016 8:47 PM
  • THANK GOD!!!

    Also worked in Windows 10 with a HTC One X - struggling for 2 whole days on this

    T H A N K    Y  O U

    Sunday, October 2, 2016 8:50 PM
  • I had the same problems, tracked down the issue to not correctly installed Android Fastboot mode device drivers for my device, fixed it by installing the latest Google USB drivers for the Android device in Fastboot Mode. Here is what I did:

    1. Enable ADB mode on my device and use the adb reboot bootloader command to reboot the device into fastboot mode. Note that fastboot mode is the same as the bootloader mode that appears, you don't have to select anything from the menu that is shown, if you select "start" or "recovery mode", the device will LEAVE fastboot mode. Also note that it might be possible to enter fastboot mode by pressing the correct key combinations during device boot, instead of using the adb reboot bootloader command. 
    2. Download and install Android Studio from https://developer.android.com/studio/index.html
    3. Start Android Studio, complete the install and choose the "SDK Manager" option from the Android Studio | Configure menu
    4. With the Android SDK tree node in the Default Settings window selected, choose the right Android SDK Location (the one used during the installation of Android Studio)
    5. On the SDK Tools tab, make sure the latest versions of the Google USB Driver and Android SDK Platform-Tools are fully selected and installed. If not, install them!
    6. Open the Windows Device Manager
    7. Right click the "Other Devices | Android" device with the yellow exclamation mark next to it.
    8. Choose "Update Driver Software..."
    9. Choose "Browse my computer for driver software"
    10. Browse to the location where the Google USB Driver from the Android SDK were downloaded. In my case, that was C:\Android\sdk\extras\google\usb_driver and click Next
    11. Windows should now install the correct driver and the device should appear in the Windows Device Manager as correctly installed device without an exclamation mark.
    12. Run any fastboot command, the command should now work!

    Hope this helps.

    Regards, Beat

    • Proposed as answer by Beat Nideröst Friday, October 14, 2016 11:03 PM
    Friday, October 14, 2016 11:01 PM
  • The registry fix recommended below worked for me with Windows 10 Pro 64 Bit and an HTC Sensation 4G.  I was unable to get adb to work but after running the reg fix, it runs.
    Thursday, January 5, 2017 6:17 AM
  • Put this in a *.reg file and rename the file to e.g. import.reg

    Windows Registry Editor Version 5.00


    Then import that import.reg via regeditor (as admin) into your registry. Then reboot your computer.

    Put your HTC device into fastboot usb mode. Plug it on your computer via usb.

    Then android drivers are beeing installed from Windows 10.

    Enjoy. (;-))))))



    This worked for me on Windows 10 64bit with an old HTC One m7 that wouldn't show when I ran fastboot devices. XDA Dev was down at the time so you sir are a life-saver. Thank you.
    • Proposed as answer by st0m Tuesday, May 30, 2017 3:19 PM
    Tuesday, May 30, 2017 3:19 PM
  • Thanks a lot for posting this.

    HTD Droid Incredible 4G LTE / Windows 10 64 was not cooperating , but this registry change allows fastboot to work. It's appreciated

    Tuesday, May 30, 2017 6:22 PM
  • Thanks a Lot it Worked on Win 10 X64 buid 1809
    Thursday, January 17, 2019 8:30 AM
  • This definitely worked for me attempting to connect to my HTC Incredible S recently.

    Just for reference in case anyone comes across this. 

    Had to do a few steps to get it all to work:

    1. Install HTC Sync.

    2. Once you have done this go to Control Panel -> Programs and Features then uninstall the HTC Sync program (the one with the sync icon) but leave the drivers etc installed.

    3. Then download and install the Android SDK and update it as per the instructions https://www.andreszsogon.com/using-android-8-and-9-emulators-without-android-studio/

    4. You then want to create a folder called C:\Android.

    5. Now browse to the C:\Users\<username>\AppData\Local\Android\android-sdk\platform-tools folder and copy the adb.exe, AdbWinApi.dll and AdbWinUsbApi.dll files to C:\Android.

    6. Now make the change to the registry as noted by Fanta5 in this thread (thanks for finding it in XDA and posting ...can be hard to find things over there).

    7. Restart your PC.

    8. If you are unlocking the bootloader for your HTC device - put the "fastboot.exe" file from the HTC Dev webpage (https://www.htcdev.com/bootloader/) here as well. Also put any recovery mods, roms, etc here as well.

    9. Make sure - if you can that - that you boot your phone normally and go into the settings and turn USB Debugging "ON" and Fastboot "Off" (the second one is you can get to the bootloader on your phone using the appropriate key combinations). You may also want to turn on the option to install apps from unknown sources. Power off your phone.

    10. Now turn on your phone into Fastboot mode then connect it to the PC it should change to Fastboot USB. 

    10. Open a command prompt as administrator and browse to C:\Android. You should now be able to use the Fastboot command. 

    • Edited by Darth Riker Wednesday, January 23, 2019 11:16 AM
    Wednesday, January 23, 2019 10:57 AM