none
Set Time Automatically Option Grayed Out RRS feed

  • Question

  • I have several Windows 10 Professional clients and a Windows 2012 R2 Essentials server.  After running the Windows Server Essentials Connector Configuration Wizard and joining my workstations to the server, I found that some of my settings are "locked" or "grayed out" with the message that "Some settings are managed by your organization".

    I found that if I open the Windows 10 settings screen and then select Time & Language, there is a Date & Time section.  Under that is an option to "Set time automatically" which is set to the On position and grayed out.

    There is also a Change button under Change date and time which is also grayed out.

    I currently have a need to change these settings.  I am administrator on the workstations and an administrator on the domain and server.

    I want to know how to I can modify these settings (either by changing a group policy object or making changes in the registry).

    Monday, January 18, 2016 4:36 PM

Answers

  • Hi adutchman,

    Please check the following group policy.
    computer Configuration\ Windows Settings\ Security Settings\ Local Policy\ User Rights Assignment   > change the system time
    Assign the users with the permissions.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, January 19, 2016 6:20 AM
    Moderator

All replies

  • Hi adutchman,

    Please check the following group policy.
    computer Configuration\ Windows Settings\ Security Settings\ Local Policy\ User Rights Assignment   > change the system time
    Assign the users with the permissions.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, January 19, 2016 6:20 AM
    Moderator
  • Hi adutchman,

    Please check the following group policy.
    computer Configuration\ Windows Settings\ Security Settings\ Local Policy\ User Rights Assignment   > change the system time
    Assign the users with the permissions.

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    MeipoXu

    We are having the same issue as with adutchman. I have implemented your suggestion with no luck. Any other suggestions?

    Monday, February 8, 2016 6:23 PM
  • We are also having the same issue and the suggestion to change the "Change the System Time" setting in Group Policy didn't work.  Anyone else have any suggestion for us?
    Thursday, March 3, 2016 10:13 AM
  • it may sound crazy but you can change it from control panel

    - Open control panel

    - Click Date and Time

    - Change Date and Time.

    - Pick a date and time

    - then press ok

    It should work

    • Proposed as answer by Connann2 Saturday, September 24, 2016 1:12 PM
    Thursday, June 16, 2016 6:03 AM
  • it may sound crazy but you can change it from control panel

    - Open control panel

    - Click Date and Time

    - Change Date and Time.

    - Pick a date and time

    - then press ok

    It should work

    Yes, this work on domain added PC.

    But this not working:

    Please check the following group policy.
    computer Configuration\ Windows Settings\ Security Settings\ Local Policy\ User Rights Assignment   > change the system time
    Assign the users with the permissions.

    Neither in local group policy nor in Domain policy

    Saturday, September 24, 2016 1:11 PM
  • You must disable NLA service (Network Location Awareness). This service is responsible for network recognition - important for example for firewall profiles (domain, private, public) and with this service disabled You will have the opportunity to change "Set time automatically" to on or off position.

    But! In domain automatic time&date setting is by default - from Windows NT era - so disabling this option is useful only in some very rare scenarios - especially in testing, not in production.

    Time and date change is possible through "legacy" control panel - of course user must have permission to do it because by default only administrator is allowed to do it.

    Regards,

    e-micra

    • Proposed as answer by e-micra Wednesday, May 24, 2017 8:22 AM
    Wednesday, May 24, 2017 8:22 AM
  • it may sound crazy but you can change it from control panel

    I can change it from control panel but it almost immediately changes back. (I just want to change it if only by a few seconds for testing some software.) But stopping NLA service (see other reply) allowed the change to stick.




    • Edited by APhillips Tuesday, December 12, 2017 5:58 AM
    Tuesday, December 12, 2017 5:45 AM
  • I have confirmed this works.

    The issue is that if you have a GPO that restricts any part of the time changing then the Windows 10 Metro view of the time settings are grayed out completely. So if you go to the settings via right clicking the time in the tray and choose Adjust date/time, you can see them grayed out.

    BUT, If you go via the old school control panel, then Date and Time, you can access and change the portions you need to that remain unlocked.

    I suspect the key culprit is when the system is domain joined, the default GPO sets the time server as the domain controllers - which is good! (don't change this!), so this is the settings that shows it as "managed by your organization" in the metro view of the settings.

    You will find a lot more settings easier to manage if you skip the new metro version of the settings and just locate the old school version. Unfortunately they are hidden away.

    As a side note, the GPO settings mentioned a few posts prior will affect what is available to change under "Date and Time", but in most instances are by default unlocked. But, you still got to view it under old school control panel "Date and Time"

    Cheers!


    Virtual Samurai - MCP, CCNA

    Monday, August 26, 2019 6:53 PM
  • Thanks!
    Monday, September 30, 2019 4:40 PM
  • None of the above options work, it remains greyed out but, my issue is that there is one person only who has their clock 10 min behind for some reason and it wont allow to change.  Everyone else on this server controlled time is fine but this one person. 

    The control panel method works briefly but auto switches back... I added the user /w Permisssions but still nothing... Anything in the Reg. that will do this? 

    Tuesday, November 19, 2019 6:35 PM