none
Administrator access using a Microsoft account (Workgroup)

    Question

  • Hi,

    I'm using a Microsoft account on top of an administrator account in Windows 8. It will happily show me that my account is an Administrator under Manage Accounts. The problem is, I don't have access to modify files that have security permissions for the local Administrators group.

    If I create a test text file under the root of C:\, it defaults to having permissions of Authenticated Users having modify, Users (local) having read, and Administrators (local) having full control.

    If I remove the Authenticated Users permissions, I can read the file but not save (as per the Authenticated Users permissions), but I'm an Administrator in the Administrators group which has full access.

    I've tried adding my Microsoft account into the local Administrators group, but it converts it to the local account it's sitting on top of, and says that account is already a member of Administrators.

    If I do the reverse on the file, and try to add my local account onto the security of the file, it converts it to my Microsoft account and it all works.

    Is this a Windows 8 bug, by design, or is there some other way I can get around this without just giving my account full access to all the files?


    Wednesday, November 7, 2012 8:35 AM

Answers

  • Hi,

    Just kill it by Task Manager, then start a new Explorer process by Task Manager with Elevated Priviledges.


    Juke Chou

    TechNet Community Support

    Monday, November 12, 2012 2:05 AM
    Moderator
  • See the screenshot above, you need to check the option "Create this task with administrative privileges". \

    Note: this is just for test. You cannot run explorer under Administrative Context for normal use. This is because all the Windows Store Apps cannot start if explorer is running under administrative context.


    Juke Chou

    TechNet Community Support

    Monday, November 12, 2012 2:09 AM
    Moderator
  • Hi,

    This is by design. It is caused by UAC enabled. UAC make the account token into split token. If you donot explicitly define your account's rights in ACL, maybe you could not inherit rights from a group you reside in. You could try to disale UAC for a test on this.


    Juke Chou

    TechNet Community Support

    Thursday, November 8, 2012 7:59 AM
    Moderator

All replies

  • Hi,

    This is by design. It is caused by UAC enabled. UAC make the account token into split token. If you donot explicitly define your account's rights in ACL, maybe you could not inherit rights from a group you reside in. You could try to disale UAC for a test on this.


    Juke Chou

    TechNet Community Support

    Thursday, November 8, 2012 7:59 AM
    Moderator
  • Hi,

    Sorry, I have not noticed that Windows 8 has already changed the process of UAC. Explorer will always run under split token so that you still get that access denied message.

    Please kill explorer process by Taskbar and start Explorer with elevated privilege to check that.


    Juke Chou

    TechNet Community Support

    Friday, November 9, 2012 9:07 AM
    Moderator
  • Thanks for the repsonse. I'm not sure how I can actually run Explorer with elevated privilidges?
    Saturday, November 10, 2012 3:44 AM
  • Hi,

    Just kill it by Task Manager, then start a new Explorer process by Task Manager with Elevated Priviledges.


    Juke Chou

    TechNet Community Support

    Monday, November 12, 2012 2:05 AM
    Moderator
  • See the screenshot above, you need to check the option "Create this task with administrative privileges". \

    Note: this is just for test. You cannot run explorer under Administrative Context for normal use. This is because all the Windows Store Apps cannot start if explorer is running under administrative context.


    Juke Chou

    TechNet Community Support

    Monday, November 12, 2012 2:09 AM
    Moderator
  • Wow didn't realise that option was there, thanks!
    Friday, November 23, 2012 2:25 PM
  • NP!, glad it could help you. :)

    Juke Chou
    TechNet Community Support

    Monday, November 26, 2012 6:46 AM
    Moderator