none
Wireless Network Connection doesn't have a valid IP configuration

    Question

  • Just purchased a new Windows 7 laptop.  Trying to connect via Borders free WIFI.  Seeing and connecting to the borders network, but getting an error "Wireless Network Connection" doesn't have a valid IP configuration

    Is there any way to resolve this?
    Sunday, October 25, 2009 4:59 PM

Answers

  • Hi,

     

    I would like to confirm the following questions first:

     

    1. Is there an exclamation mark or question mark in Device Manager?

     

    2. Can the Windows 7 machine connect other wireless network successfully?

     

    Please refer to the following steps to troubleshoot the issue.

     

    1. Upgrade the Wireless network adapter driver. First you might go to Device Manager, right click your hardware device in the list and select Update Driver Software; then click Search automatically for updated driver software.

     

    Note: Drivers on the Windows Update site are directly provided by hardware manufacturers. Microsoft tests drivers in various environments before they are published; however, we cannot guarantee all drivers will work on all hardware platforms as there are too many different models, although their hardware ID are the same as the standard version. In some cases, due to hardware modifications by different manufacturers, the driver updates may cause some error.

     

    If it still does not work on your issue, I'd suggest you installing the Vista driver in Compatibility mode. Remove and rescan that hardware device in Device Manager, right-click on the driver executable/installer file -> Properties and select the Compatibility tab; click the checkbox before Run this program in Compatibility mode for option and select Windows Vista in the list-down box; then try installing the device driver via Run as administrator. In addition, you can use the Windows XP driver for testing.

     

    2. Obtain IP address automatically.

     

    a. Click "Start", input "NCPA.CPL" (without quotation marks) and press Enter.

    b. Right click on the connection that you use for the local connection, and then click "Properties".

    c. Click to select "Internet Protocol Version 4 (TCP/IPv4)", and then click "Properties".

    d. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    e. Click "OK".

     

    If the issue persists, please move the Windows 7 machine to another Wireless network for a test.

     

    Thanks,

    Novak

     

    • Marked as answer by Novak Wu Friday, October 30, 2009 12:54 AM
    Monday, October 26, 2009 6:24 AM

All replies

  • Hi,

     

    I would like to confirm the following questions first:

     

    1. Is there an exclamation mark or question mark in Device Manager?

     

    2. Can the Windows 7 machine connect other wireless network successfully?

     

    Please refer to the following steps to troubleshoot the issue.

     

    1. Upgrade the Wireless network adapter driver. First you might go to Device Manager, right click your hardware device in the list and select Update Driver Software; then click Search automatically for updated driver software.

     

    Note: Drivers on the Windows Update site are directly provided by hardware manufacturers. Microsoft tests drivers in various environments before they are published; however, we cannot guarantee all drivers will work on all hardware platforms as there are too many different models, although their hardware ID are the same as the standard version. In some cases, due to hardware modifications by different manufacturers, the driver updates may cause some error.

     

    If it still does not work on your issue, I'd suggest you installing the Vista driver in Compatibility mode. Remove and rescan that hardware device in Device Manager, right-click on the driver executable/installer file -> Properties and select the Compatibility tab; click the checkbox before Run this program in Compatibility mode for option and select Windows Vista in the list-down box; then try installing the device driver via Run as administrator. In addition, you can use the Windows XP driver for testing.

     

    2. Obtain IP address automatically.

     

    a. Click "Start", input "NCPA.CPL" (without quotation marks) and press Enter.

    b. Right click on the connection that you use for the local connection, and then click "Properties".

    c. Click to select "Internet Protocol Version 4 (TCP/IPv4)", and then click "Properties".

    d. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    e. Click "OK".

     

    If the issue persists, please move the Windows 7 machine to another Wireless network for a test.

     

    Thanks,

    Novak

     

    • Marked as answer by Novak Wu Friday, October 30, 2009 12:54 AM
    Monday, October 26, 2009 6:24 AM
  • HI Novak,

     

     I am having a similar problem except I have tested this setup using another wireless network and everything works OK so I am wondering if it is my hoome wireless router network that is the problem.

    1. My network is set up so that my home devices have restricted access and I am running Windows 7.

    2. I put my laptop's Wireless Network Adapter's MAC/Physical Address into the router's wireless setting instead of my laptop's MAC because I was thinking that this network adapter is the bridge/interface that connects my laptop to the network and thus the network should know about the adapter not the laptop.

    2b. Note: the other devices I have entered into the router all work OK.

    3. I did everything you mentioned above in step 1 and 2 above where you are making sure that we have the latest drivers and that we get a dynamically generated IP address. There is no exclaimation point in the Device Manager and I do have the latest driver for the adapter.

    So now I get this same error for my home network but at other locations I can connect with no problem.

    Thanks for your help.

    Friday, June 10, 2011 9:59 PM
  • Hi,

     

    I would like to confirm the following questions first:

     

    1. Is there an exclamation mark or question mark in Device Manager?

     

    2. Can the Windows 7 machine connect other wireless network successfully?

     

    Please refer to the following steps to troubleshoot the issue.

     

    1. Upgrade the Wireless network adapter driver. First you might go to Device Manager, right click your hardware device in the list and select Update Driver Software; then click Search automatically for updated driver software.

     

    Note: Drivers on the Windows Update site are directly provided by hardware manufacturers. Microsoft tests drivers in various environments before they are published; however, we cannot guarantee all drivers will work on all hardware platforms as there are too many different models, although their hardware ID are the same as the standard version. In some cases, due to hardware modifications by different manufacturers, the driver updates may cause some error.

     

    If it still does not work on your issue, I'd suggest you installing the Vista driver in Compatibility mode. Remove and rescan that hardware device in Device Manager, right-click on the driver executable/installer file -> Properties and select the Compatibility tab; click the checkbox before Run this program in Compatibility mode for option and select Windows Vista in the list-down box; then try installing the device driver via Run as administrator. In addition, you can use the Windows XP driver for testing.

     

    2. Obtain IP address automatically.

     

    a. Click "Start", input "NCPA.CPL" (without quotation marks) and press Enter.

    b. Right click on the connection that you use for the local connection, and then click "Properties".

    c. Click to select "Internet Protocol Version 4 (TCP/IPv4)", and then click "Properties".

    d. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    e. Click "OK".

     

    If the issue persists, please move the Windows 7 machine to another Wireless network for a test.

     

    Thanks,

    Novak

     

    this was not helpful, and was seemingly retarded. thanks bai.
    Saturday, July 02, 2011 11:31 AM