none
Cannot turn on “Network Discovery and File Sharing” with Firewall off and relevant services running

    Question

  • I cannot turn on network discovery and file sharing on a Windows 7 PC.

    I have turned off the firewall and ensured the following services have started:

    -      DNS Client

    -      Function Discovery Resource Publication

    -      SSDP Discovery

    -      UPnP Device Host

    Is there anything that I am missing?

    Any tip will be greatly appreciated.


    Hong

    Sunday, November 18, 2012 3:56 PM

Answers

All replies

  • I got the following error when I ran Homegroup trouble shooter

    Windows Firewall is preventing HomeGroup from communicating
    This happened when the firewall was off.


    Hong

    Sunday, November 18, 2012 4:12 PM
  • I uninstalled Norton Security Suite, and disabled Windows Firewall, and network discovery and file sharing started working.  However, it stops working as soon as Windows Firewall is enabled even after restoring defaults of Windows Firewall.

    Hong

    Sunday, November 18, 2012 4:57 PM
  • I got the following error when clicking "Restore Default Policy" under Windows Firewall with Advanced Security on Local Computer:

    Windows Firewall could not restore the default policy

    error:3


    Hong

    Sunday, November 18, 2012 5:22 PM
  • Problem has been solved by importing policy exported from another working Windows 7 computer:

    Control Panel\System and Security\Windows Firewall > Advanced settings > Import Policy...


    Hong

    Sunday, November 18, 2012 8:49 PM
  • Hi,

    I’m glad to hear your issue has been resolved. Hope your experience will help other community members facing similar problems.

    Regards,

    Leo   Huang

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.


    Leo Huang

    TechNet Community Support

    Monday, November 19, 2012 6:23 AM
    Moderator
  • Me too. Now wondering how to explain to my client that, apparently, his system must be rebuilt.

    Computer Guy

    Sunday, June 30, 2013 8:24 PM
  • I ran into the same issue with a client and after checking the services and other options I found a fix:

    I first attempted to add the predefined rule "Network Discovery" to the Inbound Rules on the PC, but the Predefined section was greyed out.

    I then discovered the registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SharedAccess\Defaults

    was missing completely. It's possible the PC got hit with malware before and the malware deleted the key.

    I exported the above mentioned registry key from a working and clean Win7 system and imported it into the affected PC.

    Ran the Windows firewall inbound rule wizard and now the predefined field is working.

    Added the "Network Discovery" defined rule to the inbound rules, opened up the network and all of the domain PCs could be seen again.

    I hope this helps.

    • Proposed as answer by JRBlood Thursday, September 19, 2013 9:19 PM
    Thursday, September 19, 2013 9:18 PM
  • Thanks JRBlood!

    I was looking at all the solutions and yours made perfect sense.  I was able to import the registry key from a 32bit win7 to 64bit and it worked perfect.

    Sunday, December 01, 2013 9:13 PM