Parental Controls causing Internet explorer to close



    I have three profiles on my Vista Home premium laptop. One is the Administrator and there are two standard accounts. One of the standard accounts has parental controls setup. Recently this account stated receiving errors on startup and Internet Explorer started to close itself as soon as it launched.


    Here are the error messages;

    • Com Surrogate has stopped working.
    • Ituneshelper Module has stopped working.

    If I turn off parental controls these errors go away and I can access the Internet. The problem re-occurs if I turn on parental controls.


    I have stopped the Comm Surrogate error by adding dllhost.dll to the DEP exception list. Although I believe this is not the cause of the problem. Parental controls seems to be corrupt or something. Here are my parental controls settings.

    • I have Medium web content restrictions enforced, several address listed in the allow list, including the home page.
    • Time restrictions are off.
    • Game ratings set to PG.
    • Program limits are Off.
    • File downloads are blocked, but I did allow them during my troubleshooting, and it didnt change anything.

    None of the other accounts have this problem, I even deleted the profile and created a new one, but the problem remained. The activity reports do not show any site blocks. Also, the Problems and Solutions finder has no problems listed, even though the error messages above tried t look online for a solution.


    Any help you can provide me would be very welcome. My son wants to b able to browse the internet but Im not letting him on without the proper controls in place.






    Saturday, November 29, 2008 8:43 PM

All replies

  • Update: I installed Firefox and this too will not launch. So it is not an IE problem. Firefox reports that it encountered an error while trying to open.

    I have also started and stoped the parental control service WPCSvc. This did not help so tried unregistering and re-registering the WPCSvc.dll file. When doing this I get the error 'the entry-point dllunregisterserver was not found'. So I am presuming this dll cannot be registered.

    At my wits end here, are there any tools out there for troubleshooting parental controls?
    Sunday, November 30, 2008 10:58 PM

    Another update:


    If I try and ping any internet site I get the error .TCP/IP request has stopped working'.


    I have also tried turning User Account Control back on, but that didnt change anything.


    Parental Controls is definately stopping the request but itdoesnt seem to be doing it properly????

    Tuesday, December 02, 2008 8:03 PM