Unable to restore from previous version


  • I need to restore the Windows\CSC folder from a previous version for one of my users. (Short version - To fix an issue with offline folders the helpdesk re-initialised the cache. SyncCentre was reporting successful syncs, but wasn't actually updating the network drive. So when the cache was reset, the user lost a load of work. The user is the CIO, so this is kind of a big deal.)

    In the Previous Versions tab, the Restore button is greyed out, and  attempting to open or copy the folder gives an error of "You do not have permission to perform this action. You need permission from the Administrator of this computer".

    The problem is that I have tried to do the restore logged on as the user (and again after adding them to the Administrators group), a different user in the administrators group, as the local admin, and as a domain admin. I've tried taking ownership and changing permissions on the folder, with the same error. I don't even have permissions to see who the owner is, regardless of which account I log on with.

    I've tried a System Restore, Safe Mode, running explorer as an admin, running third party file explorers as admin, takeown and icacls commands from an administrative command prompt, and disabling UAC. I've removed the hard drive and mounted it as an additional drive on a workstation logged in as domain admin.

    I've managed to recover some data using an undelete tool, but it's not complete. Is there any way I can extract the documents from the shadow copy data?

    Thursday, January 10, 2013 1:29 PM


All replies

  • In the Previous Versions tab, the Restore button is greyed out


    Based on my knowledge the Restore Button is greyed out may be due to the GPO settings.

    How to Disable the System Restore Configuration User Interface

    Also the button was greyed-out, it means that we cannot do any system restore. That's why you could not use a System Restore.

    Finally for the error message You do not have permission to perform this action. You need permission from the Administrator of this computer, you can refer to the solution from the link below:

    Hope this helps.


    TechNet Community Support

    Friday, January 11, 2013 4:48 AM
  • Spencer, thank you for your response, but it is not the answer, and should not be marked as such.

    The System Restore Configuration User Interface is NOT disabled through GPO.

    I was able to use System Restore to revert to an earlier point in time for the OS, but it did not restore the Offline Folder data. Which is by design, I know that System Restore does not change user documents.

    As stated in the third paragraph of the original post, ownership of the the folder cannot be changed, so the article is not a solution. I have already tried that, and as stated in the penultimate paragraph, many other things besides.

    Friday, February 01, 2013 11:18 AM
  • You must have a very patient CIO, seeing that he is prepared to wait thee weeks or more for this issue to be resolved. In view of the absence of any response for such a long time I am not surprised that Spencer marked his reply as an answer.

    You can mount System Restore Points as a VHD, then restore any file or folder to any location you choose. This tool will do it:

    Friday, February 01, 2013 12:55 PM