none
Data Exceution Prevention settings greyed out

    Question

  •  

    Running Windows Vista Business x86 and x64, this occurs on both platforms.

     

    When I go to the "Data Execution Prevention" tab in system properties - performance options, all the
    settings that can be changed are all grayed out. It then indorms me: To use these settings, you must be a computer administrator and you must use the bcdedit.exe file.

     

    Screenshot:

    http://img452.imageshack.us/img452/7967/depproblemcx4cg1.jpg

     

    I am the administrator (using the built in admin account), now I know how to toggle DEP on and foff via the command line but is there any commands to toggle the status of DEP for specific applications, or better still any ideas on how I can retrieve the settings functionality back? Its really annoying as I have to now turn DEP off completley otherise many applicatiosn simply do not work.

    Saturday, May 19, 2007 7:00 PM

All replies

  • Ive managed to fix it, I found another command to use which none of the sites seem to tell you when telling you how to enable/disable via the command line.

       When enabling:

                bcdedit.exe /set {current} nx AlwaysOn 
                  bcdedit.exe /set {current} nx optin

       When disabling:

                bcdedit.exe /set {current} nx AlwaysOff

    Then restart!

    This has worked for x64 and x86, thanks for the members who viewed the thread though.

    Sunday, May 20, 2007 7:53 PM
  • Excellent piece of information. Not available anywhere in the web. Great service. Thanks.

     

    Friday, November 30, 2007 4:35 PM
  • Never considered DEP being the problem. After some failed searches this turned out to be my problem.

    When I did a P2V the VM was able to actually USE DEP on the new system and my java.exe was being forced to be checked and crashing out my tomcat services. Thank you for the update and fix!

    Saturday, October 26, 2013 7:41 PM