Windows 7 (32 bit) printer spooler problem


  • I am not sure if this is the correct forum, but I am sure someone will redirect me if necessary.

    I have encountered a problem with the spooler service under Windows 7 (32 bit). What I tried to do was print a page from an Internet site by using the "print" button. What happened was that the spooler service crashed. Every time I tried to restart it, it stopped again.Eventually I realised that the print file I had requested was somehow corrupt. Every time the spooler was started, it tried to print this file and promptly stopped again. The only way I could get the printer back into service again was to go to the spool folder and manually delete the files there. Then the printer could be "seen" again as the spooler stayed running. Is there another (easier) way to get rid of an errant print file? What caused the spooler to crash in the first place?

    Many thanks for any help

    Wednesday, September 21, 2011 5:05 PM

All replies

  • Hello geofflh,

    This is the right forum you are posting your question in. For as far as I know, there is no easier option than to remove the file from the printer spooler. To answer your last question regarding what caused the crash: when a file is corrupt or very large (larger than 10MB) the printer may have difficulties processing the file and could stop responding. The best thing to do here is printing the webpage to an XPS-file:

    - Press [CTRL + P] to bring up the 'Print'-window
    - Select the "Microsoft XPS Document Writer"-option and click print
    - Select a location on your hard drive and save the webpage

    If you can open the XPS-file, you know for sure that the file is not corrupt to prevent printing spooler issues. You should print the XPS-file in stead, since it's not corrupt and you have a better view of what your printed webpage will look like.

    With kind regards,

    Thursday, September 22, 2011 7:16 AM
  • Thanks for your input. My main concern about removing the file manually is that of actually locating the spools folder. I work in IT so I know my way around the file system pretty well and therefore knew what to look for and what to do when i located the file in question. My primary reason for the post was to see if anyone had a simpler answer for those who are not so "IT savvy".

    BTW, my file was nowhere near as large as 10MB, so the problem was not due to the size of the file. However, that said, the idea of using the XPS Document writer in those circs is certainly a good one. I will remember that!

    I should also say that I have printed off web pages before and after this incident - so I am still at a loss as to what happened thistime!

    Thanks again

    Thursday, September 22, 2011 9:28 AM
  • Hi Geofflh, 

    I am also a layman like you i.e. I am also not so IT Tech Savvy. I too faced a problem related to Print spooler. While surfing the web, I cam across the below given link. Please check it may be it can be of some help to you.

    Tuesday, June 26, 2012 6:04 AM