No Audio from Windows Media Player 11


  • Hi,

    When I play a DVD or MP3 with Windows Media Player 11 (WinXPproSP2) the movie plays but there is no sound. There is audio if I use WinDVD or Real Player so it is not a hardware problem with the laptop.

    Just wondering if anyone has any suggestions. I did recently install an MP3 ripper if that is of any use.

    Thank you.


    Wednesday, April 11, 2007 9:24 PM


  • simple fix. try start-control panel-sounds right click the entry "speakers" and select "set as default". i found on mine that if it was set to "digital" which it was be default, that the dvd audio wouldn't play in wmp11
    Friday, May 25, 2007 1:12 AM

All replies

  • Hi, I would suggest to remove those software first. Then, remove Media Player 11 and re-install it. CHeck whther the sound come back.
    Saturday, April 14, 2007 7:03 AM
  • Thanks for coming back, Richard. Have uninstalled all software since I last used Windows Media Player 11, according to Add/Remove Programs. Uninstalled WMP11 which rolled back to WMP9 and then reinstalled WMP11. Still no audio with both.

    Audio and DVD work perfectly with Real Player and WinDVD so just don't know why WMP11 won't play audio but will play video. Seems to give a small 'click' sound when starting to play an MP3. Would appreciate any other suggestions.



    Saturday, April 14, 2007 11:57 PM
  • Um, do you have two sound card in your PC? Such as on-board sound and add-on sound card?
    Sunday, April 15, 2007 5:45 PM
  • I've had similar problems just a few days ago. I downloaded codecs from DivX and it fixed the issue.
    Sunday, April 15, 2007 8:40 PM
  • Hi Richard, easterbunny,

    I'm using a laptop with a single on-board soundcard. Did install DivX codecs but still no audio. Decided to install Microsoft's latest Media Player, Zune and this plays all audio as normal. WMP11 however still has no audio. Bizarre! Have defaulted all audio files to use Zune and will have to use WinDVD for DVDs.

    Thank for your help.


    Sunday, April 15, 2007 10:07 PM
  • You may try to install the Vista codec pack:


    Monday, April 16, 2007 3:17 PM
  • Richard - I am using a Vista set-up with ban ATI card (X1650) using DVD out to a sony flat screen.  Same deal as above - sound all round but not with DVDs or with HD TV Free to air (although standard def digital is ok).

    The HDMI is fed using an ATI Catalyst driver (I am on 7.3) and Realteck HD Digital Sound - there are pretty much the latest drivers that don't cause a BSOD!

    I can use Cyberlink DVD 7- under which sound was fine on DVD's - I uninstalled it and installed the CODEC package but to no avail, still no sound on DVD under Media Player or Media Center.

    My Tuner Cards are Hauppage Nove 1100 but I cannot imagine this is the problem.

    Any advice would be greatly appreciated.  This seem to be a problem that crops up on a few message boards but nobody has any coherent answer to what is going on or how to fix it!

    Rgds & Thx.
    Friday, April 20, 2007 12:58 PM
  • I have a similar problem in that my medial 11 will play alright on my laptop speakers.  Then, it seems like when I change cds only the earphones work.  Can run utilities like Norton, for instance, which temporarily helps.  Hardware seems to be fine as far as I can tell.  I want to use this computer for sales work, and this problem is really annoying.  I want to try updated codec for Media 11 but only see a codec update for Media 10.  Will try this as a last resort.  Hope someone comes up with a fix.  There a lot of similar problems being talked about on the internet.
    Saturday, April 21, 2007 4:59 PM
  • um....using HDMI for output audio.....i am thinking about the driver problem....
    Tuesday, April 24, 2007 9:33 AM
  • I have a problem with WMP 10 - I havent seen a conversation on that in this site, so I thought that I would jump on in here, being that the problem I have is identical to the first one in this thread.

    I wondered if I should just download another DVD player software on line.

    Also, is there something that I should check on the laptop that I am using?

    Please note:  Am emailing from the deep bush in East Africa and am totally freaked out about crashing this thing (my only contact to the outside world right now, save for a 5 hour bumpy ride into the nearest town).  There is no possibility of getting help out here if it does crash!!  So anything easy and low risk in terms of suggestions for fixing this would be great!

    Thursday, April 26, 2007 1:52 PM

    Hi, I would suggest you to re-register the WMP related DLL files.

    (In Vista CMD should be opened as Administrator)

    1. RUN ->"CMD" press enter.

    2. type " regsvr32 <DLL file name with extension ".dll">


         Example :-C:\Windows\Systwm32>  regsvr32 wmp.dll  <Press Enter>



     There is more than 10 DLL files also to be re-registered. I forgot most of the files name. Please any one knows clearly about the list of DLL file please post it in this thread.

    Thursday, April 26, 2007 3:14 PM
  • Hi,


    If WMP11 worked before try to re-register the following DLL files


    Open CMD as Administrator then type the following commands.

    C:\Windows\System32>regsvr32 jscript.dll

    C:\Windows\System32>regsvr32 vbscript.dll

    C:\Windows\System32>regsvr32 wmp.dll



    Some files has to be re-register to fix this issue. I will post it later on if I collected all those file names.


    - Mathan Raj A

    Friday, May 18, 2007 11:08 AM
  • his problem is WMP don't have a sound when playing media files. It did not work from the beginning....
    Sunday, May 20, 2007 8:40 PM
  • simple fix. try start-control panel-sounds right click the entry "speakers" and select "set as default". i found on mine that if it was set to "digital" which it was be default, that the dvd audio wouldn't play in wmp11
    Friday, May 25, 2007 1:12 AM
  • Sellout - all I have to say is thank you! I suspected that the audio was being pushed to digital instead of analog, but you confirmed it.

    Just another tidbit: on my system, when digital was still set to default (under control panel -> hardware & sound -> sound), not only did the sound not work, but every 10 seconds or so, the screen would black out for a second or two.

    Thanks again, sellout!
    • Edited by Drokkon Thursday, July 1, 2010 10:30 PM
    Sunday, June 3, 2007 5:16 AM
  • For anyone who has this problem (no DVD sound in WMP11 & other DVD players working ok) can I offer the following solution.

    I simply installed AC3Filter which is an audio decoder and processor filter.
    The codec is a free download from the following link.

    Hope it works for others as well as it did for me.
    • Proposed as answer by Bill Perkin Monday, June 29, 2009 6:07 PM
    Monday, September 24, 2007 12:21 PM
  • I know these posts are a little old but every time I see them I am compelled to HELP anyone who cannot get sound from WMP11....           This fixed the same problem I, and many others had... Download the AC3 Filter Codecs from the post right above this one, it is a small and free, and has a 99.9% chance that you will solve the no sound problem... Good Health and Long Life ToolMan59..............


    Friday, November 2, 2007 1:10 AM
  • I was having some trouble with my audio drivers (no sound when using enhancments such as SRS) so I decided to reinstall my drivers. Simple enough right? Well I went to downloaded the correct drivers, uninstalled the old and installed the new. Restart. Oops? After the splash screen with the microsoft logo it just sits with a black screen and my mouse. I can control my mouse but no commands will work. So I did the following... (and I've already contacted dell and thanks to a tech support genius from India (out-sourcing jobs, way to go dell!)) it is worse than it started out(I'll explain).

    (all of this was done in safe mode which still works)
    1. tried last known good configuration
    2. system restore to before i uninstalled the original driver
    3. virus/spyware scan
    4. registry fixer
    5. checked the HDD for errors
    6. tried to boot from DVD to use the repair function but vista now will not boot from the install DVD either again stays on the splash screen (this time a vista theme wall-paper but still just the mouse and nothing happening)

    So I called Dell tech support and they had my uninstall my video driver (7600GT 163.69), I restarted and no help. They then had me go to BIOS and load defaults which causes me to get a "diskette drive 0 seek failure" every time I start the computer and I presume my media card reader does not work because windows update installed a floppy disk driver isntead. After loading defaults it still will not boot. After giving me the run around the tech said he would have to email me a solution when they researched the problem further. BUT MY PC STILL WILL NOT BOOT! I have don everything I can think of. I looked online and the only suggestion I have found is let it sit long enough to work itself out... so its been sitting about an hour now and still on a pitch black screen with the mouse in the middle.

    Any suggestions?

    My specs-
    AMD Athlon X2 5600+
    2GB 667Mhz Ram
    320GB WD HDD (two 150GB partitions)
    XFX 7600GT
    crappy dell mobo (nForce 410 i think)[audio is intigrated suposidly 7.1 HD audio)

    P.S. I'm tired of troubleshooting vista, it seems like every time I get everything working right another major problem pops up. I have re-installed vista so many times that my copied cds will not play due to the 10 liscence download limit on WMA format. Last time I ever use windows media player to copy a cd. Microsoft has really dropped the ball on vista. I love the new features (especially start menu search[btw that will be in SP3 of XP, if only I had known!]) but it looks like M$ dropped a beta on us and we were stupid enough not to wait for SP1. As always the early adopters get burnt. I am a gamer and DX10 is only on vista so for the future its the only option. I am ranting here but M$ goes so far to protect the big media corperations that they burn the end user's performance with tons of anti-piracy *** built into the OS. I am no pirate and I don't agree with the pirates but when it comes to hurting the performace of my PC thats crossing the line. With vista M$ sold out big time and even after selling out they only delivered a so-so at best OS. Not to mention, the vista certified scandal watch out if it says vista ready/certified I have found "vista ready" devices and software that "works with vista" are at best a 50-50 shot. After paying 200-400$ for an OS (Does anyone else think that price is rediculous by the way?) I was certianly expecting more.

    Saturday, November 3, 2007 9:18 AM
  • yes i did not find the solution regarding no audio when play my dvd to my computer

    Saturday, November 24, 2007 8:32 PM
  • thanks a ton man worked perfectly was crawlin forums for a while n your the only one with a good solution thanks again


    Thursday, November 29, 2007 9:25 AM
  • Help pliz! I have sound on my laptop in the morning, now there is no sound on my windows media player 11, i did an upgrade from WMP10 to WMP11. 


    Tuesday, December 4, 2007 4:44 PM

    DubReg, the ACfilter solution WORKS!!, Thanks a bunch. You Rock!
    Saturday, December 8, 2007 6:47 PM
  • Hi there: I have had almost a line item,word for word problem with M$ vista as you. You have taken the words right out of my thoughts. I have re-installed so many times that I have to beg the GAME companies to let me install my games without paying, and they are getting tired of me, but most of the GAME copanies are aware of the vista demolition derby OP system, some of them that I have talked with have had similar issues. I feel the same way as you do about this pre-mature release of vista. (YOU ARE SO RIGHT ABOUT THE PRICE ISSUE)... Oh yes; Lets not forget the miracle working software and computer experts from India. Case in point... I could hardley understand his broken english, then he proceeded to trash my boot drive, by having me do a clean install over my boot drive. Then he had someone else call me the following Sunday. At this point I refused anymore technical help, after all I can trash my system just fine myself. Don't get me wrong I have many very good friends from India, even my Dr. But at least he knows what he is doing...


    OK now that you have heard me vent I might have your solution... I wish that I had seen your thread earlier, you may already have fixed you PC...But there still might be someone out there with this problem...OK So here goes; I had the exact problem (ie).. Works in SAFE MODE but will not boot and all you have is a black screen with a curser?


    1): Install your (GRAFPHICS DRIVER SOFTWARE) while in SAFE MODE. I have a FX7300GT SLI system and I use the NVIDIA  ( ver.163.75 ) driver software... My MB is A8N-SLI Deluxe, four WD250GB dives, an AMD X24400 CPU and 4GB of Corsair PC3200 DDR. Aside from the Motherboard and drive configuration our systems are similar... You may have to adjust your features while in SAFE MODE but all you need to do is get the driver software to install and you should be up and booting...Yes it is almost allways something simple... So I hope this is your solution..... Good Health and Long Life...

    P.S. I think my Graphics driver became corrupted during one of my many re-installs. Never the Less this worked for me?




    Saturday, December 8, 2007 11:23 PM
  • I had the same problem.


    I kept digging around and found a recommendation.  Go to .  Download the installer and source code (you will see two separate downloads).  There is a language pack too, but I wouldn't bother with it unless I had to.  It's just more junk in your system. 


    This link is for the v.1.46.  I didn't see this until I was going back to look it up for you and others who haven't fixed the problem yet.  I actually installed v.1.45b.  But, it worked. Since it fixed my problem, I'm happy to take "Yes" for an answer and let it go at that.


    I hope this helps someone.


    Friday, January 18, 2008 6:58 PM
  • simple fix was right, I have been running all over the internet to download drivers for WMP11 and contacting tech support and here all along it was a slight modification from digital speakers to " set as default" and now everything is back to normal. Thanks Sellout for bringing sound back to my DVD's.

    Saturday, January 19, 2008 5:45 PM
  • what worked for me was turning off the SRS
    Monday, March 10, 2008 4:02 AM
  • One sentence solution and it worked wonders. Thanks a bunch! Appreciated.

    Monday, July 14, 2008 4:09 AM
  • Thanks Sellout, that fixed it for me!  I had my sound defaulting to Digital Audio Interface instead of speakers.  Such a simple thing but I missed it.  I had installed a new SB sound card since my old SB Live! was no longer supported under vista.  Funny thing is I was getting sound out of WMP 11 for mp3s, but not for sound from my DVD player.  I went into "Sound" from control panel and sure enough, the default was set to "Digital Audio Interface".  When I set "Speakers" to be the defaul, the DVD sound started working, and the mp3 sound still works.  I appreciate the help!




    Saturday, July 19, 2008 6:15 PM
  • I am still using XP Pro tried installing and uninstalling Media Player 11 several times still no sound.  Have added ac3 filter still doesn't work.

    What gives?
    Saturday, February 21, 2009 6:00 AM
  • did not work for me.  what's with Microsoft?
    Saturday, February 21, 2009 6:01 AM
  • My symptoms - XP pro, WMP11, codecs updated automatically.  went to play an mp3 and got no sound (all of a sudden - hadn't had problems in the past).  checked other mp3 files, some worked, others didn't.

    Dropped in the AC3Filter decoder and everything is peachy again.

    Thanks DubReg !

    Wednesday, March 4, 2009 3:35 PM
  • I have the same problem.  I called DELL Tech support since my laptop is still under warrantee and just re-installed windows XP Professional.  Still no luck.  dvd Video will play but no audio.  I tried playing with all the settings but still no luck.  I have other players and they work.  Only Windows Media Player has the problem.  Any sugestions?


    Thursday, March 5, 2009 7:21 PM
    Thursday, March 5, 2009 7:45 PM
  • BINGO.  This took care of two laptops that were driving me crazy.  DVD Sound is great now.
    Monday, June 29, 2009 6:07 PM
  • I've wasted half a morning looking for solutions and faffing around with various settings on my laptop
    The AC3 Filter solution worked brilliantly.  Many thanks
    Friday, August 14, 2009 1:22 AM
  • Hey DubReg! you rock man!! it works perfectly prayers :)
    Sunday, October 18, 2009 4:27 PM
  • simple fix. try start-control panel-sounds right click the entry "speakers" and select "set as default". i found on mine that if it was set to "digital" which it was be default, that the dvd audio wouldn't play in wmp11

    this answer from Sellout worked for me....... Kudos Sellout thanx heaps...
    Tuesday, November 3, 2009 9:51 AM
  • I tried to follow your direction. I have windows XP. I did start -> control panel, right click on Sound and Audio Devices, and opened. I do not see Speaker. How would I go to Speaker setting to default from digital?

    Thank You,
    Thursday, December 10, 2009 2:41 PM
  • I have tried most if not all.  What worked for me is down loading an AC3 filter, this can be done for free just search AC3 FILTER and take your pick you will find many. 
    Thursday, January 21, 2010 11:55 PM
  • I too have downloaded an AC3 filter .... still no sound with dvd's.  Quad core pc, vista home premium.  Any further suggestions?
    Tuesday, January 26, 2010 12:11 AM
  • Find the AC3Filter Config shortcut in your Start Menu, run it, click the System tab, make sure that all the boxes next to "Use AC3Filter for..." are checked, check the "Filter merit" setion and set it to "Prefer AC3Filter" and click "Apply". Then log off and log in. If still no sound the play with the settings - "Prefer other encoder", "Use WaveOut by default", the Output format in the Main tab. Be sure to log off and log in after applying changes.

    Tuesday, January 26, 2010 6:42 PM
  • The AC3 filter fixed my problem, thanks.
    Wednesday, January 27, 2010 6:23 PM
  • simple fix. try start-control panel-sounds right click the entry "speakers" and select "set as default". i found on mine that if it was set to "digital" which it was be default, that the dvd audio wouldn't play in wmp11
    Thanks worked perfect!!!
    Saturday, April 10, 2010 7:22 PM
  • same problem --no sound from windows media 11--running windows xp pro service pack 3 --I am running version nine of windows media player --and wanted to update --since the later versions seem to run really fast when I view them --I tried 4 times to install version 11 --each time --no sound --no matter if I actually removed the program version 9 and then installed 11 or not --no sound --my sound card is built into the mother board --and it works with all other programs except media player 11

    Saturday, April 17, 2010 9:37 PM
  • Holy ____!!!! Thank You... Thank You .... Thank You!!!! Before NO AUDIO.. after installing AC3Filter.. I HAVE AUDIO !!!! Wowie I cannot thank you enough for posting.. God Bless!!
    Saturday, May 29, 2010 10:06 PM
  • Hey I did not write anything nasty I wrote Holy Cr_ap.. I cannot believe that they edited that word.. Sorry but thanks again!
    Saturday, May 29, 2010 10:07 PM
  • Windows Media Player 11 was working fine until this morning. It would not play audio for mpeg, avi, mpeg or online videos that apparently use WMP 11. Online videos that used Flash player still worked so I knew my sound card and setup for Windows XP was good.

    After trying many suggestions I found online to no avail I found what worked for me.


    I rolled back WMP 11 to WMP 9.

    Control Panel > Add Remove > Selected WMP 11 > Remove > Rollback.

    Once that was completed WMP 9 would play audio.

    From WMP 9, I checked for updates. An update was found, WMP 11. After the update was complete, WMP 11 played all audio and video.


    Sunday, June 13, 2010 2:47 PM
  • Ok so I found this topic through google after attempting to search for my no audio problem in WMP when i tried to play a movie I downloaded. This link that DubReg supplied instantly solved the problem and my movie has sound thanks a bunch just had to share my gratitude!
    Tuesday, July 13, 2010 6:20 AM
  • That worked!  Thanks!
    Sunday, July 25, 2010 10:05 PM
  • What OS are you using, if it is VISTA SP2 uninstall the Service Pack 2 and you get sound back through the HDMI. It worked for me.


    Saturday, October 9, 2010 6:05 PM
  • I have stumbled upon an annoying problem. All media files (mp3, wav, mkv and even from optical drive) do not have audio in WMP for windows 7 HP. In other programs such as VLC, SMplayer, Quicktime and MPC sound works without a problem.

    I had earlier installed K-lite codec x64 which enabled watching mkv files in WMP and it worked great, but yesterday audio stopped playing. I had not tampered with any codecs prior to this happening. So basically I have tried every single solution given on forums since over 4 hours back, and nothing.

    I have tried uninstalling K-lite, nothing. Reinstalling it nothing. I have tried AC3 codec, nothing. I have gone into playback devices and unchecked "Allow Applications" still nada.

    But the last mentioned did show me something rather interesting all programs except WMP uses Speakers (rightly so) and WMP uses Realtek Digital output when playing (as seen on the bars next to the icons). So I presume that you have to change that, but I have no idea how to do it. Hopefully someone can give me a solution soon.





    Friday, April 8, 2011 9:35 AM
  • If you downloaded the AC3 filter but the sound still doesn't come on your WMP video, maybe the AC3 filter from the above link was corrupt.  Try getting the AC3 filter from instead.  And if you download it to your My Documents, don't forget to go there and click on it to install it.  One more thing - the 'full' version worked for me (minus the language files).
    Monday, August 29, 2011 11:35 AM
  • honestly all you have to do for this issue is go to windows media player properties/ more options. then click the tab that says devices. click speakers and chose what speakers you want to play this out of. saves the time from doing this in control panel. hope this helps :)
    Wednesday, September 28, 2011 7:53 PM
  • i highly recommend this site below and download the software .. it work 99.9% ...



    thanks i solve my problem....

    Saturday, October 8, 2011 5:42 PM
  • hello..
    thanks a lot..
    Sunday, January 22, 2012 7:09 AM
  • That worked perfectly for me.

    Thanks DubReg

    Monday, March 26, 2012 9:37 AM
  • Thanks for the simple solution.  I get annoyed with the "reinstall software" as the a first answer.  This worked perfect for me!
    Monday, August 20, 2012 7:40 PM
  • I experienced the same problem after installing WMP 11.  I followed the steps in the forum without success.  Then I opened WMP 11 and clicked on Tools-->Options-->Devices-->Speakers.  A dialog box opens.  I have a Sigma Tel Audio card installed.  It was not listed in the Sound Playback Audio Device to Use: parameters.  Using the pull-down, I selected DirectSound: Sigma Tel Audio.  WMP11 now works as it always
    Saturday, September 22, 2012 5:10 PM
  • Microsoft fixit says to download Service Pack 2 Framework 2.0.

    When I go to there, there are 3 choices. I don't know which one to use:




    Can you help me with this?

    Wednesday, November 14, 2012 2:29 PM
  • I too had very similar problem.  The answer given by Sellout is right; And one more step is required. Right-click on the Visualization Window -> Volume - uncheck Mute.

    Restart WMP.  This problem crops up only when installing skype or similar software which changes the default audio output device to communication device (instead of speaker). 

    Sunday, December 9, 2012 7:10 AM
  • This is what worked for me: (ON VISTA) note: control panel is NOT in "classic view"

    1.Click Control Panel

    2.Click Hardware and Sound

    3. Click Sound

    4. You should see your default playback device under : "Select a playback device bellow to modify its settings:" (For example mine is Conexant SmartAudio.)

    5.Right-Click on your playback device

    6. Click Properties

    7.On the top, click the Advance Tab

    8. On the bottom click "Restore to Default"

    If the 'Restore to Default" option is grayed out, then try each option under "Select the sample rate and bit depth to be used..." Until one of them works.

    Hope this helped anyone, i found this solution by just changing around the audio settings until it this worked. 

    Sunday, May 26, 2013 8:21 PM
  • removed

    Wanikiya & Dyami--Team Zigzag

    Thursday, May 30, 2013 6:22 AM
  •  you're missing the AC3Filter codec:

    Sunday, August 23, 2015 12:46 PM