none
Where did Network profile settings go RRS feed

  • Question

  • I cannot find the network profile settings in Windows 10 2017 Creator Update. Somehow my network got set to public and I want to change it to private. The forum tells me: Settings > Network & Internet > Wi-fi (my connection method) > click on network name. OK, I then have "connect automatically when in range" ; "metered connection" ; "IP settings" ; "properties"  but no network profile setting. I checked on another Windows 10 2017 Creator Update computer and have the same thing. This use to be simple. Where did Microsoft put the network profile settings?
    Wednesday, December 27, 2017 5:33 PM

Answers

  • Hello Robert,

    OK I found a tech tip that uses a regedit modification:

    Here is the key- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles

    Double click the profiles folder(s) (each one if you have multiple network connections). You will see a profile name. If this is the correct network name then go to the Category DWORD value. Change the value to which network profile you want: 

    Network Location Data Value
    Public 0 (zero)
    Private 1
    Domain 2

    Reboot and you're done.

    This should be a lot easier. If anyone knows how to get the network prfile setting back in either the settings or control panel, please let us know.

    • Marked as answer by SteveRJenkins Thursday, December 28, 2017 7:50 PM
    Wednesday, December 27, 2017 9:13 PM

All replies

  • Microsoft may have sold your network settings to some one else HAHAHAHAHAH

    something has ticked the HACKFLAG in the registry to make them disappear do a search for network settings windows 10 registry 

    open command prompt then type REGEDT32  or  REGEDIT  the in the search box type in the key you found  click search and booom you are off and running if the HACKFLAG is 0 it is off and something else is wrong if its a 1,2,3,4 then it is on 4 meaning auto start 1 meaning it turns on when needed 

     
    Wednesday, December 27, 2017 7:17 PM
  • This use to be simple. Where did Microsoft put the network profile settings?

    They are hiding the Control Panel equivalents, although generally there are some obscure shortcuts in each display that may let you get you back to them.  More often I am ignoring both of them and using PowerShell

    Get-NetAdapter  -IncludeHidden

     

    Windows 10.  Still an Adventure ("Twisty passages, all different.")


    Robert Aldwinckle
    ---

    Wednesday, December 27, 2017 8:22 PM
  • Hello Robert,

    OK I found a tech tip that uses a regedit modification:

    Here is the key- HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles

    Double click the profiles folder(s) (each one if you have multiple network connections). You will see a profile name. If this is the correct network name then go to the Category DWORD value. Change the value to which network profile you want: 

    Network Location Data Value
    Public 0 (zero)
    Private 1
    Domain 2

    Reboot and you're done.

    This should be a lot easier. If anyone knows how to get the network prfile setting back in either the settings or control panel, please let us know.

    • Marked as answer by SteveRJenkins Thursday, December 28, 2017 7:50 PM
    Wednesday, December 27, 2017 9:13 PM
  • After
        Settings > Network & Internet > Wi-fi
    Select
        Manage known networks then your required connection
    Select
        Properties
    On my Windows 1709 the public/private radio buttons are between the connect automatically and metered connection options.


    PS This applies while you are connected to that network - otherwise the buttons do disappear.
    • Edited by misar1946 Wednesday, December 27, 2017 9:38 PM
    Wednesday, December 27, 2017 9:32 PM
  • a regedit modification:

    Looks like I gave you the wrong PowerShell tip.   Use  Get-NetConnectionProfile  and  Set-NetConnectionProfile.  For example one thing that I often have to do with virtual screens, etc. is 

    Set-NetConnectionProfile  -NetworkCategory "Private"

    More permanent solutions may be available using  secpol.msc



    Robert Aldwinckle
    ---

    Wednesday, December 27, 2017 10:21 PM
  • hello misar1946,

    That is how it should be but that is my problem. The radio buttons of network profile settings aren't there.

    • Proposed as answer by ACSTEC Saturday, February 24, 2018 12:38 PM
    • Unproposed as answer by ACSTEC Saturday, February 24, 2018 12:39 PM
    Wednesday, December 27, 2017 11:22 PM
  • I know this passed some time ago but, I just had the same problem and the regedit and PowerShell solutions failed to fix. On further investigation my security software had taken control of this part of windows 10, check your firewall settings in the security software, it fixed my issues.

    Saturday, February 24, 2018 12:42 PM
  • i had similar to Misar1946 above.

    went through to the security settings, windows defender on left hand side, open security system.

    I turned off the firewall and the Public/Private buttons appeared. I was set up as Public.

    I switched to Private, and then went back in and turned the firewall back on.

    Tuesday, April 24, 2018 11:36 PM
  • Are you using a third-party firewall or an antivirus like Avast Internet Security. These antiviruses will use their own network profiles and hides the Windows 10 'Public', and 'Private' options. Here's a brief tutorial about bringing these options back.

    http://www.pcnexus.net/2018/08/bring-back-missing-wifi-network-profile-options-windows-10.html

    Monday, August 13, 2018 6:47 AM
  • Depending on your security software, firewall or privacy setting may be controlling this. 

    If you're running AVAST Internet Security or Premiere, open firewall and set the connection type to private. 

    It defaults to public to provide add'l security until changed by the admin. 

    Wednesday, December 19, 2018 10:05 PM
  • This one doesn't require a reboot:

    Set-NetConnectionProfile -Name "Unidentified network" -NetworkCategory "Private"

    Tuesday, January 8, 2019 5:03 PM
  • For me, the solution was to (temporarily) reduce UAC from level 4 (max) to 3

    Run UserAccountControlSettings.exe to open UAC control panel.

    If the UAC slider is on maximum level, reduce it to the level below.

    Get back to Network settings and show the properties for the current network connection.

    The section "Network Profile" that was missing before should now appear.

    Once you've switched to the profile you want, you can restore the UAC settings to level 4.


    • Edited by _Wizou_ Saturday, April 27, 2019 3:53 PM
    Saturday, April 27, 2019 3:52 PM