none
RDP Black Screen After installing update 1909 RRS feed

  • Question

  • I have tried all the suggestions in an earlier thread.  I haven't used the windows store software because my company has a citrix solution that provides access to the RDP client only.

    When I try to connect using RDP I get an initial black screen.  Then I relaunch RDP and click on edit credentials.   If I give it a bad password, and get the password error, I can then enter the correct credentials and the connection is then made with no black screen.    However, when I close the rdp session, the host screen does not come back on.    It remains black and it seems there is nothing I can do to get it back short of holding the power button for 10 seconds to do a forced shutdown, and turning back on again.

    Any assistance would be greatly appreciated.

    Thursday, November 14, 2019 6:38 PM

All replies

  • "I have tried all the suggestions in an earlier thread."
    great, now we know exactly what you already tried.

    did you set the "
    Use WDDM graphics display driver for Remote Desktop Connections" to Disabled on both machines: server and client?
    Thursday, November 14, 2019 7:43 PM
  • Sorry about not providing more complete info.

     I tried

    -deleting the display driver, causing it to revert back to the Microsoft generic driver
    -booting in safe mode
    -doing a clean boot with all services disabled except Microsoft, Intel and Acer, plus all startup programs except for core essential
    -disabling persistent bitmap caching on client machine in RDP experience tab
    -changing colors to 24 bit
    -changing Local Policy on host machine [Use WDDM graphics display driver for Remote Desktop Connections] to Disabled.

    The same local policy for WDDM graphics is not present on the client machine.


    djroller

    Thursday, November 14, 2019 10:11 PM
  • Hello,

    See if suggestions provided here helps you:

    https://www.kapilarya.com/fix-black-screen-with-remote-desktop-in-windows-10

    Let us know if this helps!

    Note: Included link in this reply refers to blog post by a trusted Microsoft MVP. 


    Microsoft MVP (Windows and Devices for IT)

    Windows Insider MVP

    Windows Help & Support [www.kapilarya.com]

    Friday, November 15, 2019 7:07 AM
  • Hi djroller, 

    Thank you for coming TechNet forum. 

    According to your description, we recommend to ask for help from Remote Desktop Service support, they should be more familiar with your issue and should have more resource to help you.

    Bests, 


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, November 15, 2019 8:25 AM
    Moderator
  • I completed all steps suggested in the link except for installing KB4512941 because that seemed to be specific to the 1903 release and I'm on 1909.

    Nothing has made a difference.   I can connect, and do not get a black screen on remote client, but the instant I connect the host screen turns black (as opposed to the standard wallpaper), and remains black when the remote computer disconnects.  

    If I then try to reconnect to the host, I get a black screen upon connection.  I then disconnect, delete credentials, enter password and connect.   Now the true screen displays on the remote.  But again, if I disconnect, the host screen remains black and unresponsive to any keys.  Cntl+Alt-Del does nothing on host. Nor does windows key.   The monitor light is blue which indicates active, but screen is black.

    Again, the only way I've been able to get the screen back on the host is to hold the power button.

    The one thing I haven't done is roll back to an earlier version of windows.

    Thanks for your suggestions!


    djroller

    Friday, November 15, 2019 4:20 PM
  • Thank you Joy, I have just taken your advice and posted to the Remote Desktop Support Service.

    djroller

    Friday, November 15, 2019 4:40 PM
  • Link to new post? I ran into the same thing, rolling back to 1809 resolved the issue. Looks like I'll have to put off yet another enterprise deployment, was hoping 1909 would be cleaner than 1903.
    Tuesday, November 19, 2019 11:08 PM