locked
Disable LegalNoticeCaption and LegalNoticeText RRS feed

  • Question

  • Hi folks,

    We have a domain GPO pushing the LegalNoticeCaption and LegalNoticeText to all domain computers, we cannot disable this domain GPO.

    We had 20+ computers running Windows XP Professional with autologon enabled, we were able to bypasss this GPO by removing permissions on registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system and deleting the LegalNoticeCaption and LegalNoticeText entries.

    We only allowed one specific IT group with full permissions, the autologon account with ready-only permissions and removed everyone else including the SYSTEM account.

    We recently upgraded these computers to Windows 7 Enterprise SP1 64-bit, we applied the same registry permission settings, but somehow the GPO overrides it all the time.

    Even if we delete the complete "KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system" key, the GPO recreates it with default permissions.

    For the time being, we enabled the "NoMachinePolicy" registry hack, see below, it works, but it is affecting other GPO we need to enforce.

    http://www.microtom.net/os-management/disable-legal-notice-text-forced-by-policy

    Any ideas on an alternative solution to disable the LegalNoticeCaption and LegalNoticeText?

    Thanks for reading.

    ...Alex


    Alex W. Caldas

    Monday, September 29, 2014 4:55 PM

All replies

  • Hi,

    Regarding current information, it seems that the local GPO always over-write the deployed GPO, right?

    I suggest we run following commands to clear local GPO on the client PC, and then try to log off and log in to apply the deployed GPO:

    Reset GPO:


    RD /S /Q "%WinDir%\System32\GroupPolicyUsers"
    RD /S /Q "%WinDir%\System32\GroupPolicy"
    gpupdate /force

    If the issue perisits, please try to delete all group policy registry keys.
    1. Click “Start”, type “regedit.exe” (without quotation marks) into “Start Search” box and press Enter.
    2. Locate the following key:
     
    [HKEY_LOCAL_MACHINE\Software\Policies\Microsoft]
     
    Right click on "Microsoft", click "Export"; please name the file as "RegBackup" (without quotation marks) and then save it to the C:\ drive as a backup.
     
    Note: In case we need to undo the modification, we can double click this RegBackup.reg file to restore the registry key.
    3. Highlight Microsoft and click "Delete".
    4. Please repeat the above steps for the following registry keys.
     
    [HKEY_CURRENT_USER\Software\Policies\Microsoft]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy Objects]
    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies

    Note: if some keys do not exist, please ignore them.

    5. Exit the Registry Editor.

    If the issue still persists, please post back the results of following command:

    gpresult /s ComputerName /user Domain\UserName /h c:\gpreport.html

    Note: Here, ComputerName is the name of the computer that you want to log policy results for and Domain\UserName indicates the user that you want to log policy results for.


    Kate Li
    TechNet Community Support

    Tuesday, September 30, 2014 10:21 AM
  • Hi Kate,

    Thanks for your prompt response.

    I think you have it backwards, the deployed GPO (domain GPO) is enforced to display the legal caption and text. I removed permissions on the registry to avoid this, but it seems the deployed GPO overrides the permissions and still applies the legal caption and text.

    Removing registry permissions worked on Windows XP to bypass this deployed GPO, but on Windows 7, this deployed GPO is always enforced.

    Thoughts?

    ...Alex


    Alex W. Caldas

    Friday, October 3, 2014 4:09 AM