Windows 8 Windows Installer service could not be accessed (Error 1719)


  • Seriously, Microsoft???  This same error has been coming up since Windows XP!  It is January 2013.

    Windows 8 64x.  Attempting to install Adobe 9, getting this same error.

    I run mmc services - the services IS started, IS set to manual, and the option to change the startup is grayed out.  I am an administrator on my machine.

    I tried the following in a cmd.exe window "Run as Administrator".

    > msiexec /unregister
    > msiexec /regserver
    > net stop msiserver
    > net start msiserver

    The service reported it successfully stopped and started.

    Still won't install, and anything else that uses the Microsoft Windows Installer won't install. 

    I find nothing about this happening on a Windows 8 install.  I am dual-booting Windows 7 and Windows 8, and it is happening only on Windows 8.

    Can't you get out an authoritative fix on this?????  Seriously?

    Jacqueline Tregre

    Saturday, January 12, 2013 3:57 PM


All replies

  • Saturday, January 12, 2013 4:00 PM
  • FYI, I just finished resolving this issue on 32-bit Windows 8.  In my case, the underlying cause turned out to be corruption of the underlying .NET 4 framework itself.  (The top-level folder C:\Windows\Microsoft.NET\Framework\v4.030319 was "corrupt and unreadable", according to File Explorer.  "sfc /scannow" pointed me in the right direction:  it generated lots of diagnostic messages about various missing .NET files, though of course it was unable to conjure these missing files out of thin air.)

    I wanted to try resolving this issue by reinstalling .NET 4 alone, but my reinstallation attempt was blocked because ".NET 4 is already part of Windows 8" (and therefore it must be working perfectly???).  So I was forced to do a complete reinstall of Windows 8.  Following this reinstall, the .NET 4 folder was fixed and I was able to run the installation scripts which had failed before.

    The key takeaway here:  the Windows Installer Service depends on .NET 4, so consider the possibility that your installation problems are actually your first encounter with a more general problem with this framework.  Secondary takeaways:  1) "sfc /scannow" is your friend; 2) you cannot repair .NET 4 alone in Windows 8.


    Tuesday, September 10, 2013 4:47 AM
  • Jacqueline & JWFreeman I have have spent 2 weeks searching the web for a solution to this problem on windows 8.1..  i just did the following

    "sfc /scannow"


    > msiexec /unregister
    > msiexec /regserver
    > net stop msiserver
    > net start msiserver

    and it worked just fine

    THANK YOU :)

    Friday, December 20, 2013 12:26 AM
  • best help ever, work instantly after weeks of trying
    Wednesday, August 05, 2015 2:53 PM