none
POWERCFG -REQUESTSOVERRIDE doesn't work?

    Question

  • I have a Win7 x64 that has a mapped drive off a 2008 domain. I always run a program that access data on that mapped drive. When the program is running, the PC doesn't go to sleep.

    ---------------------------------------

    C:\Windows\system32>powercfg -requests

    DISPLAY:
    None.
    SYSTEM:
    [DRIVER] \FileSystem\rdbss
    A file has been opened across the network. File name: [\server\shared\folder\data.ldb] Process ID: [560]
    AWAYMODE:
    None.
    C:\Windows\system32>

    ---------------------------------------

    So, I did this (realizing it is case sensitive) and rebooted the PC:

    C:\Windows\system32>POWERCFG -REQUESTSOVERRIDE DRIVER \FileSystem\rdbss SYSTEM
    C:\Windows\system32>POWERCFG -REQUESTSOVERRIDE
    [SERVICE]
    [PROCESS]
    [DRIVER]
    \FileSystem\rdbss SYSTEM
    C:\Windows\system32>

    ---------------------------------------

    But the PC still doesn't go sleep unless the program is not running.

    Please help.

    Oh, I have modified the registry so that I have "Allow sleep with remote opens = on" in my power plan.


    Derek Chung


    • Edited by Derek94587 Friday, November 30, 2012 7:03 AM
    Friday, November 30, 2012 5:02 AM

Answers

  • The command is forcing the PC in to standby/sleep mode.

    http://support.microsoft.com/kb/555569

    If this command works duing your application is running, that means maybe the "Allow sleep with remote opens = on" works, but maybe the system status doesn't meet the sleep request you configured.

    Please try to receate a local admin account and boot your PC to clean boot for test:

    1.     Log on to the computer by using an account that has administrator rights.
    2.     Click Start, type msconfig.exe in the Start Search box, and then press ENTER to start the System Configuration Utility.
    3.     On the General tab, click Selective Startup, and then click to clear the Load startup items check box. (The Use Original Boot.ini check box is unavailable.)
    4.     On the Services tab, click to select the Hide all Microsoft services check box, and then click Disable all.
    5.     Click OK, Choose Don’t show this message again and then click Restart.

     

    If you want to start Windows normally after you do the test, Click Start, type msconfig.exe in the Start Search box, and then press ENTER to start the System Configuration Utility. On the General tab, click Normal Startup. Click OK, Choose Don’t show this message again and then click Restart.


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Friday, December 14, 2012 4:43 AM

All replies

  • No solution?


    Derek Chung

    Saturday, December 1, 2012 5:29 PM
  • Hi,

    Please check the issue referring to the methods in the following Knowledge Base article:
     
    Windows 7 does not go to sleep
    http://support.microsoft.com/kb/976877
    Hope this helps.
     
    Thanks.


    Spencer

    TechNet Community Support

    Tuesday, December 4, 2012 6:11 AM
    Moderator
  • Not that simple.

    I set the sleep to 1 min and tested the PC with and without the app running. It goes sleep ONLY when app is not running. And when it runs, I have this:

    C:\Windows\system32>powercfg -requests

    DISPLAY:
    None.
    SYSTEM:
    [DRIVER] \FileSystem\rdbss
    A file has been opened across the network. File name: [\server\shared\folder\data.ldb] Process ID: [560]
    AWAYMODE:
    None.
    C:\Windows\system32>

    I read and read and read and according to the Microsoft AvailabilityRequests.docx and http://technet.microsoft.com/en-us/library/cc748940(v=ws.10).aspx, I am supposed to override the request (see first post). I did so and it is still not sleeping.

    Also made sure I have  "Allow sleep with remote opens = on" by modifying the reqistry according to  http://iboyd.net/index.php/2010/05/16/windows-7-power-management-fixing-pc-insomnia/

    and it is still not working.

    Another bug, Microsoft?


    Derek Chung

    Tuesday, December 4, 2012 5:13 PM
  • Hello Microsoft. Can you please help?  

    Derek Chung

    Wednesday, December 5, 2012 5:39 PM
  • Hello Microsoft. Can you please help?  

    Derek Chung

    Thursday, December 6, 2012 7:11 PM
  • Try to use the following command to force your pc go to sleep status again, same problem?

    %windir%\System32\rundll32.exe powrprof.dll,SetSuspendState Standby


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Wednesday, December 12, 2012 9:34 AM
  • That would just hibernate my PC even it has that program running. When I hit the spacebar, the PC powers up and resume from hibernation. It does no help to the problem as my PC still doesn't go sleep with that program running. 

    I tried it on two PCs here.


    Derek Chung

    Wednesday, December 12, 2012 7:24 PM
  • The command is forcing the PC in to standby/sleep mode.

    http://support.microsoft.com/kb/555569

    If this command works duing your application is running, that means maybe the "Allow sleep with remote opens = on" works, but maybe the system status doesn't meet the sleep request you configured.

    Please try to receate a local admin account and boot your PC to clean boot for test:

    1.     Log on to the computer by using an account that has administrator rights.
    2.     Click Start, type msconfig.exe in the Start Search box, and then press ENTER to start the System Configuration Utility.
    3.     On the General tab, click Selective Startup, and then click to clear the Load startup items check box. (The Use Original Boot.ini check box is unavailable.)
    4.     On the Services tab, click to select the Hide all Microsoft services check box, and then click Disable all.
    5.     Click OK, Choose Don’t show this message again and then click Restart.

     

    If you want to start Windows normally after you do the test, Click Start, type msconfig.exe in the Start Search box, and then press ENTER to start the System Configuration Utility. On the General tab, click Normal Startup. Click OK, Choose Don’t show this message again and then click Restart.


    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Friday, December 14, 2012 4:43 AM
  • Do you have any updates?

    “Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.”

    Tuesday, January 15, 2013 7:13 AM
  • No. I did not bother to try. I worry that will bring up more other issues and honestly I gave up on getting this resolved like I have been with many other Microsoft bugs. 

    So, before working out all the bugs, you release your products for $, let us be the beta testers and waste all our time, then when most bugs are addressed, you put a new face on it and call it a new name (Windows 8?), then sell again?

    you sold me a products that is not working as intended. Am I getting a refund for what I paid or I can get a copy of Windows 8 for free? Is Windows 8 more buggy?


    Derek Chung

    Tuesday, January 15, 2013 7:29 PM
  • Hey, I struggled with the same error for some time. Finally, I figured it out. Type:

    POWERCFG -REQUESTSOVERRIDE DRIVER rdbss SYSTEM

    instead of "\FileSystem\rdbss"

    And if that doesn't work already, try to also add the process name of the program that uses the network share via:

    POWERCFG -REQUESTSOVERRIDE PROCESS yourappname.ext SYSTEM

    Hopefully, this will help you. For me it did.


    Monday, May 5, 2014 2:19 PM
  • A little late for the OP, but I had an issue with my PC not sleeping if there was any audio playing, or even with a cable plugged into the line-in jack. 

    Powercfg showed driver "VIA HD Audio" was keeping it awake, so I used:

    Powercfg REQUESTSOVERRIDE DRIVER "VIA HD Audio" SYSTEM

    It did not work initially, but then I tried restarting the system, and then it worked.  At least with drivers, the request override needs a system restart. 


    • Edited by ltngwsimgv Sunday, July 23, 2017 5:47 PM
    Sunday, July 23, 2017 5:46 PM