Windows 8.1 Pro 64bit (with Media Center) Store Update Restores to 8.0 with 0xC1900101-0x40017 Error


  • Long standing technet subscriber with an older and fairly complex system. Win 8.0 Pro 64 Bit installed on a 120GB SSD and most applications, e.g. photoshop, office 13, etc. installed on a large raid 0 array drive, 6GB RAM, Xeon 3520 CPU, NVida GTX 570 Graphics Adapter, a couple large network (NAS) type drives... all drivers, patches, etc. up to date...

    I tried several times to install 8.1 Pro using the technet ISO but it failed and restored 8.0... no BSOD... I checked that out in the forums and everyone says "wait for the full release"... well...  no joy...

    I tried updating from the windows store today and the installation proceeded normally until it tried to boot into 8.1 one and I received a BSOD (SYSTEM_SERVICE_EXCEPTION) twice... then it recovered my 8.0 installation with 0xC1900101-0x40017

    I have Norton 360 installed (updated) but that didn't seem to matter with earlier ISO attempts.  Windows update showed me an optional NVidia update after the windows store failure but that wouldn't install because my drivers are more current...

    So short of a clean install, which I won't do, does anyone have any ideas ??

    Thursday, October 17, 2013 11:38 PM

All replies

  • Disable all Av tools during setup and try again. Also share all dmp files from C:\Windows\Minidump

    "A programmer is just a tool which converts caffeine into code"

    Friday, October 18, 2013 5:38 AM
  • I have the exact same problem.

    I'm running Win 8 Pro 64 Bit on a 120GB SSD, nVidia G555M, i7-2760QM, 16GB RAM and again have applied all available patches, drivers etc. and disable Windows Defender and AV.


    Followed by:

    Sorry, we could not complete the update...

    0xc1900101 - 0x40017

    I found on another forum that the nVidia driver could be the issue but I have totally uninstalled the nVidia drivers.

    Also, each time I change something, the ENTIRE 3GB upgrade file downloads again as if it detects a change in my setup and needs to update?! I can't keep downloading 3GB files!

    I don't have a C:\Windows\Minidump? but I have a windowsupdate.log?

    (I'd attach the photo I Microsoft would let me Verify my Account...)

    Friday, October 18, 2013 9:37 AM
  • There are no files in my C:\WINDOWS\Minidump folder... I do have a MEMORY.DMP file that corresponds with the crash (BSOD) but it's 520 MB and I don't see how to "share" or upload it here... ???  I used to use Windows 7 debugging tools, but now the tools are out there for Windows 8 and Windows 8.1 and I don't know which one to use or if it's even worth the effort ??

    Please keep us posted... it looks like I'm not the only one who's encountering this error...

    Thanks... MTGB


    Friday, October 18, 2013 9:19 PM
  • Looks like this problems is widespread :)


    Saturday, October 19, 2013 10:36 AM
  • Hello

    I have solved the Problem.

    I have posted on my Page
    cu Stone
    Saturday, October 19, 2013 6:26 PM
  • It is a driver issue. I had to uninstall Steelseries (Steelseries does not have a dirver for Windows 8.1 yet) and update my AMD Catalyst driver to the Beta and it worked.

    All you need to do is find drivers that are not Windows 8.1 and uninstall them and update all other drivers to Windows 8.1 drivers. This should work.

    Sunday, October 20, 2013 8:55 PM
  • I'm not so sure... my there are other threads now and it seems widespread.  the only question is if Microsoft is listening or paying attention.! 


    Sunday, October 20, 2013 9:05 PM
  • Is anyone at MS listening... ???  Today Lenovo advised it's customers that many of it's models couldn't be upgraded to 8.1... there's a lot of web chatter but nada from anyone here on technet or MS...

    Anyone ??


    Monday, October 21, 2013 5:27 PM
  • Apparently not. I have tried virtually everything driver wise, but it feels like a trial and error exercise which is just nuts for an OS upgrade!

    Microsoft, any advice/comments/update? Just a "we're looking into it..." would be great.

    Tuesday, October 22, 2013 8:02 AM
  • Anything?
    • Proposed as answer by mjpfx Thursday, October 24, 2013 8:08 AM
    • Unproposed as answer by mjpfx Thursday, October 24, 2013 8:08 AM
    Thursday, October 24, 2013 7:03 AM
  • Ok, so I finally have success...

    Essentially, I've been through the upgrade cycle about 10 times, each time uninstalling various items from Device Manager.

    Now for the unhelpful bit... I can't pinpoint exactly what it was that I uninstalled that triggered the successful upgrade, however it could be one or more of the following:

    Display Adapters:

    • Intel(R) HD Graphics 3000
    • nVidia G555M

    Sound, video and game controllers:

    • High Definition Audio Device
    • Intel(R) Display Audio

    Imaging Devices

    • BisonCam, NB Pro

    I also removed, but can't remember what headings they come under:

    • Huawei MiFi Device

    Uninstalled rather than disabled Avast antivirus and as described in an earlier post uninstalled anything nVidia.

    Hopefully this will help some people, ultimately by removing and uninstalling devices bit by bit (the one's which look least likely to be supported or upgraded), you should be able to upgrade.

    I was desperate not to have to install the OS from scratch, but I wasn't far away from doing this after removing so much.


    • Proposed as answer by mjpfx Thursday, October 24, 2013 8:09 AM
    • Marked as answer by Niki HanModerator Monday, October 28, 2013 4:27 PM
    • Unmarked as answer by Niki HanModerator Wednesday, October 30, 2013 9:20 AM
    Thursday, October 24, 2013 8:09 AM
  • This may have been marked as answered but this issue HAS NOT been resolved !


    Monday, October 28, 2013 9:40 PM
  • you as threadstarter can unmark the answer.

    "A programmer is just a tool which converts caffeine into code"

    Tuesday, October 29, 2013 6:32 AM
  • That post is merely echoing that and confirming that it's almost impossible to work out which it is without trial and error a lot of time and effort.

    So I'm pretty certain my solution still works. You just have to find the correct driver that's causing the issue and uninstall it. 

    Wednesday, October 30, 2013 4:50 PM
  • Well... still nothing on this... it's drivers most likely but the fact that MS released 8.1 and killed devices that were working perfectly in 8.0 is just pitiful... just pitiful... there's dozens of threads on this... one where MS asks to collect your crash data... when you try it, it say's they collected enough data... If I have to wind up doing a clean install it's going to Windows 7... all you have to do is look at PC sales and apple sales to see that MS has lost it's way... what a shame... within in two years, my company (13,000 employees) will have all it's critical applications in the cloud (hosted or self managed) and we'll be using dumb terminals and tablets... wake up folks !


    Sunday, November 10, 2013 8:00 PM