this file does not have a program associated with it for performing this action


  • Hi,

    My laptop has stopped working.  When I start it up it allows me to login but then it shows my desktop without any icons/shortcuts.  When I press the windows button, nothing happens.  The only thing I can do is open the task manager.  I have read on many forums that it might have been a virus that removes the registry association on files.  When I open task manager, I can open “new task” and then I can see my files when I browse.  When I click on anything I get “this file does not have a program associated with it for performing this action” .  I can not open a cmd prompt or anything else.  Does anyone have idea’s on what I can try next?


    • Edited by Paul Montreal Thursday, November 26, 2009 4:21 PM useless info
    Thursday, November 26, 2009 3:29 PM

All replies

  • Download this file and unzip it then double click it and let it run, it will restore most all of the default file associations for XP
    Thursday, November 26, 2009 4:05 PM
  • One of the problems I am having is that I can not open, unzip anything on this laptop.  I plugged in my thumb drive and nothing happens.  when I press win+e nothing!  The keyboard/mouse work just fine.

    Thursday, November 26, 2009 4:24 PM
  • Download this one then and save it to your desktop, double click on that one and choose "merge". that should restore the zip function and allow you to use the other
    Thursday, November 26, 2009 5:53 PM
  • Sorry, I am not doing a good job of describing my situation.  On my laptop, I can only open task manager by pressing ctl+alt+del at the same time.  Nothing else will open.  Not IE, My Computer, Control Panel, not even the start shows on my desktop.  when I try to create a shortcut off a file on my thumb drive nothing happens.  Nothing shows even when I right click on my desktop
    • Edited by Paul Montreal Thursday, November 26, 2009 6:28 PM spelling
    Thursday, November 26, 2009 6:27 PM
  • It sounds like the explorer shell isnt starting then, try this, in task mananger click "File>new task(run...)" and type in "explorer.exe" without the qoutes and see what happens

    Thursday, November 26, 2009 9:33 PM
  • I get the same error message.  “This file does not have a program associated with it for performing this action.  Create an association in the Folder Options control panel.”
    Friday, November 27, 2009 3:41 PM
  • Have you tried safe mode, or safe mode with command prompt? if your able to at least get a command window try to do a system restore, to do that in a command window type " %systemroot%\system32\restore\rstrui.exe" without the qoutes and just follow the directions from there, try getting safe mode with command prompt and try that.
    • Proposed as answer by securityguy14 Saturday, December 05, 2009 1:48 AM
    Friday, November 27, 2009 4:26 PM