Windows 8 'wscript.exe' not working for *.vbs files


  • Hey all,

    I've had Windows 8 running fine on my work PC for several months, but today when I booted it up, it would not run my *.vbs logon scripts.

    There is no script engine for file extension ".vbs".

    I first tried the obvious, and have since done a fair amount of Google searches. Here is a list of all of the actions that I have carried out.

    • Restarted my computer (you never know).
    • Check that C:\Windows\System32\wscript.exe exists, which it did.
    • Set the program default by right clicking, selecting 'Open with -> Choose default program...' and choosing Microsoft Windows Based Script Host.
    • Set the association through 'Control Panel -> Programs -> Default Programs -> Set Associations'. As expected, this was already correct due to the action above.
    • Register vbscript.dll by clicking 'Start -> Run -> type "regsvr32.exe vbscript.dll"'.

    After all of these actions, I am still receiving the same error message. Can someone please help with a suggestion as to what I should do next?


    Wednesday, July 24, 2013 9:20 AM


All replies