Quick Edit Greyed out in Custom List RRS feed

  • Question

  • I have set up a SP 2013 environment using the trial software.  I have created a new custom list using the Custom List App.  I've created all the columns and I just want to use Quick Edit to be able to cut and paste columns from an excel sheet (I'd prefer to import the excel sheet but that icon is missing!).  Unfortunately, this is greyed out.

    Just to test further, I created another custom list using the Custom List in DataSheet View App - I can use Quick Edit in this list.

    Is there a way to enable Quick Edit in my original list..?  I don't want to recreate all the columns again - there are quite a few.


    Wednesday, April 3, 2013 12:56 AM


  • I'm using SharePoint 2013 Foundation but this worked for me.

    I had created a custom list and made it a template. I then found the issue your describing. After faffing with permissions and trying things I did to create the list reversed and taken out 1 by 1 I found its all about the checkboxes.

    You have to enable check boxes.

    List settings > (Under Views heading) All Items > Tabular View > Allow individual item checkboxes (Tick this box).

    > CLICK OK <

    Now you should have the ability to edit using quick edit. Hope this helps you out?

    • Proposed as answer by _jam Wednesday, April 24, 2013 10:23 AM
    • Marked as answer by Margriet Bruggeman Thursday, April 10, 2014 7:04 PM
    Wednesday, April 24, 2013 9:10 AM

All replies

  • Same problem here. Just upgraded our SharePoint 365 site online.
    One of our lists does not show the options above the list that allows you to select views and add or edit items.

    Moreover the Quick edit button for this list is greyed out.

    Please help as this is very annoying.


    Here's a screenshot of a list that works fine:

    Here's a screenshot from a list that show the problem behaviour:

    • Edited by DirkL Wednesday, April 3, 2013 10:58 AM
    • Marked as answer by Jack-Gao Thursday, April 11, 2013 12:55 PM
    • Unmarked as answer by Trevor SewardMVP Tuesday, October 1, 2013 5:06 PM
    Wednesday, April 3, 2013 10:58 AM
  • I see this has been marked as an Answer but the above does not provide a reason or solution.  Jack-Gao, can you please provide some further information.  Thanks.

    Thursday, April 11, 2013 11:30 PM
  • Has anyone found a solution for this?

    Lazer Systems Admin

    Monday, April 22, 2013 4:36 PM
  • I'm using SharePoint 2013 Foundation but this worked for me.

    I had created a custom list and made it a template. I then found the issue your describing. After faffing with permissions and trying things I did to create the list reversed and taken out 1 by 1 I found its all about the checkboxes.

    You have to enable check boxes.

    List settings > (Under Views heading) All Items > Tabular View > Allow individual item checkboxes (Tick this box).

    > CLICK OK <

    Now you should have the ability to edit using quick edit. Hope this helps you out?

    • Proposed as answer by _jam Wednesday, April 24, 2013 10:23 AM
    • Marked as answer by Margriet Bruggeman Thursday, April 10, 2014 7:04 PM
    Wednesday, April 24, 2013 9:10 AM
  • Hi iam,

    I am trying to find in my list where you are referring to "Tabular View" but I can't see anything under the List tab or under Views.

    What I did do though, was create a new View.  I just created it using "Standard View".  Now, I am able to change to Quick Edit, and I can now also see the search field for the list and the Edit link.  iam - maybe this is what you are referring to.

    Not sure why, but for some reason, the default "All Items" view that is created when you create the list does not allow the Quick Edit or the Find an Item search field.

    Hopefully this helps someone else.

    Monday, April 29, 2013 12:22 AM
  • Hi Kelsnz,

    If you go to your list in question.

    Click on lists from the ribbon and select list settings.

    Scroll down towards the bottom and you will see Views heading. Click on All Items.

    If you scroll down the list I have a subheading called Tabular view.





    > Tabular view

    If you expand this tree out you will hopefully see the option allowing you to tick the Allow individual item checkboxes. Tick the box and your away.

    I'm using SP2013 Foundation and SP Online and both have the option I describe.

    I hope this helps clarify the position?



    Thursday, May 2, 2013 10:59 AM
  • I found that turning off any grouping in the view fixes the problem as well.

    Cheers, Jim ___________________________________________________ If this was helpful please mark as an answer.

    • Proposed as answer by turkoise.aa Friday, August 2, 2013 6:10 PM
    Friday, May 10, 2013 8:16 PM
  • Jim, you're the one! Thanks!
    Friday, August 2, 2013 6:11 PM
  • Checking the Allow individual item checkboxes did not fix my issue.  The only thing that worked was removing the Group By selection.  Frustrating for something to work fine in 2010 only to stop working in 2013.  :(

    Jennifer Knight (MCITP, MCPD)

    Monday, August 19, 2013 6:30 PM
  • Another option is that custom XSL in the view seems to be preventing Quick Edit and the view menus from appearing. I'm still looking into this but if anyone is still stuck, it's another place to look.
    Tuesday, October 1, 2013 3:15 PM
  • My list wasn't in group when I had this issue, but this worked for me:

    Modify View-> Style->under View Style select Default(mine was on shaded before)

    Hope this helps

    • Proposed as answer by Richard Duffy Monday, March 3, 2014 1:37 PM
    Monday, February 10, 2014 2:22 PM
  • I have similar problem on list that was upgraded from SP2010 template. I found working solution by applying 'clienttemplates.js' value to jslink property in my view. This property is new to SP2013 so it was not existing in my old list template. SP2010 is ignoring this property so you can include it Schema.xml to have it working for both versions.

    You can also edit view webpart and update jslink property manually.

    All credits belong to this post http://www.rickvanrousselt.com/updating/

    Sunday, March 9, 2014 4:35 PM
  • That setting was currently correct ... still greyed out

    Wednesday, March 26, 2014 7:22 PM
  • I didn't have any grouping on the list and it still greyed out... that may have an impact on it but it isn't the silver bullet that fixes this with those who have upgraded.

    Wednesday, March 26, 2014 7:24 PM
  • I also had this issue. I changed to Shaded and the Quick edit disappears. Changed it back to default and it now appears. How silly! I am also not liking how the Quick edit will only list as many as you set your view up to list. Show me all of them!
    Wednesday, March 26, 2014 7:40 PM
  • This has to do with 'groups'.  The list you are having problems with, is probably grouped. If it's not grouped the "edit" and "quick edit" should show up. If it's grouped it doesn't, because the 'group' would kill the bulk edit.

    Worked for me anyways.

    Good luck!

    Tuesday, April 8, 2014 8:52 PM
  • I have the same problem, with a custom list imported from a SharePoint 2010 site.

    This is what is SUPPOSED to work. Yes, you have to enable checkboxes for Quick Edit to work. However, the solution by kelsnz worked for me: Just create a new view using "Standard View". The imported view will not allow Quick Edit, and none of these suggestions will correct an IMPORTED view.

    Christopher W. Douglas

    Thursday, May 29, 2014 10:22 PM
  • I ran into this problem as well and none of the listed items helped me. Even creating a new view did not work. What I discovered was that my XML View definition was missing "<JSLink>clienttemplates.js</JSLink>". I added this to an existing view using SharePoint designer and now Quick Edit works as expected.
    Thursday, August 14, 2014 3:53 PM
  • This can occur when columns are defined as Multiple Line Text fields with Rich or enhanced Rich Text. Change those to plain text!
    Tuesday, September 23, 2014 10:22 PM
  • I'm late to the game on this, but I just encountered the same issue.  SP Foundation 2013 demo in a VM.  Simple, four-column list.  Nothing fancy.  I have the box checked to 'Allow individual item checkboxes.  

    The important variable for me is that I set the view to display Newsletter style.  That's what's causing the Quick Edit box to gray out (apparently, any choice other than Default causes this). 

    I found a resolution at https://support.microsoft.com/kb/2876824?wa=wsignin1.0 .  Eventhough that page talks about SP Online, the proposed fix works on SPF also.  Click the List tab on the ribbon for your list.  Then, click Modify View.  Scroll down and click on the plus sign next to Style to expand that section.  From the 'View Style' choices, select Default.

    Wednesday, October 22, 2014 3:24 PM
  • just wanted to say thanks for this answer. i was going crazy trying to figure this out and this was exactly what i needed to do. thanks!
    Thursday, March 19, 2015 6:07 PM
  • Not working for me. It's already ticked.
    Thursday, May 21, 2015 7:45 AM
  • Even this option is not working for me :(
    Thursday, May 21, 2015 7:48 AM
  • I can't seem to get Quick Edit to work with a discussion board in SharePoint online.  I tried a couple of the solutions mentioned here, but none are working.  Does anyone know if it's possible with a discussion board?
    Thursday, June 11, 2015 5:44 PM
  • I had this same problem as well and tried all of the above fixes.  None of them worked.  I was able to resolve by changing my style setting back to default...somehow the style setting eliminated the quick edit option.

    Hope this helps!

    Tuesday, October 27, 2015 6:54 PM
  • So i did all that was suggested and nothing worked. But....
    What i did find that worked was make a new View, Change nothing.
    use standard list view to start as base
    Limit the items to show to 4-5 
    take the defaults
    No grouping 
    No Filtering

    Now the Quick edit worked. Once it was working I went in and added one Rule to filter but no more.
    I found that quick edit has issues when filters, and when adding more than one it goes to crap. once the view has gone to crap i can't undo it.

    Even in this view i find adding more filters or sorting under quick edit, it gets all messed up and drop downs stop working. But this could i have almost 5000 files in my list. (yea i know almost at the end of my rope)

    I hope this helps one person :)

    Also found that sometimes just remove the formating, Example if i remove Graylines to default it starts working, adding formatting back it stops.

    • Edited by ZacheryS Friday, January 29, 2016 5:55 PM
    Friday, November 6, 2015 11:18 PM
  • The problem is the style option in the view settings. You must keep this on default or the quick edit turns grey.

    Lewin Wanzer MCSE, MCDBA, MCTS (SQL 2005, 2010 Config, 2007 Config)

    Friday, February 26, 2016 8:28 PM
  • Lewin - Do you mean the Per-location view settings?  I'm trying to get this to work on a Discussion board in SP Online, and it's not working.  Per-location view settings is not supported with the discussion board.

    Are you aware of any other way to use quick edit with the discussion board?


    Friday, February 26, 2016 9:57 PM
  • I eventually found the solution. 

    Originally i wanted to use the "import spreadsheet" to create a new custom list, which i did, however i noticed when i did this a lot of the cells were greyed out in "edit list" mode and i could only edit the cells by going into each item and editing it.

    I found that if you change the column type from rich text to simple text then you can edit the list. I'm guessing this is because rich text formatting doesnt work when trying to edit the entire list. This is a bit of a pain, the only way round it is to create all your columns first in basic text, then copy and paste each column one by one.

    Thursday, March 17, 2016 10:30 AM
  • Perfect! Thanks Lukasz!
    Friday, April 1, 2016 4:34 PM
  • For me what worked was turning the style from Shaded back to Default.

    Based on responses above, maybe anything in the view properties will interfere with the button showing.


    Tuesday, May 10, 2016 12:16 PM
  • Must all document libraries be on the same setting for 'Quick Edit' to function or can you have one document library in 'shaded' style and all others in default style?
    Thursday, May 19, 2016 7:39 PM
  • In "Discussions List", the option of "Quick Edit" is not available on the "Advanced Settings" of the list.

    All workarounds above do not seem to work (Checking the checkbox for "Allow individual item checkboxes" in tabular view settings of the view, remove grouping, reverting to "default" style).

    The solution seems to be setting it with PowerShell:

    $list = $web.Lists.TryGetList("Discussions List")
    $list.DisableGridEditing = $false

    • Proposed as answer by abz Wednesday, August 24, 2016 12:07 PM
    Tuesday, June 21, 2016 8:37 AM
  • That fixed it!
    Tuesday, August 23, 2016 3:31 PM
  • Helped indeed. Thanks.
    Wednesday, February 15, 2017 8:46 AM
  • I had a situation where Quick Edit was greyed out.  It turned out to be because the Site Owner set all View Settings to Style - Shaded.  In order for Quick Edit to work, it needs to be set to Style - Default.

    Hope this helps someone.

    Friday, February 17, 2017 4:12 PM
  • @Rich Hubbard

    Good trick, but unfortunately makes the shading go away. 

    I added the "clienttemplates.js' in the webpart tag properties under Miscellaneous > JSLink 

    the quick edit appeared, but the rows shading went away.

    Do you know if there is a way to make the 'edit' and 'shaded' style show both at the same time??

    • Edited by LG-active Thursday, February 23, 2017 8:09 PM
    Thursday, February 23, 2017 8:05 PM
  • This fixed the issue for me. You can apply clienttemplates.js in web part properties.
    Tuesday, June 20, 2017 6:50 PM
  • This one finally worked; all other solutions did not work.
    Monday, July 24, 2017 1:20 PM
  • The cause is also often that you in your view have enabled "Group By". As long as you use it, Quick edit will never be available for the list.

    Sorry for the incorrect language, it is never consistent even if you use English OS (trying to mitigate error msg etc)

    Wednesday, September 6, 2017 6:28 AM
  • There is a setting under List Settings > Advanced Settings called Quick Edit. Select Yes to enable this feature.
    • Proposed as answer by Susan.Barnes Monday, November 13, 2017 4:14 PM
    Monday, November 13, 2017 4:13 PM
  • Tabular View is a setting specific to each view. There is a section of the View configuration which will allow you to set this to yes.

    Tabular View <<
    Group By

    Monday, November 13, 2017 4:16 PM
  • For me, the Quick Edit button also reappeared when I changed back from Shaded style to Default style! The checkboxes had no effect. I can't believe this has been going on since 2013!
    Saturday, November 25, 2017 12:25 AM
  • This answer helped me, once I changed my View Style to Default, the Quick Edit came back....
    Monday, December 11, 2017 9:57 AM
  • Yes -- for some dumb reason Shaded removes the ability to Quick Edit.  What moron decided that Quick Edit was effected by Shaded?????  So fail.
    Monday, December 18, 2017 3:28 PM
  • Thank you, this worked!
    Thursday, December 28, 2017 6:54 PM
  • This is an old thread, but I wanted to summarize the answer succinctly as users are still asking about the availability of Quick Edit. Quick Edit is enabled only if:

    (1) The view has no group.

    (2) The view uses the Default style.

    (3) Allow Individual Checkboxes must be selected. 

    Kim Ryan, SharePoint Consultant kryan@[no spam]spscholar.com

    Friday, February 16, 2018 2:30 PM
  • My list stopped working while I was editing it, and it greyed out the 2 columns to where I was adding data and I didnt change any settings I was just adding data, which is very frustrating.  Sharepoint is the worst tool I have ever used!  

    I tried all the recommendations i read here and none of them worked. I finally edited the column and changed it to take only plain text and for some reason this did the trick for me, I changed it back and its working but added some tags and characters to my texts, Ill have to sort that out now. . 

    Tuesday, April 17, 2018 3:34 PM
  • This is what worked for me - seems weird, but thanks for the idea!
    Thursday, August 9, 2018 6:28 PM
  • Can't believe I managed to find this answer. I wish it could give it 5 million points.
    Tuesday, September 25, 2018 9:46 AM
  • Sir, you saved me even almost 5 years after you posted this!


    Wednesday, October 10, 2018 9:14 AM
  • This is already enabled and still the quick edit is grayed out.
    Thursday, May 16, 2019 5:13 AM