C000009A error on Win 7 SP1 install


  • have tried this on 5 machines today - got the C000009A error on 2 of them - the only fix seems to  be the DISM revert command shown in this thread.  All 5 had ALL language packs installed and where fully up-to-date with all Windows Update fixes prior to the install.  The 2 that failed where a brand new i5-based HP laptop that was a clean win64 ultimate install, and a core i7 gigabyte x58 mobo loaded up with 5T drives and 12G ram also a win64 ultimate machine - been running fine for a while.  2 other machines, both i7-920 x58 gigabyte units running win64 ultimate w/all language packes installed, took 12 hours to get 1/2 way thru the progress bar - "cancelled" at 12hrs - hopefully they will succeed at cancelling...;)  5th machine is a ibm/lenov TP 410 core-i5 laptop - cancelled after 10 hours at 1/2 complete. That's 0 for 5;)  Guess I'll wait for a bit before attempting this again.
    Thursday, February 24, 2011 10:55 AM

All replies

  • I've got the same issue on my Core 17 950 HP desktop with  9GB ram running Win 7 Ultimate with all language packs installed it stopped after more than an hour with the C000009A error.  I tried a second time, same error.  I then removed all the language packs.  Same error.  I always keep my systems up to date with all updates current.  I'm running MS Security Essential and Avira, which I have been running for several years now without any issues.  I think I'm just going to sit on the sidelines for a while until MS does a SP1 patch.  How quaint.  Now we need an update for an update.
    • Proposed as answer by Andre.Ziegler Thursday, February 24, 2011 3:33 PM
    Thursday, February 24, 2011 1:49 PM
  • remove all MUIs, install the Sp1 and install the new MUIs again.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter
    • Proposed as answer by Paolo Manenti Sunday, February 27, 2011 1:59 PM
    Thursday, February 24, 2011 3:34 PM
  • After running the DISM command referenced in the other threads (/cleanup-images amd /revertpendingactions)) I rebooted the HP Pavilion laptop and during boot it seemed to indicate that updates were applied (blue background, % complete, don't power off message) - and when it booed and logged in it reported that SP1 was installed.  Control Panel reports Windows 7 Ultimate, Service Pack 1.  A trip to Windows Update reports only security essentials definition update available - so I installed that and all seems ok on machine 1.

    Second machine was a core i7-920 gigabyte machine - had run the DISM command on as well - after reboot, login and window pops with SP1 installed - windows update and 1 update for security essentials - installed that - things seem ok on that machine too.

    Third machine - I cancelled this one after 12 hours and 5 hours later it is still trying to "cancel" the install of SP1 - I'll be rebooting soon on this one (I'm running on this machine now).

    Fourth machine - also "cancelled" at 12 hours and 1/2 progress bar - 5 hours later it's still trying to cancel the install - I think we'll reboot this one first and see what's up with it.

    Fifth machine was the IBM/Lenovo 410 laptop - it was cancelled after 10 hours and seemed to be operating as before...

    So 2/5 now but both of the "updated" machines required a trip through DISM...  adn could be in an unknown state post-install.

    Thursday, February 24, 2011 4:18 PM
  • I HAD the same problems. Tried 5 times and crashed every time. I read on several sites things to try. Here is what I did and it worked. Remove all langauges but English (which is the default and can't be removed anyway). I downloaded the 903 MB- Windows 7 SP1 x64 update file. I disconnected my internet, disable my firewall/antivirus. Ran the SP1 update file and after about a 45 min wait, it installed fine. I now have SP1 x64 version on my computer. I then enabled my firewall/antivirus and reconnected to the internet.

    All is working fine. Just wanted to give you something else to try. 

    Friday, February 25, 2011 6:11 PM
  • <form id="aspnetForm" action="365bb5ac-065f-422e-901b-843496ff1245?prof=required" method="post">
    <input id="__EVENTTARGET" name="__EVENTTARGET" type="hidden" /> <input id="__EVENTARGUMENT" name="__EVENTARGUMENT" type="hidden" /> <input id="__VIEWSTATE" name="__VIEWSTATE" type="hidden" value="/wEPDwUJMjYwNDUyNzA3ZGTaxDaRhYpO7Yi5Vi9WsCqyNOnrLA==" />

    Hello everyone,


    Today I have learned how easy you can lose hair.


    Here is the error message that I have.

    Error C000009A applying update operation 138698 of 354096 (\Registry...)


    I have tried booting into safe mode, last known good configuration and trying to check, reading more about this pending.xml.

    Now since the operation number for all of us is not the same, we can conclude that MlaHaak said may not apply to all of us.

    The good news is that he showed us the path but the bad news is that I fear many of us will have to reinstall windows from scratch.


    I am currently using SLAX to browse my hard drive but my XML life is like 125.3MB.

    Not sure what exactly I am looking at and I am trying to see if there is a way you can skip or something to have this bloody SP1 completed.


    I want to say thank you to all of you trying to help us and if I find something with my skills of "so, so", I will give you updates asap.

    Good luck to all of us


    - soulpaladin
    Friday, February 25, 2011 8:58 PM
  • Hopefully I found a Blog that has the answer. I also have this prob. When the update fails, shutdown and restart. Do a startup repair/restore or try and boot in save mode, takes forever! launch cmd and type in lpksetup and uninstall all language packs except english. Reboot and try to install SP1. Trying this now;)
    • Proposed as answer by Joseph Hargrave Saturday, February 26, 2011 5:28 PM
    Friday, February 25, 2011 10:10 PM
  • Hi guys! Back on my Dell Laptop. Took all night to fix but got up in Safe Mode after two Repair/Restores and uninstalled the language packs. Then installed SP1. Then supposedly you can reinstall the language packs, but I think not! LOL
    Saturday, February 26, 2011 5:33 PM
  • remove all MUIs, install the Sp1 and install the new MUIs again.

    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter

    Thank you so much  Andre..I solved my problem removing first IE9 RC..then W Silverlight..without to solve the problem..then removing all languages pack...I successfully installed Windows SP1 on my W7 ultimate Italian...and finally I installed new languages pack..IE 9 RC and W Silverlight.

    Great! Thank you so much Andre


    Sunday, February 27, 2011 2:03 PM
  • HI Joseph,


    How to uninstall language packs from command line in recovery mode

    I tryed your lpksetup cmd but it's unknown ???

    Where is this thread giving solution to roll back the SP1 when it has crashed in middle.


    Poor Microsoft, working with it since MS-DOS 1.1 and going worse....

    Thanks for some formal help.



    Sunday, February 27, 2011 7:29 PM
  • Hi CS:

       While you're waiting for Joseph to respond back, I can tell you that lpksetup.exe should reside in your C:\Windows\System32 Folder.  It takes a while to bring up it's window after invoking it...  But I would perform a System Restore from WinRE first, then uninstall the Languages, then attempt the SP1 Install, once again.  If System Restore fails, then the next thing(s) to try are the DISM/POQE Routes...

    Here are all the known Threads concerning the, "C000009A Fatal Error Applying" Issue thusfar (including this one):

    Error C000009A applying update operation 119595 of 334565 (\Registry\...) when loading SP1

    Fatal Error C000009A applying update operation [number] of [number]

    C000009A error on Win 7 SP1 install

    Windows 7 64-bit SP1 failure to install

    Error C000009A applying update operation 118743 of 336226 (\Registry\...)

    History - Windows 7 Service Pack 1 Error C000009

    Sunday, February 27, 2011 9:32 PM
  • Could not boot to Windows

    Tried Startup Repair, it stated that it fixed the issue... rebooting resulting in the same issue, C0000009A

    Tried system restore, no restore points found...

    Tried to clean up the image using the following at the command prompt:

    DISM /image:C:\ /cleanup-image /revertpendingactions /ScratchDir:C:\temp

    which results in - Error: 2 An error occurred reverting the pending actions from the image.

    The log file has errors:

    • CSI 00000006 (F) STAUS_OBJECT_NAME_NOT_FOUND #27320# from windows:Rtl::SystemImplementation...
    • CSI 00000002 (F) d:\w7rtm\base\wcp\sil\merged\ntu\ntsystem.cpp(2057) Error STAUS_OBJECT_NAME_NOT_FOUND..
    • a couple like the above

    DISM didn't work for me so I was stuck until I saw a post in the comments section by a mlahack on the MS Win 7 Service Pack page.

    Using the Windows 7 Install Disk or Recovery CD, goto the command prompt and launch notepad

    in the log file c:\windows\winsxs\poqexec.log you find a reference to the error:
    1cbd36fd5eb05f3: 74c, c000009a, 1abe7, 0, SetKeyValue ;\Registry\Machine\Software\Microsoft\Windows\CurrentVersion\SideBySide\Winners\amd64_microsoft-windows-ultimate.resources_31bf3856ad364e35_pt-pt_0b9032dad0ee6ed8\6.1, 6.1.7600.16385, , AQ===

    open c:\windows\winsxs\pending.xml file (99 MB) and find "atibility.resources_31bf3856ad364e35" Comment the xml node this string of text is found in.  i.e. change < <!-- and /> to --> then save the file (recommend you do a backup of the file first)

    Restart the system it will go through and try to configure updates then state that there was an error and is now reverting the changes.  On the second boot (took a long time) gives the same message and eventually lets you log in.

    Monday, February 28, 2011 5:39 AM
  • Well done, romelq ... You perservered!

    ... You may want to go into RegEdit and manually fix up the one or 2 registry entries that failed for you (if they are still relevant, etc.) ... I found that when I manually deleted the registry key POQE was hanging up on (a delete value operation for a language pack entry, and I had no problem deleting it), it STILL errored the next time at the same point!

    ... I then tried the DISM command and had no problem getting into SP1 ... At the time, I wasn't aware of the XML Edit Post (which I really wanted to figure out how to do, eventually), so I did not attempt it.

    Monday, February 28, 2011 6:08 AM
  • I was having the same problem , tried to install sp1 from updates , and downloading it , was at my wits end , then I thought I would have to do a clean install , so I put my insall disk in the drive , then I thought I'll do an in place upgrade , which leaves all programs intact , took 2 hrs , but after that , once i redownloaded all the previous updates , sp1 installed ok , thinking CC Ceaner or similar program might have deleted something . did this fix on 2 laptops , both worked ok , just had to reinstall wireless printer settings , just a thougt if you have sp1 package already downloaded on computer maybe you wont have to download all the previous updates ? just install sp1 first .

    • Proposed as answer by flukeyboy Tuesday, March 01, 2011 1:29 PM
    Monday, February 28, 2011 1:27 PM
  • Hi guys! Back on my Dell Laptop. Took all night to fix but got up in Safe Mode after two Repair/Restores and uninstalled the language packs. Then installed SP1. Then supposedly you can reinstall the language packs, but I think not! LOL

    SP1 has new MUIs as well. I guess you can't install the RTM on a SP1 system.


    Monday, February 28, 2011 7:39 PM
  • Hello All,

    Content has been created to help with this issue, here's a link to the website: 


    • Proposed as answer by BobbyMi Monday, March 07, 2011 5:30 PM
    Monday, March 07, 2011 5:30 PM
  • Is there a solution that does not involve uninstalling Language Packs?  Manually touching each machine in our corporate environment is tedious at best, and unacceptable given the tools available that should be able to roll this out through automation.

    Is there any word from Mircosoft on an updated installer, that will work with Language Packs installed?

    Geoffrey Schaller
    Monday, March 07, 2011 9:46 PM
  • why have you deployed so many MUIs? You can use PSExec and run DISM commands to remove the MUIs on the target PCs.

    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo:
    Monday, March 07, 2011 11:18 PM
  • We have some users that are multi-lingual, and may need to use the other languages - as a result, we deployed them as a part of the standard image.  Removing them just to install SP1 is a lot of extra effort, when an updated SP1 would be much easier on Microsoft's customers.

    Geoffrey Schaller
    Tuesday, March 08, 2011 3:08 PM
  • if you have 1 or 2 installed MUIs thats ok. Only if you install all available MUIs you get the issues.

    "A programmer is just a tool which converts caffeine into code"

    Want to install RSAT on Windows 7 Sp1? Check my HowTo:
    Tuesday, March 08, 2011 8:24 PM
  • thank you, everyone who replied here.  i will add my input to the topic as well


    all is not lost if you are forced to run the DISM command and have a half installed SP1.  after you boot in to windows you can uninstall the language packs, uninstall SP1, reinstall SP1, then install the language packs again.  i put in probably about 10 hours worth of educated guesses and i finally got everything up to date and working right.


    hope this helps someone else

    Friday, March 18, 2011 4:11 PM
  • Well thats cool. But what is DISM and how would someone use it in correlation with this issue?
    Monday, April 18, 2011 9:20 AM
  • Glad there's a work around but it shouldn't matter why someone installed all the MUIs.  The feature should work ...PERIOD!    Afterall, multi-language support was one of the very few features even justifying the Ultimate SKU.   Microsoft absolutely should fix this problem or not offer the feature.   Not saying anyone here is saying Microsoft shouldn't but if there really is any doubt there shouldn't be.

    I personally support globally developed products for global use so I need to switch into every language you can think of so yes there are real reasons to have all the packs installed.  But like I said, it doesn't matter.  Microsoft sold the Ultimate version with this being one of the key features and it should work; shouldn't be hard to understand.   Plus the way the upgrade fails is completely unacceptable as well; a total hang of the system that leaves your system so it won't boot! 

    Sunday, May 08, 2011 5:14 AM
  • Hello,

    The fix is available for download.

    2534366 "0xC0000009A" error message when you try to install Windows 7 SP1 or Windows Server 2008 R2 SP1;en-US;2534366

    Thanks, Darrell Gorter [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights. VAMT - Volume Activation Management Tool - Download link
    Sunday, May 08, 2011 11:18 PM
  • I tried the hotfix, but am running into a similar error now - instead of the 0xC0000009A error during bootup, I get the following error in Windows, during installation:

    ERROR_OUTOFMEMEORY (0x8007000e)

    Researching online, it looks like there's a thread for this already, and it's still related to language packs:

    Geoffrey Schaller
    Monday, May 09, 2011 2:49 PM