Nothing happens when i open desktop gadgets


  • either from control panel or right click on desktop > gadgets.

    there's some disk access, then nada.  any idea?  thanks.
    Wednesday, January 21, 2009 2:24 AM


All replies

  • I had the same problem. Found elsewhere on here that it's related to setting the UAC setting to off. I reset the UAC to the default, rebooted and my gadgets came back.
    Wednesday, January 21, 2009 2:33 AM
  • In order to display desktop gadgets, you must enable the User Account Control, and enable desktop items.

    Hope this helps.
    Wednesday, January 21, 2009 2:42 AM
  • Hey all,

    I was in the same quandry and found the following,

    I was able to add gadgets from the microsoft web site and they would install and run but
    was unable to bring up the program file folder to start already installed gadgets.
    Once I had a gadget up I could access the folder through "right click/add gadgets".
    Right clicking desktop and click gadgets, nothing would happen as was true
    with control pannel route as well!

    Spent many hours going through the tec-web and trying every suggestion to no avail.

    Steps taken to access desktop gadgets

    Checked and reset (where nessessary) the following

    UAC -on (recomended level)
    show desktop icons - on
    show desktop gadgets - on
    windows gadgets platform - on
    %PROGRAMFILES% - no responce
    control panel - no responce
    event log - no reports
    many re-boots
    full disc check - volume is clean
    system file checker - no integrity violations
    running regedit (as adminn)
    HKEY_local_machine\software\microsoft\windows\current version\sidebar
    (\settings does not exist on my unit therefore could not adjust "allow elevated process")
    full virus scan - none found
    protected mode - tried both on and off

    The last thing I have tried is:

    With the desktop gadget file open, bring up task manager, click processes,
    right click "sidebar.exe", click UAC Virtualization.
    A pop up question comes up "do you want to change virtualization for sidebar.exe......"
    click "change virtualization"

    Now most if not all built-in short cuts to the file work!
    So far all is well we shall see if it lasts,
    Hope this helps others.

    Thus far all still works after re-boots etc.
    All shortcuts still work.


    Saturday, September 12, 2009 2:48 PM