8E5E03FA fix.

    General discussion


    Ok after months of trying I have finally got this error sorted and here’s how.


    1. Restart your computer into safe mode.


    2. Login using the Administrators account


    3. In Start, Accessories, right click on Command Prompt, and click on Run as Administrator


    4. In DOS type:-  net stop cryptsvc


    5. Press enter and wait for the computer to say its stop this service


    6. Close DOS and remain in Windows Safe Mode.


    7. Go into My computer and navigate to your Windows directory


    8. Find the folder windows\software distribution and remove the contents, but not the folder it’s self


    9. Then navigate to windows\system32\catroot2 folder and remove the content of that folder


    10. Right click on the catroot2 folder and rename it to catroot3


    11. Restart windows and login as normal.


    12. Once logged into windows run Windows Update from the Start menu. Download and install updates as normal.


    13. Norton’s Internet 2008 may ask you for permission for Live updates to go online, depends on your setting with Norton.


    I hope this works for every one who is still having problems with this error. I did this exact process last night after 6 months with no updates and now my computer is all updated and working fine.


    Good luck to you all, and thank you to every one that helped me.

    Sunday, November 04, 2007 3:48 PM

All replies

  • Bingo !!!

    Thanks Pal, It went like a piece of cake. No problem.

    Just followed instructions word by word and I am on track.


    Monday, June 09, 2008 7:49 AM

    Many thanks. I am glad, that with your help have solved such problem.

    Thursday, February 19, 2009 4:42 PM
  • Wow thank you VERY much everyone who helped to figure this out so good :)

    Been ages with no updates and now all working fine!

    Great job =)

    Thanks again
    Saturday, March 28, 2009 9:38 PM
  • thanks alot for the post, also had problems for 6 months.. finally!!

    Tuesday, March 20, 2012 3:16 PM
  • Even though this is found in a Vista forum, I had the same problem with Windows 7/64.

    I followed the steps and shazam! it worked like a million bucks.  Thanks ever so much.

    Sunday, May 27, 2012 1:40 PM
  • thank,s very much all done but had to run microsoft mr fixit just to open gateway,s ect

    as we say in norfolk england you are a good old boy

    pity microsoft cant sort out this error

    • Edited by bobby54921 Thursday, June 28, 2012 10:34 AM
    Thursday, June 28, 2012 10:30 AM

    Have this problem for over 2 months. I have tried various solutions, downloaded 'fixes' from Microsoft, followed instructions from a number of sites but unfortunately nothing worked. 

    Today,  I have seen your suggestion, and followed it to the letter. IT WORKED PERFECTLY !!! Thank you very much.

    I think your suggestion to do the changes in Safe Mode was the main difference to every other solution I have tried. Well done !!!

    Microsoft should reward you for this, since they could not solve THEIR problem themselves.

    • Edited by Sonyuser2012 Thursday, September 06, 2012 7:12 PM
    Thursday, September 06, 2012 7:11 PM
  • Thank you so much, this has sorted out my computer update 8E5E03FA

    All that frustration in not being able to install this update (for over a month) was sorted out within minutes once I printed a copy of your instructions before going into Safe Mode

    Can only say how easy it was to do and send my thanks, Freddie

    Monday, September 10, 2012 12:45 AM
  • Worked beautifully for me as well - Thank you for being much more help than even Microsoft's paid support staff.

    • Edited by John Hard Tuesday, October 09, 2012 11:39 AM
    Tuesday, October 09, 2012 11:38 AM
  • Thank you for your prompt reply. The problem seems to appeared when I installed the update from Vista to Windows 7.

    I'm using Norton 360 for my virus protection and fire wall.

    I have trouble going into My Computer  and navigating to widows directory. Also finding the folder windows\ software distribution and removing

    content. Also with windows\system32\catroot2 folder. This folder is readily found in dos.

    Once again  Thank You for your help.


    Thursday, October 18, 2012 5:07 PM
  • Does this work with windows vista 64 bit?  That's what I have and am getting the same problem!
    Monday, January 07, 2013 6:07 PM
  • Thanks so much for sharing this.  Microsoft was no help on this at all.  Their "Fix-it" tool designed specifically for this problem was useless  and their "tech support" wanted me to re-install Windows 7.  They must not even bother to read the forums.  Their "IT professionals" version of this fix involved the writing of numerous batch files and other heady nonsense.  This was simple, to the point, and worked like a charm.
    Saturday, January 18, 2014 3:54 AM
  • Thank-you. Just used your fix on a Windows 8.1 64 bit machine. Worked perfectly. A few minor comments: the folder in Step 8 was windows\softwaredistribution (not software distribution). I don't know if this has changed since Windows Vista or was a typo. I also noted that windows update history was deleted after this fix was used. I don't know how you figured out this fix, but its perfect.

    Thursday, February 13, 2014 5:17 PM
  • thank you sir...

    my bug is fixed... :-)

    Sunday, March 16, 2014 7:13 AM
  • This works for Windows Server 2008 R2   Thank you.

    Friday, June 13, 2014 12:06 PM
  • I also solved my problem using this article. I have Windows 8.1 64 bit with Unicode language and it works great.

    Actually after doing those steps I got an error saying I was unable to do windows updates at all, 

    but I had the update file that I had downloaded manually before, so I ran it again and it works great.

    Then, after restart I was able to use the windows update wizard.

    Actually, after reading some other sources on the net, I am not sure it is necessary to delete the content of folder softwaredistribution, However it worked for me.

    Thank you very much!!!



    Sunday, December 14, 2014 8:52 PM
  • Same error code 8E5E03FA and refusal to update KB3004361 since Feb 11, 2015.

    System:  Win 8.1 Pro on X64 Dell XPS17


    1. stop the service CryptSvc (via Task Manager or 'net stop CryptSvc' in admin Dos box)

    2. rename the folder 'catroot2' to 'catroot3' (or other) in 'C:\Windows\System32\'

    3. reboot

    4. retry the update

    This has worked fine in my case.

    I hope it does for you too.


    Sunday, February 15, 2015 9:54 AM
  • It solved a year old problem of mine.
    It worked just fine. Thank you!
    Friday, July 03, 2015 5:07 AM
  • Thanks. It was working for me on 2012 R2 Server. No Need to boot in safe mode.
    Monday, May 02, 2016 6:22 PM
  • I did this and my pc is just checking for updates, I left it for bout an hour and it never found anything it just kept checking, what can I do?

    Tuesday, April 25, 2017 9:08 PM
  • I know you posted this a while ago but thanks for the fix.  Much appreciated :)))

    Wednesday, September 06, 2017 12:39 PM