none
Monitor goes to sleep

    Question


  • Hello there,


    I have an application that becomes very hard disk intensive when the computer goes to sleep. I tried to set the power options of my computer so that the monitor will always stay on and never go to sleep but whatever I try doesn't do it and the monitor keeps going to sleep after 15-20 minutes of inactivity.

    I am running Windows 7 Ultimate x64 on an Asus M2N32-SLi Deluxe motherboard. No known problems such not enough disk space or not enough memory or with any other hardware and all latest updates and drivers are installed.

    The Power Options settings in Control Panel are set as follows:

    Preferred plan: Balanced
    Turn off the display:Never
    Put the computer to sleep: Never

    Advanced settings:
    Balanced, Require a password on wakeup, Setting: Yes
    Hard disk, Turn off hard disk after, Setting: 30 Minutes
    Desktop background setting, Slide show, Setting: Paused
    Wireless Adapter Settings, Power Saving Mode, Setting: Medium Power Saving
    Sleep, Sleep after, Setting: Never
    Sleep, Allo hybrid sleep, Setting: Off
    Sleep, Hibernet after, Setting: Never
    Sleep, Allow wake timers, Setting: Disable
    USB settings, USB selective suspend setting, Setting: Enable
    Power button and lid, Power button action, Setting: Do nothing
    PCI Express, Link State Power Management, Setting: Off
    Processor power management, Minimum processor state, setting: 5%
    Processor power management, System cooling policy, setting: Active
    Processor power management, Maximum processor state, Setting: 100%
    Display, Turn off display after, Setting: Never
    Multimedia settings, When sharing media, Setting: Prevent idling to sleep
    Multimedia settings, When playing video, Setting: Optimize video quality

    What else can I do to keep my monitor on at all times, even after a long period of inactivity, let's say over night?


    Thank you,
    Arie

    Monday, October 19, 2009 12:54 PM

Answers

  • Hi arie01,

     

    Please first see if the issue occurs after disabling the screen saver (by selecting the screen saver to "None"). If the issue persists, please disable sleep in BIOS. To check the BIOS settings, please refer to the user manual or contacting the motherboard manufacturer.

     

    In addition, please set the following Group Policy and see if the issue can be resolved.

     

    1. Please go to Start, type Group Policy in the Search box and then press Enter.

    2. Expand the following item:

     

    Computer Configuration -> Administrative Templates -> System -> Power Management -> Video and Display Settings

     

    3. Double click "Turn Off the Display (Plugged In)".

    4. Change the setting to "Disabled".

    5. Click OK.

    6. Repeat step 4 to 5 to disable "Turn Off the Display (On Battery)".

     

    Also, you can test in Clean Boot and see if the issue occurs. If the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

    • Marked as answer by Linda Yan Saturday, October 24, 2009 2:22 AM
    Tuesday, October 20, 2009 5:44 AM

All replies

  • Hi arie01,

     

    Please first see if the issue occurs after disabling the screen saver (by selecting the screen saver to "None"). If the issue persists, please disable sleep in BIOS. To check the BIOS settings, please refer to the user manual or contacting the motherboard manufacturer.

     

    In addition, please set the following Group Policy and see if the issue can be resolved.

     

    1. Please go to Start, type Group Policy in the Search box and then press Enter.

    2. Expand the following item:

     

    Computer Configuration -> Administrative Templates -> System -> Power Management -> Video and Display Settings

     

    3. Double click "Turn Off the Display (Plugged In)".

    4. Change the setting to "Disabled".

    5. Click OK.

    6. Repeat step 4 to 5 to disable "Turn Off the Display (On Battery)".

     

    Also, you can test in Clean Boot and see if the issue occurs. If the issue disappears in the Clean Boot environment, we can use a 50/50 approach to quickly narrow down which entry is causing the issue.

     

    Hope this helps.

     

    Regards,

    Linda

     

     

    • Marked as answer by Linda Yan Saturday, October 24, 2009 2:22 AM
    Tuesday, October 20, 2009 5:44 AM
  • Thank you Linda Yan.

    Ok, I modified the GPO for the (Plugged In) only because it's a desktop and it will never be on bettery.
    I let the computer become idle and after about 30 minutes, I saw the hard drive LED solid red. As soon as I moved the mouse, the LED stoped showing red.
    So, it didn't help.

    Thank you,
    Arie
    Tuesday, October 20, 2009 2:15 PM
  • Hi Arie,

     

    Did you try disabling sleep from BIOS? What about the result in Clean Boot mode?

     

    In addition, is the issue that the hard disk goes to sleep or just the monitor goes to sleep? Also, could you please let me know when the issue first occurred? Did it occur after installing certain software or changing some hardware?

     

    Sincerely,

    Linda

     

    Wednesday, October 21, 2009 2:53 AM
  • Hi,

    I experience the exact same prob where my monitor keeps going to sleep even when I set it to never under high performance setting.

    The monitor persistantly goes to sleep no matter how I changed the setting. Even when I am watching a movie with my computer, it just goes blank every 15 - 20 mins. The comp requires constant keyboard or mouse input else it goes to sleep.

    Had just come across this thread and tried the group policy method. Will monitor again and report back.

    I am running Window 7 PRO 64-bit on a ASUS P5Q Turbo motherboard + Intel E8400 @ 3Ghz CPU and a Viewsonic monitor VX2423W and a Nvidia GeForce 9600GT.

    Pls advice if there are new findings.

    Monday, April 05, 2010 3:17 PM
  • I too am experiencing this sleep problem,win7x64.

    I just want the screen saver to kick in and keep going.

    The SS kicks in but after so long the monitor goes to sleep.

    I dual boot and this does not happen in XPx64.

    SS kicks in and stay working until I move mouse or press a key.

    I seem to have fixed my issue. I updated my ATK0110 ACPI UTILITY to version 1043.6.0.0. Don't remember what version it was before? I do know that it was from 2006 and the newer one is from 2009.
    • Proposed as answer by Naigidni Thursday, May 06, 2010 7:35 PM
    Thursday, May 06, 2010 4:03 PM
  • I'm seeing the same issues and then some. My monitor will go to sleep and not wake back up. I have tried the Windows 7 High Performance power settings but I had the same results. I then created a custom power plan which set all options pertaining to hibernation/sleep to "Never". I tried the suggestions presented by Linda, but to no avail. When the monitor goes to sleep there is a message that is displayed: "DPMS PC - In power save mode. Press any key on keyboard or move mouse...". I've tried hitting several keys on my keyboard and moving mouse, but I get no response. It's as if my video card has ceased sending a signal to my monitor.

    I have discovered a workaround which is very much unacceptable as it requires the use of a secondary computer with remote access to the "problem computer". I remote into the sleeping computer and change the resolution one tick lower and hit "Ok". I then wait for the resolution change to take and change it back to the original resolution....Voila the screen comes on instantly. I then select "Keep changes" when prompted and the monitor stays on...until it gets "tired" again at which point I have to repeat the entire process.

    I reformatted and installed a clean version of Windows 7, but I was having this same issue with WinXP. I have a Dimension E510, a Radeon X600 video card, and a Dell W3706MC LCD HDTV. The video card connects to the monitor via a DVI-I (I think..maybe DVI-D) to HDMI cable.

    Windows 7 was very good about installing all drivers, but since this has been happening, I have downloaded Radeon drivers from their site with no luck. I truly believe this is OS related. Although the fact that I've experienced this when I had WinXP seems to rule out the computer and point to the monitor.

    I truly hope someone steps up to the plate to resolve this issue if it is OS related; or at least provide some ideas as there are obviously a few people that are experiencing this. I'm sure there are many more that have been experiencing similar issues, but have not posted.

    Thanks in advance to anyone that can shed some light on this!!

     

     

    Saturday, May 08, 2010 3:38 AM
  • Did you try my fix?

    Check which version of ATK0110 ACPI UTILITY your running?

    Saturday, May 08, 2010 1:35 PM
  • I am also having an issue with the monitor going to sleep. I have changed my power management settings so that everything stays on, but it did not solve my problem. After reading this forum, I have tried Linda Yan's fix. I will see if it works and report back. I had the same problem with Windows 7 RC2, and am now running Windows 7 x86 Ultimate.

     

    System Specifications:

    Dell Dimension E-521

    AMD Athlon X2 64 4200 2.2GHz

    3GB DDR3

    256MB Radeon X1300 PCI Xpress

    400GB Hitachi SATA2 HD

    Friday, July 16, 2010 4:25 AM
  • After trying Linda Yan's solution, my monitor is finally staying on. Thank you for your help.

     

     

    mckenzme:

    If you're having the same problem on XP and 7 (two completely different operating systems), then it's not likely an OS issue.  It sounds like your computer itself is going to sleep and not just the monitor (In Windows 7, the default sleep settings power down the hard drive and monitor after 20 minutes). If this is the case, you will actually need to press the power button on the PC to resume from sleep mode. If the computer is not resuming from sleep mode properly, it could be the sleep settings in BIOS. If they are set to S1, try changing them to S3.

    Hope that helps. If not, I'll definitely try and see what I can dig up on this issue.

    Friday, July 16, 2010 7:25 AM
  • I am a system builder and this happens on every single machine I build. First thing I generally do is install drivers then I set power management so that its set to never turn off the monitor never hibernate and never sleep, as I need to be able to see the screens due to generally building 5+ machines at a time. However I can guarantee that 20 mins later I'll turn to the PC and the monitor is off, it will continue like this for a few hours then mysteriously stop! I just want it to do as its told from the very beginning!

    I have tried all the suggestions made and none have helped, this happens no matter the hardware used so cannot be anything other than a O/S issue.

     
    Monday, April 02, 2012 3:40 PM
  • It is not the OS your running, it is the View Sonic monitors. I've had mine on two different OS and it goes to sleep like you said within 15 mins. of inactivity. I hate it and have tried with no success to fix the problem. You can bet I'll never purchase another View Sonic product. The older monitor I had didn't have this issue, it was a Dell. I have a Dell monitor on another comp and it never goes off.
    Saturday, April 07, 2012 1:51 PM
  • It's probably not the monitor brand also.  I have a Samsung SyncMaster914v and it does the same thing.  I can only think that because my power settings say to put the computer to sleep after an hour that sleep turns off the screen saver function causing the monitor to go turn off no matter what it says in the power plan setting.
    Sunday, April 29, 2012 6:35 PM
  • I am running windows 7x64, I have a view sonic monitor and have been without problems. Until a few days ago and all of a sudden this changed... now I am experiencing the same problem... after a short time of inactivity my monitor goes to sleep and I cannot wake it up.
    • Edited by Lin N Saturday, May 05, 2012 9:55 PM
    Saturday, May 05, 2012 9:53 PM
  • Set the computer not to go to sleep at all from the power settings.
    Sunday, May 06, 2012 2:14 PM
  • I have the same problem. Windows 7 Ultimate installed. I've  also found that certain operations make the monitor go to sleep. E.g. If, on the Screen Resolution window, I select "Detect", my monitor switches off.

    To my best knowledge, my drivers are up to date. Admittedly, my machine is a little old (MSI k8N Neo4 Platinum) but I don't see why it should be a particular problem.

    I've looked at thread after thread on this issue and they all die from apathy. Input from Microsoft seems to be conspicuous by its absence.

    Is anybody there as MS?

    Sunday, July 22, 2012 9:51 PM
  • Controll Panel > System and Security > Power Option > Choose When to turn off Display

    For Windows7 Home desktop

    Monday, July 23, 2012 4:20 AM
  • Set the computer not to go to sleep at all from the power settings.

    I have the same issue and I have set the computer to never sleep, never hybernate and never turn off the monitor, however, it still does so.   Not sure what the problem is.
    Wednesday, October 03, 2012 2:26 PM
  • It's probably not the monitor brand also.  I have a Samsung SyncMaster914v and it does the same thing.  I can only think that because my power settings say to put the computer to sleep after an hour that sleep turns off the screen saver function causing the monitor to go turn off no matter what it says in the power plan setting.

    I also have the Samsung SyncMaster and have the same problem.    My computer settings are to never sleep, never hybernate and never turn off the monitor, however, it still does this.   It is driving me crazy.   
    Wednesday, October 03, 2012 2:27 PM
  • I THINK I figured it out.

    I'm having the same issues.  About 20 minutes then the monitors sleep even though everything is turned off.  Even the bios on the motherboard.  EVERYTHING.  But one time when waking the monitors, I saw a small icon at the bottom.  After researching the processes running, I discovered it's related to "SixEngine.exe" which I believe is connected to my motherboard "ASUS P6X58D Premium".  But I'm pretty sure that the software runs with other motherboard series.  Anyhoot, clicking on the "SixEngine.exe" brought up the powersaving features.  Mine was set to AUTO.  Of the four different modes, 2 of them (Medium, and Max Power Saving), it was set to turn them off after 20 minutes.  I changed those to NEVER as well.

    The result.. monitors stay on!

    The weird question still remains though... why all of a sudden did this start doing this?  It never happened before.  Not sure if a windows update would change it, or the Catalyst update would.   I never had the problem then suddenly I did.  Thankfully it's all in the past now.

    • Proposed as answer by DCegledi Sunday, December 30, 2012 3:07 PM
    Sunday, December 30, 2012 3:06 PM
  • BINGO!  You nailed it right on the head.............If you noticed, most everyone here has an Asus board, and the 6 engine is the Asus software to control the fan speed/temp, and apparantly sleep mode!  Thank you soooo much for bringing this up, as now I am going to go and fix my issue!  Thanks a ton!
    Saturday, January 05, 2013 4:15 AM
  • Tonight I was watching movie on my TV being broadcasted via HDMI from my Laptop. 

    It was annoying to force my laptop from dying every now and then. (Somehow I was not able to change power management settings to never sleep, don’t know why!!!) 
    So here is the powershell script solution : 
    only move mouse ( http://sharepoint.asia/can-i-stop-my-screen-from-locking-due-to-inactivity/#onlymovemouse )
    Source(s):
    http://sharepoint.asia/can-i-stop-my-screen-from-locking-due-to-inactivity/#onlymovemouse
    Friday, February 21, 2014 4:12 PM