I get “Your PC needs to be repaired” and “Error code: 0xc0000225” in Windows 8.


  • I just bought a new laptop (HP g6) which had 500 TB of HardDisk. In the package: NO INSTALLATION CD/DVD/ NO product key..NOTHING...No serial code...

    I tried to partition the HardDisk intro 4 parts : 100 GB, 100 GB, 100G and 100 GB for the local C:
    The problem was when the diskmanagement.msc didn't want to shrink my local C less than 200 GB left in drive C
    It was very weird: how come Windows 8 DOESN"T allow me to shrink C: less than 200 GB? It was absurd to use 200 GB  ONLY for the Operating if something goes loose 200 GB of data...

    Soo I tried using the partition tool: EaseUSE partition..which actually allowed me to shrink my local C: down to 100 GB....and asked for restart afterwards....

    After the restart I got this message:
    "error code 0xc0000225 \windows\system32\winload.efi"

    And after several other rebooting attempts I now get:

     “Your PC needs to be repaired” and “Error code: 0xc0000225” in Windows 8.

    Soo...Windows 8 didn't want me to have a local C drive less than 200 GB :(

    How can I fix this??

    I don't have a recovery CD....nor DVD... nor any key (the PC came already installed)

    HELP PLS>>>>!!!

    Sunday, May 05, 2013 8:47 AM


All replies

  • Your post is almost an exact copy of the one here ( by MihaitaSimona, except the model name and size allocations have been changed.

    In any case, the Original Poster of that question said he resolved it by following directions and comments here:  Have you tried those solutions?

    David Coulter | | @DCtheGeek

    Sunday, May 05, 2013 2:14 PM
  • I just bought a new laptop (HP g6) which had 500 TB of HardDisk.

    That's a very impressive laptop. It must be big as a car! Which company makes the hard drive?
    Sunday, May 05, 2013 3:38 PM
  • Thank You All!

    Thanks Geek! You're right! I did look at that. In fact I just copied and pasted his post then changed the laptop name and error msg! I also looked at ""

    I was up till 5:00am last night trying to get it to work...I did make recovery CDs when I got the laptop (last week), but those didn't help, when inserted and trying to boot from the cd/dvd drive, I was still getting the same error. I also got stuck on step 9 of the above link, coz I've mounted the corrupt (hp g6) drive onto a dell laptop I had, which had win 7, so when I was trying to execute "F:\Windows\System32\bcdedit /store F:\Boot\BCD /enum" (step 9), i got a message about the bcdedit.exe on F:\ was different (64-bit) and could not run on 32-bit system

    So I've downloaded "Visual BCD Editor" (with GUI interface) , installed it on my win7 dell laptop, then used diskpart to get to the hidden (win 8) partition , then edited the right BCD (it wasn't straight fwd though) so it took me hrs trying to figure it all out, BUT FINALLY IT WORKED!!! My HP was able to boot, then I noticed that "EaseUSE partition" was finishing up what it was suppose to do, and I got my desktop back. I then went to disk manger found an 100G unallocated space (which came about by splitting my 200GB C:\), assigned a drive letter and Voila! Woooooooooooooooooooooooooof Woooooooooooooooooof wooooooooooooooooooooof

    Thanks to all of you and especially the posters of the original threads...

    • Edited by pmolson Sunday, May 05, 2013 6:18 PM
    Sunday, May 05, 2013 6:16 PM
  • Hello, please I need your help, almost the same thing happened to me. My windows 8 laptop keeps crashing and windows 8 won't start after using AOMEI tools to give my c: drive more space. I just get a
    blue screen saying "your PC ran into a problem and needs to restart, we're just
    collecting some error information, and then we'll restart for you". This keeps
    going and going in a loop. It's been going for 1 day. Please what can I do?. I
    just had it for 4 months. It's an ASUS N56V. I don't have the windows 8 CD and
    don't know what to do now. I don't want to lose all of my data, since I had lots
    of important data, to which I need access as soon as possible (homework mostly, I am a med student and desperately need all of my data). When I press F9 to enter the recovery screen, I get the following message. "Your PC needs to be repaired, a required device isn't connected or can't be accessed. Error Code: 0x0000225. You'll need to use the recovery tools on your installation media. Press Enter to try again, Press F8 for startup settings, Press Esc for UEFI Firmware Settings. By the way, Automatic Recovery screen won't work. Please, please, please help me resolve this issue. I thank you in advance. I cannot boot in safe mode or anything. I can only access the BIOs. And I'm not a very technical person, so please be patient with me. Thank you.
    Monday, October 07, 2013 12:41 PM
  • I have the exact same problem as you!!! I used Aomei trying to move more space from D to C and this happend after my Asus laptop restarted!!! I NEED HELP! please!!
    • Edited by Ray Avitia Tuesday, December 03, 2013 8:27 AM
    Tuesday, December 03, 2013 8:25 AM