none
The Windows 7 Search Does Not Return Any Results when started with Windows+F

    Question

  • Hi,

     

    I have a very strange problem. First, the problem:

    Environment: Windows 7 Enterprise

    Actions:

    1. Press Windows+F

    2. Search Window Opens.

    3. Type few characters or string in search box.

    4. Nothing happens

    5. Press Enter

    6. Still Nothing Happens.

    7. The search window keep displaying "To begin..."

    8. I give up and close the window.

    Repeatability: Multiple. Consistent ("No Results") every time.

     

    Bigger Problem:

    (a) Start Menu search box does find programs. It claims to find files (Search Program and files ) but never find any files.

    (b). Explorer search box (like Search Local Disk (E:)) does find files. It seems to find them by name but not by contents.

    (c). The search in (b) does not find the outlook messages or onenote notes.

     

    More Details:

    i. All drives are indexed. File types are also associated with right indexing, such as content indexing for docx etc.

    ii. Outlook and onenote also appear in list of indexed locations

    iii. I have rebuilt the index, twice just to ensure that it is not corrupt or a problem. Indexing Service is running.

     

    I'm now plain and simple clueless what might be wrong. The same search works (as you type) for others but not for me. I have similar setup. What is wrong?

     

    Need help to (a) identify the root cause, (b) eliminate the root cause. I need this to work.

     

    Thanks.

    Rupak

     

    Sunday, April 11, 2010 2:46 AM

All replies

  • Just want to add here that I did the troubleshooter and microsoft automated troubleshooter engine et al. It said "it didn't detect any issues..."
    Sunday, April 11, 2010 2:52 AM
  • I am having the same exact Search and indexing problems with Win 7 Pro. It just happened within the last 2 days. The Search feature was fine up until then and then all of a sudden, it wouldn't find all files during my search in my supposed indexed directories.

    Everytime I try to rebuild the index now, it only goes so far and says index complete but doesn't get even close to indexing the full amount in the categories that are checked before it says indexing complete, and it's always a different number, sometimes 0, sometimes 3, sometimes a couple of thousand and then says index complete, but there are over 100,000 files in the categories that are checked to be indexed.

    I tried some Hotfix that was mentioned by MS, but that didn't work. I had to dnld and install Google Desktop to use as a Search application, but that doesn't have the same capability and tools that I want that is on the Win 7 Search application when Windows 7 Search was working correctly.

    Thanks...Charles

    Saturday, April 24, 2010 12:34 PM
  • Hi. I had the exact same issue before (no results whatsoever apart from programs' names) and the solution was a bit hidden:

    1. Open the Taskbar and Start Menu Properties, go to the Start Menu tab and click "Customize..."
    2. Scroll down to the option set "Search other files and libraries" and select "Search without public folders".
    This worked for me, as I had previously changed the Start Menu settings.

    • Proposed as answer by kaIinc0 Saturday, April 24, 2010 1:32 PM
    Saturday, April 24, 2010 1:31 PM
  • Thanks for trying, I checked but mine was already set on  "Search without public folders". It's still indexing haphazardly. Sometimes it says Indexing complete and then start indexing on its own a few more and then says indexing complete again.
    Saturday, April 24, 2010 2:43 PM
  • The other funny thing I notice is that even though Windows 7 is still not indexing my User folder when I try to rebuild the index, and therefore shows no results in a Search for a file name that I know is in there, if I open a file manually, then close it, then search for it, that 1 file (or however many I manually open and then search for) shows as being found in the search, but none others.

    But I don't feel like opening every file on my User folder every time just so they will show up in the Search function. I just don't understand why the Search function and index would all of a sudden start acting corrupted.

     

    Sunday, April 25, 2010 5:55 PM
  • I'm actually surprised by this behaviour. How come start menu find and windows+f are linked?

    I have re-indexed umpteen times. No help. Windows update et al are giving so solution. Troubleshooting is not helping and No MVP is replying to this post either. I thought they would be able to fix such trivial issues as such. Wouldn't they not know all the if condition that are applied before windows oblidge to finally start finding files. Forget correct file, it behaves as if "enter" key does not exist. Repeatedly pressing enter has no effect.

    Sunday, May 02, 2010 11:15 PM
  • I am having exactly the same trouble!  Has anyone found a solution to this yet.  Where are the Microsoft experts on this?
    Thursday, May 06, 2010 6:55 PM
  • Hi All,

    This is a strange problem. I could only find one reference to the no results issue. It is related to the permissions being lost. Here's a few of ideas to try:

    1. Temporarily disable the security\anti-virus software and try a search-any results? (rule out that blocking access for some reason)

    2. Boot to the installation DVD and select the repair option-confirm that nothing is corrupted

    3. Finally, the permissions fix. I would check the entire C:\ folder or drive permissions

    When I search in a specific folder, nothing is found.

    For files to be indexed, the folder containing the files must have SYSTEM permissions. These may have been removed.

    To troubleshoot this, do the following:

    1. Right-click the folder which is not returning results.

    2. Select the Properties option.

    3. Click the Security tab.

    4. If SYSTEM appears in the Group or user names box, system permissions is not the problem.

    5. If SYSTEM does not appear in the Group or user names box, click the Edit… button to open the Permissions dialog.

    6. In the Permissions dialog, click the Add… button.

    7. In the Select Users, Computers, Service Accounts, or Groups dialog, enter system in the Enter the object names to select box and click the Check Names button.

    8. Select SYSTEM from the list of Matching names and click OK.

    • Proposed as answer by Sanberdino Thursday, July 28, 2011 1:09 AM
    Saturday, May 08, 2010 11:31 AM
  • Ok,

    Another item to check.

    click Start

    select Control Panel

    change view to large or small icons to see all items

    select indexing options

    review what is there or missing-the modify button will help confirm locations and add\remove.

    I would not venture to the advanced button unless you want to manually rebuild the index.

     

    Saturday, May 08, 2010 11:51 AM
  • ChasFL

    I have exactly the same issue.  I am using Win 7 Home.  The funny thing is that if I open a Word or Excel file and then close it, the file immediately appears in the index (the index count goes up one and the file then appears in the search) but if I open a pdf and close it, nothing happens - it does NOT then appear in the index.  My guess is that opening an Office file triggers a change in the file that is saved to disk on close, which then reveals the file to the indexing system.  Merely opening and closing a pdf does not trigger the same effect .. I guess.  I think it could be something to do with permissions and am trying some things out ..

    Wednesday, May 12, 2010 11:07 PM
  • danimal,

    I found someone mention this same problem in another forum and I had continued the conversation there. But what I finally found that ultimately fixed the problem was to complete uninstall McAfee Anti-Virus, which then allowed me to re-indexed everything correctly, and then I re-installed McAfee afterward. The Search function worked correctly again, being able to find anything that was typed in the "Search" box.

    Temporarily disabling my Anti-Virus as someone else suggested here did not help the re-indexing on my machine. It wasn't until I completely unistalled McAfee that the re-indexing acted correctly again. Reinstalling McAfee afterward automatically puts your McAfee account where you left off before you uninstalled it, meaning you still have the same amount of time left on your account.

    I saw something mentioned somewhere that McAfee had added something incorrectly in their latest update that treated a Win7 system file as corrupt, therefore corrupting the Win 7 Search function. They said it is fixed now, but I did have to go through that same 'unistall McAfee, re-index, re-install McAfee' process once more about 2 weeks later when I saw my Search function trip up again.

    Hope that helps....Charles

    • Proposed as answer by ChasFL Thursday, May 13, 2010 7:34 PM
    Thursday, May 13, 2010 7:33 PM
  • Charles,

    Thank you!  Uninstalling McAfee completely, rebuilding the index and reinstalling has fixed the problem!  Thank you again for your help.  Could you provide a link to the other conversation you mention?  I would like to follow that. 

    Also, you say that McAfee say they have fixed the issue - is this covered in their knowledge base somewhere?  If so, could you let me have a link to that too as I couldn't find any reference to it (I guess it is not something McAfee wants to shout about!). 

    Once again, thank you so much.  I have wasted so much time trying to fix this issue and am very relieved that it is now solved. 

    Best regards

    Dan

    Friday, May 14, 2010 7:12 PM
  • Hey Dan,

    No problem, glad I could help. I had tried everyone's suggestion on these forums and none of them worked until I tried the uninstalling McAfee scenario. I was trying to fix this problem for almost a week before I finally solved it. Actually, I think I had spoken to a Microsoft rep on the phone who had told me about the McAfee update situation. Here's the other forum I was speaking of where I had posted my solution: http://social.technet.microsoft.com/Forums/en-US/w7itproui/thread/ecbecc00-f3e7-429f-87cd-8900fc313add/

    Anyway, if you rely on the search function like I do, I can imagine how frustrating it was for you without it. Google Desktop doesn't cut it, and the other forum mentions another alternative called  Locate32  which I tried, but that didn't cut it either. I actually miss the old Vista Search function that had a nice GUI type tool bar with a nice GUI icon if you are looking for a graphic, rather than the Win7 Search that has you have to add in a code like 'type:picture'.

    Like I said, I had to repeat the uninstall Macafee, reindex scenario about 2 weeks later after I initially did it the first time when my Search function tripped up again so when you dnld McAfee, save the install ap somewhere on your HD in case you have to repeat the scenario.

    You got it.....Charles

     

     

    Friday, May 14, 2010 9:39 PM
  • Charles,

    An update.  After reinstalling Mcafee, the index that was created for my documents was deleted, leaving only the index for my Outlook emails, rendering search useless again (as you predicted).  Not wanting to go through the palava of uninstalling Mcafee again etc, I have just now been on to McAfee chat support.  After one hour of avoiding being fobbed off by a tier 1 support techy who had no idea what they were talking about, they eventually talked to a tier 2 techy who said the following

    Quote "There is a known conflict with Windows 7 and McAfee products.Our engineers are working on it and they will fix the issue soon."

    I said "when?" and he said,

    Quote "our engineers are working on the issue and they will fix the issue with in one week." 

    Mark your diary -  a fix should be released through auto update by 27 May 2010. 

    In the meantime, the only way i can use search now is to remove all my document folders from the Win7 index configuration (so that Win7 indexes only emails) and then enter a search term in Windows Explorer, which will, of course, not return any results, then hit the button "custom" (which has a weird pop up message that says "Search a Custom Scope" - English was clearly not the first language of the engineer that coded THAT message!) and then specify the folder that I want to search.  THAT kicks off a manual search of the target folder, that does return all expected results.  Its a bit slow and clumsy but it is a reasonable workaround if McAfee's timeline for a fix is to be believed.  If there is no solution in a week, given that this has been going on for so long, then it is time to dump McAffee and go back to Norton ... unless there is a better product .... ?

    Best

    Dan

    Friday, May 21, 2010 5:33 AM
  • Dan,

    You'll find Microsoft Security Essentials + Windows 7 firewall to be more than adequate until McAfee notifies you of the fix. And it's free.

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=e1605e70-9649-4a87-8532-33d813687a7f

    You can also test one or more of these providers using a trial version to have security software while you waiting:

    http://www.microsoft.com/windows/antivirus-partners/windows-7.aspx

     

     

    Friday, May 21, 2010 10:29 AM
  • Having problems with my search too, though it's not that that no results are returned. Instead, what I'm getting are like 'Programs', 'Control Panel', 'Documents' etc. of which the icons are white colored folders. Tried the different options of 'Search with public folders' and 'Search without public folders', and unchecking and re-checking 'Search programs and Control Panel' but it still doesn't work.
    Tuesday, May 25, 2010 2:12 AM
  • Oops. Realized I didn't read the topic fully. My problem is not related to Windows+F but rather at the 'Search programs and files' box in the Start menu. So guess it's different.
    Tuesday, May 25, 2010 8:15 AM
  • Found this thread because I had the identical problem of WIndows 7 Search not finding file or contents unless they had been manually opened. Also using McAfee. Indexing said it was complete, with 294 items!

    However, since I had just done a clean install and copied files back on with Sync, I wondered if the 'manual opening' thing somehow indicated that the system hadn't properly recognized the files were there in some way.

    To check I changed the permissions on a file, applied, and then changed the permission back. Lo and behold, the file instantly appeared in the index. So I changed the permissions for my user on My Documents - just set it to not list files - applied and then changed back without closing the dialogue. Just over 100 files added to the index. Unindexed files still apear if opened manually.

    I'm now wondering what I can do to make the system recognize _all_ the files...

    Argel

    Wednesday, September 29, 2010 11:07 AM
  • Hi All,

    This is a strange problem. I could only find one reference to the no results issue. It is related to the permissions being lost. Here's a few of ideas to try:

    1. Temporarily disable the security\anti-virus software and try a search-any results? (rule out that blocking access for some reason)

    2. Boot to the installation DVD and select the repair option-confirm that nothing is corrupted

    3. Finally, the permissions fix. I would check the entire C:\ folder or drive permissions

    When I search in a specific folder, nothing is found.

    For files to be indexed, the folder containing the files must have SYSTEM permissions. These may have been removed.

    To troubleshoot this, do the following:

    1. Right-click the folder which is not returning results.

    2. Select the Properties option.

    3. Click the Security tab.

    4. If SYSTEM appears in the Group or user names box, system permissions is not the problem.

    5. If SYSTEM does not appear in the Group or user names box, click the Edit… button to open the Permissions dialog.

    6. In the Permissions dialog, click the Add… button.

    7. In the Select Users, Computers, Service Accounts, or Groups dialog, enter system in the Enter the object names to select box and click the Check Names button.

    8. Select SYSTEM from the list of Matching names and click OK.


    Cool!  It worked for me!

    I had one folder (perhaps there are more) that I used to be able to search, but lately gave NO results whatsoever. The above procedure fixed the problem. I still don't know why this folder suddenly lost the ability to be searched.

    Thanks,

    Sanberdino

    Thursday, July 28, 2011 1:14 AM
  • I agree that the problem is with the permissions level. I use MS's Security program for virus protection so McAfee isn't my problem. Also, since MS's Outlook program uses Window Search service it is affected by the problem too. The only message that I have recieved while trying to use window search is in Outlook. "Access Denied". In Windows Explorer no error or informational messages are given. If I select "give more results" when I try to search for a program or file in the Start  Menu "Search program and file" window I get a message saying that I don't have appropriate permission to access....

    I have check the access permission of my folders and all looks ok.

    This problem needs more attention by Microsoft than it is getting.

    Bob

    Wednesday, August 10, 2011 10:48 PM
  • Just out of interest i have indexing turned off for my local hard drive and searching locally works perfectly!!?
    • Proposed as answer by Total Control Friday, August 16, 2013 3:24 PM
    • Unproposed as answer by Total Control Friday, August 16, 2013 3:24 PM
    Wednesday, April 04, 2012 10:25 AM
  • I did an awfully simple thing - In Taskbar and Start Menu properties, under Start Menu customize, I ticked the box Search with Public Folders. I remembered I unticked that box earlier on. Now I do get search results.
    Sunday, October 07, 2012 7:21 AM