none
exe file association problem ... help

    Question

  • Hi.. somehow I managed to associate exe files with my Inetexplorer browser. How can I change it back ?? ANY help would be appreciated.

     

    Thanks

    Al  Turcotte

     

    Saturday, January 06, 2007 4:32 PM

Answers

  • Thanks for the reply..I had to get this one going that same night.  I ended up doing the following to restore the association after Intuit's download manager screwed things up.

    * Reboot in safe mode (with command prompt) by tapping on F8 key during restart
    * In the command prompt, navigate to the following file (you may need to refresh your dos command prompt skills):

    c/windows/system32/restore/rstrui.exe

    * Run a restore and thank the computer gods for this one.

     

    Tuesday, February 20, 2007 1:35 AM

All replies

  • I have the same problem. While trying to download an application I suddenly lost the file association and all .exe files are associated to internet explorer.

    I checked the registry with a 3rd party app (renamed the extention to .com) and the association information is intact.

    If I create a new user and log in using that account the association is correct.

    • Proposed as answer by less-ley Friday, January 21, 2011 9:15 AM
    Monday, January 08, 2007 6:33 AM
  • Get into the folder properties just like xp and change them back.

    Glenn
    Thursday, January 11, 2007 7:26 PM
  • I have the same problem.
    what I did wrong was once I had to download anti-virus program at; 
    ftp.kaspersky.com/utils/getsysteminfo/GetSystemInfo.exe

    and a box poped up asking which program I wished it to run with. I chose Firefox and as soon as I associated it, all my .exe file associations were altered.

    How can I change .exe associations back to originals.
    For example how can I associate quickbooks file (QBW32.exe)  with what?
    Thanks,
    Lewis

    Tuesday, February 06, 2007 5:33 PM
  • I've got the same problem except every .exe file opens windows media player. I can find where to change other associations but not where to change associations for the .exe files. any help would be appreciated
    Friday, February 09, 2007 3:57 AM
  • Me too!!  I have searched and tried just about everything I know.  Help!

     

    UPDATE!!!!!

    I fixed it!!  You have to restart in "Safe Mode, Command prompt only".  Once you do this, you can run regedit.  After opening the editor, drill down to the this location and place these entries there.


    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe]
    @="exefile"
    "ContentType"="application/x-msdownload"

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\OpenWithProgids]
    "exefile"=hex(0):

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.exe\PersistentHandler]
    @="{098f2470-bae0-11cd-b579-08002b30bfeb}"

    After you set these in the registry, you can exit and restart.  Hopefully that works.  I nosed around alot so I think this is all I did.  Let me know if this didn't fix it.

    Saturday, February 10, 2007 12:15 PM
  • Ok, this has really got me frustrated.  I just brought home a brand new computer and was re-loading software.  It seems the culprit here is a download manager from Intuit (Quickbooks).  Anyway, I'm looking up at the post above (by the way, I'm on Visa - Ultimate) and I restarted in safe mode, got to the registry, and I think I need a little more help.

    Once I'm in the registry I see the following:
    ...

    ..\.exe
    --OpenWithList [3 strings here: (Default), a, MRUList]
    --OpenWithProgids [2 strings here: (Default), exefile]
    --UserChoice [2 strings here: (Default), Progid]

    Question 1: I do not see ...\.exe\PersistenHandler, should this be there or should I use one of the above items?
    Question 2: I don't do much registry editing, so what do you mean by "place these entries there"?

    I see two locations where the 'iexplore.exe' is mentioned.  They are at:

    --OpenWithList, at a string called "a", and in the "Value Data" field it says: "iexplore.exe" (without the quotes)

    --UserChoice, at a string called "Progid", and in the "Value Data" field it says: "Applications\iexplore.exe" (without the quotes)

    I'm not sure what to do here but it seems like you know what you're doing so if you could provide a little more detail for me that would be fantastic.

    Jim

    Monday, February 12, 2007 6:24 AM
  • Here is what I did and it works for me in Windows Vista Business and it works for me.

    Question 1: You can add a key there and then add a value (@) in that key using expandable string.

    Right Click the Right Window, choose key, type "PersistentHandler", then highlight the new key by left click it on the left panel, then right click right window, choose expandable string, then enter "{098f2470-11cd-b579-08002b30bfeb}" for the value and change the name to "@".

    // comment: -  @ = {098f2470-11cd-b579-08002b30bfeb}

    Question 2: explained above.

    OpenWithList: change the value in "a" to "exefile"

    delete "userchoice" key.

    now Click .exe key in the left panel, add two values:

    @ = "exefile"

    ContentType = "application/x-msdownload"

    restart computer.

    I hope this works for you.

     

    Chen

    McMaster Unviersity - Comp Eng 3rd Year

     

     

    Monday, February 19, 2007 8:49 PM
  • Thanks for the reply..I had to get this one going that same night.  I ended up doing the following to restore the association after Intuit's download manager screwed things up.

    * Reboot in safe mode (with command prompt) by tapping on F8 key during restart
    * In the command prompt, navigate to the following file (you may need to refresh your dos command prompt skills):

    c/windows/system32/restore/rstrui.exe

    * Run a restore and thank the computer gods for this one.

     

    Tuesday, February 20, 2007 1:35 AM
  • How do yu get into the registry editor.  When I try since my the exe association is incorrect (Assigned to IE), IE opens not regedit.

     

    I booted into safe mode and the same thing happens.

    Thursday, February 22, 2007 12:23 AM
  • Ditto on the Intuit thing. Why in the world would it not know to open an exe normally and instead ask us what we want to open it with.. and on top of that, set all exes to open with the selected program.. totally crappy....
    Friday, February 23, 2007 1:00 AM
  • Thanks for the solution! I just ran into this problem yesterday evening...Yes it was due to a quickbooks download onto Vista. I lost a day of business dealing with this problem. Thanks for the help and the knowledge that I wasnt alone.
    Wednesday, February 28, 2007 9:18 PM
  • Here is another solution to the exe file assocation problem.

    http://jtbworld.blogspot.com/2007/03/have-you-lost-your-exe-file-extension.html

    Wednesday, March 07, 2007 6:50 PM
  • All you people who got misled on the Quickbooks Pro 2007 downloader that associates .exe files with something else, this is the easiest fix.  If you, Jimmy, are jtbworld - thank you, thank you, thank you.
    Tuesday, March 13, 2007 8:46 PM
  • You're welcome sandradee.

    Jimmy Bergmark

    JTB World

    Wednesday, March 14, 2007 10:16 AM
  • The JTB World fix worked perfectly! Thanks, Jimmy.

    My ".exe" files were associated with IE. It did this with an Active X download manager. This is a ridiculous problem that Microsoft needs to fix, BTW!

    There may be an easier way, but here's how I did it with Vista Business.

    • Started the OS in safe mode.
    • Using another PC, I downloaded the ".reg" files from JTB World to a USB memory stick.
    • In safe mode, I went to the start menu and found "cmd.exe", right-clicked and from the context menu, Properties, Open File Location. Using right-click, I copied the file from that location and pasted it to the desktop, then I renamed the extension to ".com" so it would run.
    • Once I had the Command window open, I plugged in the memory stick and navigated to the drive, where I was able to run the reg files.

    This was a potential nightmare so I hope others can use this information! Thanks again.

    Saturday, March 17, 2007 3:44 AM
  • I had the same problem --

    1) Right clicked on the Quickbooks Desktop icon and selected properties

    2) Looked under the compatablity tab and checked off Run this program in compatibility mode for WINDOWS 98 / WINDOWS ME

     

    This is contrary to what was written on the Quickbooks (Inuit) website. They asked to select Windows XP (Service Pack 2) -- this actually dissociates the .qpg files and Windows vista won't display the navigation pages within the program.

     

    Good luck !

     

     

    Friday, December 07, 2007 10:57 PM
  • None of my EXE files execute...box says no file association exists for this type of file.  Apps will execute if I click on a created file (eg., a DOC file will open MS WORD which otherwise can't be opened directly or with a shortcut).  Any suggestions?

    Tuesday, December 25, 2007 3:09 PM
  • there is a reg fix in this link.  download the zip file, double click the reg file and BAM - fixed

     

    http://www.dougknox.com/xp/file_assoc.htm

    Monday, January 21, 2008 1:14 PM
  •  

    Saturday, November 15, 2008 7:52 PM
  • Copy and Paste:

     

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT\.exe]
    @="exefile"
    "Content Type"="application/x-msdownload"

    [HKEY_CLASSES_ROOT\.exe\PersistentHandler]
    @="{098f2470-bae0-11cd-b579-08002b30bfeb}"

    [HKEY_CLASSES_ROOT\exefile]
    @="Application"
    "EditFlags"=hex:38,07,00,00
    "TileInfo"="prop:FileDescription;Company;FileVersion"
    "InfoTip"="prop:FileDescription;Company;FileVersion;Create;Size"

    [HKEY_CLASSES_ROOT\exefile\DefaultIcon]
    @="%1"

    [HKEY_CLASSES_ROOT\exefile\shell]

    [HKEY_CLASSES_ROOT\exefile\shell\open]
    "EditFlags"=hex:00,00,00,00

    [HKEY_CLASSES_ROOT\exefile\shell\open\command]
    @="\"%1\" %*"

    [HKEY_CLASSES_ROOT\exefile\shell\runas]

    [HKEY_CLASSES_ROOT\exefile\shell\runas\command]
    @="\"%1\" %*"

    [HKEY_CLASSES_ROOT\exefile\shellex]

    [HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
    @="{86C86720-42A0-1069-A2E8-08002B30309D}"

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PEAnalyser]
    @="{09A63660-16F9-11d0-B1DF-004F56001CA7}"

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\PifProps]
    @="{86F19A00-42A0-1069-A2E9-08002B30309D}"

    [HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
    @="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

     

    Save it into a file and name it EXEFIX.REG.

    If notepad doesn't open, use another computer and transfer with a USB stick.

    Double click it and all will be fine.

    • Proposed as answer by RJCad Thursday, January 05, 2012 2:18 PM
    Saturday, November 15, 2008 7:53 PM
  • "There is a reg fix in this link.  download the zip file, double click the reg file and BAM - fixed"

     

    Many thanks. And my misses' thanks for putting an end to 2 hours of swearing in the wake of a viral infection.

    Wednesday, April 14, 2010 6:38 PM
  • I'm using Vista premium & all the applications(.exe) opens with the Adobe Acrobat reader. If anyone know a solution please reply asap...
    Monday, August 02, 2010 5:55 PM
  • Jimmy,

    Even though this is an old link it fixed my problem in 30 seconds. My files lost their "path" and would not open without me directing them to the location. The problem occurred after my Anti-virus removed a Trojan.

    Thank You so much for the information!!!!

    Thursday, March 31, 2011 4:16 AM
  • quick temp fix if you really need to open an app:   right click the exe or lnk icon and select "open with" then navigate to the correct exe!  E.G.  trying to open word:  right click the icon, select open with and then browse to the word.exe file in "program files\microsoft office .....

    ie open the app with itself!

    Monday, October 31, 2011 7:00 PM
  • Thanks..  All is fine!
    Thursday, January 05, 2012 2:19 PM
  • JTB fix #2 worked great.  I am running Windows 7 Home and all .exe's opened Windows Media Center.  Easiest, fastest fix I've ever experienced.  Thanks Jimmy.

    Diana

    Thursday, December 13, 2012 7:12 AM
  • thanks dude this above text  is helpful  for me
    Saturday, February 22, 2014 1:18 PM